LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Crazy Problems with XkbLayout (http://www.linuxquestions.org/questions/slackware-14/crazy-problems-with-xkblayout-4175432169/)

thomasf 10-14-2012 01:36 PM

Crazy Problems with XkbLayout
 
Hello

I use Slackware64 14.0 with NVIDIA-Linux-x86_64-304.51

I have copied the 90-keybord-layout.conf from /usr/share/X11/xorg.conf.d to /etc/X11/xorg.conf.d and edit "XkbLayout" from us to "de"

The /etc/X11/xorg.conf(created from Nvidia-Installer) have copied in /etc/X11/xorg.conf.d/20-nvidia.conf and modified. Only Section Monitor, Device and Screen is in this file.

The Xorg.0.log says
8.534] (**) Option "xkb_rules" "evdev"
[ 1028.534] (**) Option "xkb_model" "evdev"
[ 1028.534] (**) Option "xkb_layout" "de"
[ 1028.534] (**) Option "xkb_variant" "qwertz"
[ 1028.534] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"

are it works absolutely not.

My Login Manager is Slim , here is false ... The Desktop is E17 and is false (Slackbuilds from slackbuilds.org)

In 13.37 its All OK for Slim and E17 and all Programs with the 90-keybord-layout.conf

I have no Idea more
Its Magic

Greetings and sorry for my chaotical English.
Thomas

bathory 10-15-2012 09:34 AM

Quote:

[ 1028.534] (**) Option "xkb_variant" "qwertz"
Perhaps of the error (typo?) above?
It should read
Code:

Option "xkb_variant" "qwerty"

thomasf 10-16-2012 04:00 AM

Thats right , here in Germany is qwertz :)

I have last tested with this option , but no change

I have Multilib installed .. maybe is this the Problem

Thomas

lambo69 10-16-2012 06:21 AM

I had the same problem with xdm, putting
Code:

setxkbmap de
in its startup or setup script worked for me.

jtsn 10-16-2012 07:19 AM

The XkbVariant option and the other stuff isn't needed, just put the following into /etc/X11/xorg.conf.d/keymap.conf:

Code:

Section "InputClass"
    Identifier      "Keyboard0"
    MatchIsKeyboard "True"
    Option          "XkbLayout" "de"
EndSection


thomasf 10-16-2012 03:39 PM

@lambo69

Wondefull :)
I have edit (to test) the xinitrc.twm "usr/bin/setxkbmap de & " ... it works :)

@jtn
Thatīs the Problem ... the File for Keyboard in /etc/X11/xorg.conf.d/ is completely ignored.
I have tested with all Options (with/without qwertz,nodeadkeys XkbLayout with and without XkbVariant) ... in /etc/X11/xorg.conf and in the .d/Directory
Nothing ... completely ignored.

Maybe comes from the newest Nvidia-Driver.

Thanks all for the Help
Greating Thomas

jtsn 10-17-2012 04:37 AM

Maybe it isn't ignored, but set to something different by your non-Slackware display manager or desktop environment. Try to revert to xdm and twm and post a complete xorg.conf and Xorg.0.log

thomasf 10-17-2012 05:29 AM

I have new installed.
At the Moment , is SLim no installed. Is the same, only the Trick with setxkbmap de X-Start had helped. The 90-xkeyboard.conf brings no effect .... only the Trick with setxkbmap de in xinitrc had helped.

I use my Laptop in the Moment. I poste later the Xorg.log

Thomas

jinnz 10-19-2012 10:16 AM

advice
 
Quote:

Originally Posted by thomasf (Post 4805501)
Hello

I use Slackware64 14.0 with NVIDIA-Linux-x86_64-304.51

I have copied the 90-keybord-layout.conf from /usr/share/X11/xorg.conf.d to /etc/X11/xorg.conf.d and edit "XkbLayout" from us to "de"

The /etc/X11/xorg.conf(created from Nvidia-Installer) have copied in /etc/X11/xorg.conf.d/20-nvidia.conf and modified. Only Section Monitor, Device and Screen is in this file.

The Xorg.0.log says
8.534] (**) Option "xkb_rules" "evdev"
[ 1028.534] (**) Option "xkb_model" "evdev"
[ 1028.534] (**) Option "xkb_layout" "de"
[ 1028.534] (**) Option "xkb_variant" "qwertz"
[ 1028.534] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"

are it works absolutely not.

My Login Manager is Slim , here is false ... The Desktop is E17 and is false (Slackbuilds from slackbuilds.org)

In 13.37 its All OK for Slim and E17 and all Programs with the 90-keybord-layout.conf

I have no Idea more
Its Magic

Greetings and sorry for my chaotical English.
Thomas

Hello!
You needed write that also in /etc/X11/xorg.conf.
Also append Option "Device" "/dev/input/event0"
else attempt:
Option "xkb_variant" ",winkeys", comma needed.
Ukraine

jinnz 10-19-2012 06:25 PM

Section "InputDevice"
Identifier "Keyboard0"
Driver "evdev"
Option "AutoServerLayout" "on"
Option "Device" "/dev/input/event0"
Option "XkbRules" "evdev"
Option "XkbModel" "evdev"
Option "XkbLayout" "us,de"
Option "XkbVariant" ",winkeys"
Option "XkbOptions" "terminate:ctrl_alt_bksp,grp:alt_shift_toggle,grp_led:scroll"
EndSection


All times are GMT -5. The time now is 01:58 AM.