LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 07-05-2012, 01:58 PM   #46
Kallaste
Member
 
Registered: Nov 2011
Distribution: Slackware
Posts: 344

Original Poster
Rep: Reputation: 84

Here is my lilo.conf. The vesa options are all there. I have an option to choose between the VESA modes at start-up, but it defaults to standard if I wait 30 seconds without making a choice.

I am going to go read man xorg.conf, because there is something I don't quite understand about the video.conf file. Namely, why is it needed to be sure the Intel driver is used by X? That is, what other drivers are there that X has to choose from, and why would it do so if the Intel driver is available?

Thank you!
Attached Files
File Type: txt lilo-conf.txt (1.8 KB, 4 views)
 
Old 07-05-2012, 02:22 PM   #47
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad W520
Posts: 4,679

Rep: Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240
Ok, I understand now what you meant writing "I choose between 20 or so of them at every start-up". My excuse being that English is a second language for me

EDIT Forgot to tell that the file CHANGES_AND_HINTS.TXT in the root of a Slackware mirror tree or a Slackware DVD explains how Xorg is configured in Slackware so in your case if not already done it's a _must_read_. In the same vein have a look at /usr/share/X11/xorg.conf.d/50-synaptics.conf.

Last edited by Didier Spaier; 07-05-2012 at 03:07 PM.
 
1 members found this post helpful.
Old 07-05-2012, 03:34 PM   #48
Kallaste
Member
 
Registered: Nov 2011
Distribution: Slackware
Posts: 344

Original Poster
Rep: Reputation: 84
Okay, I will look at them, thanks. And sorry, I should have been more clear about the vesa thing. I just always assume you Slackware people know everything!
 
Old 07-06-2012, 09:17 AM   #49
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad W520
Posts: 4,679

Rep: Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240
I have investigated a bit about graphic processor switching.

The result is the text in appended file.

I intend to post it in a new thread because it's really a different topic than this thread's, but would like you to read, test and comment it before.

I ask you that because my laptop doesn't include a hybrid graphic sub system, thus I can't make any test to check the accuracy of what I wrote.

I am not in a hurry, so do it when you can.

Thanks in advance,
Attached Files
File Type: txt switcheroo.txt (5.6 KB, 2 views)

Last edited by Didier Spaier; 07-08-2012 at 01:31 AM. Reason: Wrong comand in appended file corrected
 
Old 07-06-2012, 10:03 AM   #50
Kallaste
Member
 
Registered: Nov 2011
Distribution: Slackware
Posts: 344

Original Poster
Rep: Reputation: 84
I will do this today by late this afternoon. I have some errands to run, and some hardware problems on my main computer to deal with, but I am enjoying learning in this fashion and will get to it soon.

Also, I have been busy reading, and I have some questions I hope you can answer for me.
 
Old 07-06-2012, 06:09 PM   #51
Kallaste
Member
 
Registered: Nov 2011
Distribution: Slackware
Posts: 344

Original Poster
Rep: Reputation: 84
Well, I tried every option I could, but I'm afraid I didn't really have much luck. First, I found that my computer (HP Pavilion dv6t-3000) does not have an option to configure the graphics processors from the BIOS. However, there was a BIOS update that according to user forums was supposed to support this functionality, and as I was wanting to flash the BIOS anyway, I thought I would try it. So I updated. Unfortunately, the users were wrong, and the new BIOS still does not let me change the graphics processors. So I was not able to see the output of lspci with one turned off.

However, I was able to attempt many other functions, and I will give them to you step by step. The beginning I did in X, but then I logged out to attempt the switching operations.

Code:
lspci | grep VGA
shows I have two graphics processors. Good.

However, after

Code:
grep switcheroo /var/log/messages
Instead of just one line of output, I get multiple lines of the same output with different timestamps:

Code:
bash-4.1# grep switcheroo /var/log/messages
Jul  4 12:44:00 darkstar kernel: [    8.609135] VGA switcheroo: detected switching method \_SB_.PCI0.GFX0.ATPX handle
Jul  4 12:44:00 darkstar kernel: [    8.663401] vga_switcheroo: enabled
Jul  4 13:40:14 darkstar kernel: [    8.458275] VGA switcheroo: detected switching method \_SB_.PCI0.GFX0.ATPX handle
Jul  4 13:40:14 darkstar kernel: [    8.945319] vga_switcheroo: enabled
Jul  4 17:19:52 darkstar kernel: [    7.872232] VGA switcheroo: detected switching method \_SB_.PCI0.GFX0.ATPX handle
Jul  4 17:19:52 darkstar kernel: [    8.003157] vga_switcheroo: enabled
Jul  4 20:06:24 darkstar kernel: [    8.103164] VGA switcheroo: detected switching method \_SB_.PCI0.GFX0.ATPX handle
Jul  4 20:06:24 darkstar kernel: [    9.653912] vga_switcheroo: enabled
Jul  4 21:07:07 darkstar kernel: [   16.083738] VGA switcheroo: detected switching method \_SB_.PCI0.GFX0.ATPX handle
Jul  4 21:07:07 darkstar kernel: [   16.206924] vga_switcheroo: enabled
Jul  5 07:39:12 darkstar kernel: [   16.723562] VGA switcheroo: detected switching method \_SB_.PCI0.GFX0.ATPX handle
Jul  5 07:39:12 darkstar kernel: [   17.389422] vga_switcheroo: enabled
Jul  5 08:11:55 darkstar kernel: [   15.390994] VGA switcheroo: detected switching method \_SB_.PCI0.GFX0.ATPX handle
Jul  5 08:11:55 darkstar kernel: [   20.210988] vga_switcheroo: enabled
Jul  5 08:14:12 darkstar kernel: [   17.423704] VGA switcheroo: detected switching method \_SB_.PCI0.GFX0.ATPX handle
Jul  5 08:14:12 darkstar kernel: [   17.534583] vga_switcheroo: enabled
Jul  5 13:14:28 darkstar kernel: [    7.958422] VGA switcheroo: detected switching method \_SB_.PCI0.GFX0.ATPX handle
Jul  5 13:14:28 darkstar kernel: [    8.466828] vga_switcheroo: enabled
Jul  5 13:25:54 darkstar kernel: [   17.554775] VGA switcheroo: detected switching method \_SB_.PCI0.GFX0.ATPX handle
Jul  5 13:25:54 darkstar kernel: [   17.671190] vga_switcheroo: enabled
Jul  5 18:07:58 darkstar kernel: [   17.091267] VGA switcheroo: detected switching method \_SB_.PCI0.GFX0.ATPX handle
Jul  5 18:07:58 darkstar kernel: [   17.601919] vga_switcheroo: enabled
Jul  6 13:18:30 darkstar kernel: [    7.760099] VGA switcheroo: detected switching method \_SB_.PCI0.GFX0.ATPX handle
Jul  6 13:18:30 darkstar kernel: [    7.971680] vga_switcheroo: enabled
Jul  6 13:21:30 darkstar kernel: [    8.055365] VGA switcheroo: detected switching method \_SB_.PCI0.GFX0.ATPX handle
Jul  6 13:21:30 darkstar kernel: [    8.063594] vga_switcheroo: enabled
Also, when I do

Code:
cat /sys/kernel/debug/vgaswitcheroo/switch
I do not have the output

Code:
0:IGD:+:Pwr:0000:00:02.0
1:DIS: :Pwr:0000:01:00.0
Instead, my output looks like

Code:
0:+:Pwr:0000:00:02.0
1: :Pwr:0000:01:00.0
So it is basically the same except without the nice labels.

And this is where I logged out of X.

In the raw console, I tried

Code:
echo DIS /sys/kernel/debug/vgaswitcheroo/switch
but

Code:
cat /sys/kernel/debug/vgaswitcheroo/switch
showed that nothing had changed. I restarted X (even though I know this is the one that should be immediate) and still no change.

I thought maybe I had to turn on the inactive card first, so I entered

Code:
echo ON /sys/kernel/debug/vgaswitcheroo/switch
It told me:

Code:
ON /sys/kernel/debug/vgaswitcheroo/switch
But the output of

Code:
cat /sys/kernel/debug/vgaswitcheroo/switch
was exactly the same. (I don't know what change I expected here because I'm not sure what the numbers represent, but I expected some change).

I tried the DIS command again, and still the result of my query to the state of the graphics processors remained unchanged. To see if it would matter, I rebooted at this time. Still no change.

Finally, I tried

Code:
echo MDIS /sys/kernel/debug/vgaswitcheroo/switch
and rebooted. Still, no change.

Perhaps I did something wrong?

As for my hardware problems, I have been doing a lot of reading, but perhaps not very much understanding. I was wondering about what you said about creating an xorg.conf (or video.conf) file to make sure X uses the Intel driver. I do not really understand this because earlier, when we saw

Code:
bash-4.1$ grep _drv.so *Xorg.0.log 
problemXorg.0.log:[   155.850] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
problemXorg.0.log:[   155.850] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
problemXorg.0.log:[   156.090] (II) Unloading /usr/lib64/xorg/modules/drivers/vesa_drv.so
problemXorg.0.log:[   156.232] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
problemXorg.0.log:[   156.353] (II) Loading /usr/lib64/xorg/modules/input/synaptics_drv.so
tpWorking-Xorg.0.log:[   236.655] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
tpWorking-Xorg.0.log:[   236.686] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
tpWorking-Xorg.0.log:[   237.065] (II) Unloading /usr/lib64/xorg/modules/drivers/vesa_drv.so
tpWorking-Xorg.0.log:[   237.679] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
bash-4.1$
I thought this meant that the vesa driver was being unloaded because the Intel driver was overriding it and so X was already using the Intel driver. Is this not correct?

I do know that something is not right, however, because I have started noticing another issue where frequently when I try to start x, my computer freezes at a black screen so that a hard reset is required. Between this problem, the almost constant boot freezes, and the impossible mouse I am starting to pull my hair out.

Might any of these problems might be solved by switching to the 32 bit Slackware?

Thank you for your help!
 
1 members found this post helpful.
Old 07-07-2012, 06:32 PM   #52
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad W520
Posts: 4,679

Rep: Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240
I will answer step by step.

I don't know why you do not have the nice labels in 'cat /sys/kernel/debug/vgaswitcheroo/switch' output.

The reason why you have multiple lines of the same output in /var/log/messages could simply be that you get these at each reboot.

The fact that all commands you tried seem to have no effect could unfortunately mean that switcheroo can't handle your device.

lspci identifies your ATI GPU as "Mobility Radeon HD 5000 Series", that is to say according to this page an "evergreen" model.

But the Radeon Feature page of the X.org website says for this device type:
Quote:
6 There are two versions of hybrd graphics: MUXed and MUX-less. MUXed have a display MUX to switch the displays between the discrete and integrated cards. MUXed systems can be switched using vgaswitcheroo. MUX-less do not have a display MUX and the displays are only connected to the integrated card. On MUX-less systems, the discrete card is solely for rendering, not display. At the moment the X server does not support rendering and display from different cards so the discrete card can not be used with MUX-less systems at the moment. Most new laptops (2011+) are MUX-less.
So I'm afraid your specific device be a MUX-less one.

If this is the case that could explain why, though the radeon kernel driver be in use (as 'lsmod' shows), under X the Intel driver be used instead, that is to say the Intel graphics device could be used for both rendering and displaying.

So far, so bad

Maybe, at least switcheroo can allow you to switch off the ATI GPU in order to increase battery life if you type:
Code:
echo OFF > /sys/kernel/debug/vgaswitcheroo/switch
But I am not too optimistic about that either...

Their is a hope, though that you can enhance the situation if you use a closed source ATI (or AMD) driver called fglrx.

If you want to try do this:
1) Get the driver here (it is really an archive containing many files as well as a "sh" script)
2) The driver includes what is needed to make a slackware package, that you will be able to install with "installpkg"
As root, type:
Code:
sh amd-driver-installer-12-6-x86.x86_64.run --buildpkg Slackware
then once the package is built:
Code:
installpkg fglrx-8.98-*tgz
You will have to modify the X server configuration after that, the "aticonfig" utility will help you to do that.

To know more about this driver, simply type:
Code:
sh amd-driver-installer-12-6-x86.x86_64.run -h
the amd-driver-installer-12-6-x86.x86_64.run bundle include a Slackbuild provided by distinguished members of the Italian Slackware Community

I don't think that switching to 32 bit Slackware will help. At least I checked that the Slackbuild included in the closed source bundle will detect your architecture and compile the driver accordingly.

In the hope to have less problems at boot, you could simply blacklist the radeon module. For that simply add this line at the end of /etc/modprobe.d/blacklist.conf:
Code:
blacklist radeon
If you still have video related problems I suggest you open a specific thread, so that more people notice it.

I probably won't follow my idea to begin a specific thread about switcheroo, as I realize that there are so many different hybrid graphic devices, among which some can make use of it and others not, that it could be more confusing than helpful.

If I have another idea for your touchpad, I will let you know tomorrow.

Last edited by Didier Spaier; 07-07-2012 at 06:58 PM. Reason: Command "echo" corrected
 
2 members found this post helpful.
Old 07-07-2012, 06:52 PM   #53
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,298

Rep: Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722
It should be
Code:
echo ON > /sys/kernel/debug/vgaswitcheroo/switch
with the redirect (>); otherwise you're just echoing the name of the file instead of changing its contents. Then a `cat` of the file should get different results. I don't know if this will make a difference -- I just thought I'd point out one possible error.
 
2 members found this post helpful.
Old 07-07-2012, 06:56 PM   #54
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad W520
Posts: 4,679

Rep: Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240
@T3slider: Fixed, thanks.

EDIT Probably you were writing about last post for BloomingNutria (as well).

I just checked the file "switcheroo.txt" I appended in a previous post in this thread and saw I missed the ">" (now corrected), so that's entirely my fault, sorry about that

So please BloomingNutria tell us if you in fact typed the right or the wrong commands. In the later case my assumption about switcheroo not being able to handle your ATI GPU could be fully wrong

Last edited by Didier Spaier; 07-08-2012 at 02:14 PM. Reason: s/from/for/ Oh, well...
 
Old 07-08-2012, 07:56 AM   #55
Kallaste
Member
 
Registered: Nov 2011
Distribution: Slackware
Posts: 344

Original Poster
Rep: Reputation: 84
I followed the instructions exactly, so I typed the wrong commands. I will try again today.
 
Old 07-08-2012, 01:18 PM   #56
Kallaste
Member
 
Registered: Nov 2011
Distribution: Slackware
Posts: 344

Original Poster
Rep: Reputation: 84
Well, the switcheroo function does work. I was able to switch to the discrete graphics card. However, while trying to test the MDIS function, I have lost the ability to boot. (Or more probably, it is booting and I just cannot see it ) At any rate, it gets about halfway through the boot process and I get a black screen. Ctrl + Alt + Del restarts it. This used to happen to me about 50 % of the time before, but now I have rebooted about ten times and I can't get past it. Drat.

I think I am going to reinstall Slackware 32 bit tomorrow (since I was wanting to do it anyway) and see if the hardware gods smile on me. It may be unlikely to help, but as things stand now, I might as well!

If the same difficulties persist into the new installation, I will eventually open another thread for my black screen while booting and starting X problem, since I don't think the switching function will help with that. It also doesn't appear to help with the fuzziness issue. Still, it is good to have the option to switch between cards when I need to and I am thankful you took the time to find out how.

I will leave this thread open for my mouse problem, since that is my greatest source of irritation at the moment and the issue I want to work through first, after a short break.

Thank you for all the time you have spent working on this with me, as well as the instructive quality of your posts.
 
Old 07-08-2012, 03:38 PM   #57
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad W520
Posts: 4,679

Rep: Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240
Quote:
Originally Posted by BloomingNutria View Post
At any rate, it gets about halfway through the boot process and I get a black screen.
As you can reboot with Ctrl+Alt+Del at least the keyboard is still working.

You could try one of following tricks:
1) Probably you get a black screen when the radeon frame buffer driver takes over the console (this is called the "handover"). If that is the case you can disable kernel mode settings (KMS) at boot time. To do that, when lilo's greeting screen is displayed, select your kernel then instead of hitting Enter hit Tab. Then add to the command line a space character then either:
Code:
radeon.modeset=0
or if it you still can't boot:
Code:
nomodeset
then hit Enter.

2) Wait till you guess the boot sequence is finished (allow enough time, or wait until there is no more sign of HDD activity) then login blindly and, still blindly, type 'startx' -- I suppose that your system is set up to start at run level 3.

3) Start with vga=normal. But I guess you already tried this one.

If you use the trick #1, maybe you won't be be able to use switcheroo but that's not lethal

Anyhow, once you can get into your system, blacklisting radeon could help.

About switcheroo it's possible that you got in trouble after using the MDIS function because this function was not yet implemented in the driver version shipped with kernel 2.6.37 and the error handling in switheroo.c was not perfect (yet): this function was implemented in the 2.6.38 kernel (there is one in /testing in Slackware 13.37).

If you want to reinstall maybe you could try Slackware-current as it includes more recent kernels (version 3.2.21 at time of writing) as well as more recent components of the X stack.

Last edited by Didier Spaier; 07-09-2012 at 12:39 AM. Reason: s/frame buffer console/frame buffer driver/
 
1 members found this post helpful.
  


Reply

Tags
mouse


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mouse cursor jumping erratically + takes clicking action when not moved? JZL240I-U Linux - Software 23 04-30-2008 09:54 AM
mouse cursor goes crazy during network activity TMKroeger Linux - General 0 03-12-2006 07:39 PM
Belkin KDM & MS scoll mouse solution (jumping mouse) otchie1 Linux - Hardware 2 03-02-2006 02:16 PM
startx on Debian gives grey background - cannot move mouse cursor or type fdac Linux - Newbie 7 05-04-2005 04:11 PM
(STRANGE) Mouse get's crazy when holding a key and moving mouse(Update to 2.6.10) the-copy Linux - Hardware 2 02-08-2005 01:07 PM


All times are GMT -5. The time now is 03:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration