LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 07-03-2012, 11:41 AM   #31
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware-14.0 on a Lenovo T61 6457-4XG
Posts: 3,651

Rep: Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828

Well, in the working Xorg.0.log the synaptics driver is not used at all. Instead, the touchpad is taken care of by the generic evdev driver, but only as a generic mouse. This probably explain why you can't scroll with it. FYI modules names end in _drv.so, so that's easy to check:
Code:
bash-4.1$ grep _drv.so *Xorg.0.log 
problemXorg.0.log:[   155.850] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
problemXorg.0.log:[   155.850] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
problemXorg.0.log:[   156.090] (II) Unloading /usr/lib64/xorg/modules/drivers/vesa_drv.so
problemXorg.0.log:[   156.232] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
problemXorg.0.log:[   156.353] (II) Loading /usr/lib64/xorg/modules/input/synaptics_drv.so
tpWorking-Xorg.0.log:[   236.655] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
tpWorking-Xorg.0.log:[   236.686] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
tpWorking-Xorg.0.log:[   237.065] (II) Unloading /usr/lib64/xorg/modules/drivers/vesa_drv.so
tpWorking-Xorg.0.log:[   237.679] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
bash-4.1$
The reason you have the line ending in 'InputClass "touchpad"' in the "bad" log is that in this case your touchpad is recognized as a 'SynPS/2 Synaptics TouchPad' (two lines above in the log) not as a '"PS/2 Synaptics TouchPad" (type: MOUSE)' like it is in the "good" log. This is normal and you shouldn't worry about the "bad" log showing two InputClass lines: a device can be associated to several InputClasses.

So at this point of time my guess is that even the 1.6.2 version of your xf86-video-thinkpad driver... Doesn't drive so well your touchpad

Oh, and don't worry about unloading of the vesa video module: the intel video module takes precedence and that's normal as it is more specific to your hardware.

PS I didn't notice till your last post that you are running a 64 bit Slackware. But I don't think that change anything.

Last edited by Didier Spaier; 07-03-2012 at 11:43 AM.
 
Old 07-03-2012, 02:18 PM   #32
Kallaste
Member
 
Registered: Nov 2011
Posts: 343

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Didier Spaier View Post
Well, in the working Xorg.0.log the synaptics driver is not used at all. Instead, the touchpad is taken care of by the generic evdev driver, but only as a generic mouse. This probably explain why you can't scroll with it. FYI modules names end in _drv.so, so that's easy to check:
Code:
bash-4.1$ grep _drv.so *Xorg.0.log 
problemXorg.0.log:[   155.850] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
problemXorg.0.log:[   155.850] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
problemXorg.0.log:[   156.090] (II) Unloading /usr/lib64/xorg/modules/drivers/vesa_drv.so
problemXorg.0.log:[   156.232] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
problemXorg.0.log:[   156.353] (II) Loading /usr/lib64/xorg/modules/input/synaptics_drv.so
tpWorking-Xorg.0.log:[   236.655] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
tpWorking-Xorg.0.log:[   236.686] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
tpWorking-Xorg.0.log:[   237.065] (II) Unloading /usr/lib64/xorg/modules/drivers/vesa_drv.so
tpWorking-Xorg.0.log:[   237.679] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
bash-4.1$
Oh, I see, thank you! So my touchpad is un-drivable with current software, then. Oh well, I guess you can't have everything. But I wish the driver gods would fix that.

So, how do I tell it to load the generic evdev driver instead of the Synaptics one, even without the USB mouse plugged in? A non-scrolling touchpad is better than a crazy-jumpy one.

P.S. Yes, sorry I forgot to mention the 64 bit. I think it was a bad choice to install it, and now that I think of it I will probably switch to 32.
 
Old 07-03-2012, 02:44 PM   #33
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware-14.0 on a Lenovo T61 6457-4XG
Posts: 3,651

Rep: Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828
There are probably ways to do that using a config file you would put in /etc/X11/modprobe.d, see "man xorg.conf"

But the simplest way is probably this one:
Code:
removepkg xf86-input-synaptics
If X can't start and you see in Xorg.0.log that there is no core pointer available, come back here and we will find something more sophisticated

In any case the driver is not lost, 'installpkg' or 'slackpkg install' would re-install it for you.

Last edited by Didier Spaier; 07-03-2012 at 02:46 PM.
 
Old 07-03-2012, 04:21 PM   #34
Kallaste
Member
 
Registered: Nov 2011
Posts: 343

Original Poster
Rep: Reputation: Disabled
Oh, my. I removed the package, and even though it is now using the evdev driver, the mouse is worse than ever. It is still jumping around when I try to drag (though scroll still does nothing with this driver), and now, additionally, it is vibrating when I try to move it, or even when I just place my finger on the touchpad without moving. Now I can't even hold it still to click on anything!

Code:
grep _drv.so Xorg.0.log
returns exactly what yours did in the "good" log above, so I surely do not understand it. Unlike before, it does this regardless of whether the USB mouse is plugged in or not.

Maybe I should mention that these mouse troubles have always occurred even before I start X, when I am just in a raw terminal. Does that make any difference?

Thanks.
 
Old 07-03-2012, 04:42 PM   #35
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware-14.0 on a Lenovo T61 6457-4XG
Posts: 3,651

Rep: Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828
Quote:
Originally Posted by BloomingNutria View Post
Maybe I should mention that these mouse troubles have always occurred even before I start X, when I am just in a raw terminal. Does that make any difference?
Of course, as then some kernel driver (not to be confused with an X driver as 'evdev' or 'synaptics') should have a problem driving your touchpad.

To investigate further please first type as root "rm /var/log/messages", then reboot with no mouse plugged in, but do not start X.
1) Type 'lsmod | sort' in a raw terminal and append the output to your next post (the "|" sign is the vertical bar, not a capital i or a lowcase l)
2) Plug-in an USB mouse and again type 'lsmod | sort' and append the new output to your next post.
3) To make good measure append to your next post as well the whole /var/log/messages file, in its state after step 2)

Time to sleep for me, so see you tomorrow

PS You may re-install the xf86-input-synaptics package to get a better working state under X, it won't change the results of aforementioned steps anyway.

Last edited by Didier Spaier; 07-04-2012 at 07:25 AM.
 
Old 07-03-2012, 08:35 PM   #36
ReaperX7
Senior Member
 
Registered: Jul 2011
Distribution: LFS-SVN, Slackware-14.1, PCBSD-10.0
Posts: 2,424
Blog Entries: 14

Rep: Reputation: 588Reputation: 588Reputation: 588Reputation: 588Reputation: 588Reputation: 588
Blooming. This is just a raw suggestion of what to try, but this may or may not help you.

Try to disable /etc/rc.d/rc.gpm at boot time and see if the problem clears up.

Run
Code:
chmod -x /etc/rc.d/rc.gpm
and reboot and see if your touchpad at least works within X11 using the Synaptic driver.
 
Old 07-04-2012, 01:07 PM   #37
Kallaste
Member
 
Registered: Nov 2011
Posts: 343

Original Poster
Rep: Reputation: Disabled
Didier Spaier: I am sorry about that. I began to suspect that was the case about half way through the thread when I started learning more, but when I started this thread I had no idea if the drivers were kernel specific or X specific or what got loaded when. Then, since the mouse problem outside of X is not really the same (all that happens in the terminal is when I try to drag to select text, it drags in the opposite direction: when I try to drag in an upward motion it goes "down," and vice versa) I thought maybe that dragging with the touchpad just wasn't supported outside of X and the driver was supposed to fix it. Then I thought that doesn't make sense, because if dragging were not supported there would just not be any functionality at all instead of glitchy functionality.

Anyway, please forgive my uninformed mistake. Here are those files. Thank you!

P.S. I had to save the var/log/messages files as a text file to get LQ to let me upload it, so I hope some formatting has been preserved. On my Linux computers it looks fine, but on Windows it's a mess.
Attached Files
File Type: txt withoutUSB.txt (3.2 KB, 1 views)
File Type: txt withUSB.txt (3.4 KB, 1 views)
File Type: txt messages.txt (90.2 KB, 1 views)
 
Old 07-04-2012, 01:09 PM   #38
Kallaste
Member
 
Registered: Nov 2011
Posts: 343

Original Poster
Rep: Reputation: Disabled
Reaper: I will read some more about that and figure out how I can undo it if it does not work. Thanks!

And of course, since Didier Spaier offered to look at that information, I would like to wait until he does first.

Last edited by Kallaste; 07-04-2012 at 01:54 PM.
 
Old 07-04-2012, 02:00 PM   #39
ReaperX7
Senior Member
 
Registered: Jul 2011
Distribution: LFS-SVN, Slackware-14.1, PCBSD-10.0
Posts: 2,424
Blog Entries: 14

Rep: Reputation: 588Reputation: 588Reputation: 588Reputation: 588Reputation: 588Reputation: 588
Curious question but what desktop environment are you using?
 
Old 07-04-2012, 02:44 PM   #40
Kallaste
Member
 
Registered: Nov 2011
Posts: 343

Original Poster
Rep: Reputation: Disabled
I switch between XFCE and KDE.
 
Old 07-04-2012, 03:00 PM   #41
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware-14.0 on a Lenovo T61 6457-4XG
Posts: 3,651

Rep: Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828
Don't be sorry, you are learning fast and your answers are smart and sensible, so it's a pleasure to try to help you. Furthermore I could have asked you if you noticed the problems with your touchpad long ago.

I will be able to answer your post with the appended files in two hours or so.

Meanwhile, please send the output of following command as well:
Code:
lspci -k
This way we will know for each piece of hardware connected to a PCI bus which are the kernel driver in use and the kernel modules.

I should have asked that before, sorry about that.
 
Old 07-04-2012, 04:29 PM   #42
Kallaste
Member
 
Registered: Nov 2011
Posts: 343

Original Poster
Rep: Reputation: Disabled
Here it is. And I am in no rush at all. Just thankful you are helping me!
Attached Files
File Type: txt lspciFile.txt (3.9 KB, 6 views)
 
Old 07-04-2012, 05:44 PM   #43
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware-14.0 on a Lenovo T61 6457-4XG
Posts: 3,651

Rep: Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828
Well, I think that the "psmouse" kernel driver is used to drive your thinkpad.

This can seem odd, as the 'modinfo psmouse' command says 'description: PS/2 mouse driver' but it's how it is, at least here. I have another model of touchpad but I think this is true for yours as well. Anyway it's easy to check: if I type as root 'rmmod psmouse' the mouse still works but the touchpad is inactive. In fact, in my case at least, the kernel driver for the USB mouse is 'usbhid' (FYI, hid stands for 'Human Input Device').

Enough with this digression, back to the topic. On the raw console the mouse is made available by the 'gpm' command, launched at startup by the file /etc/rc.d/rc.gpm.

Typing 'man gpm' I saw that the '-t' option allows to choose the type of 'mouse' used. The command (typed as root, again) 'gpm -t help' shows the different types available, among which I guess that 'synps2 The "Synaptics" PS/2 TouchPad' is the one which fit best your touchpad. Thus I suggest you try this:
1) Edit as root the file /etc/rc.d/rc.gpm (e.g. 'nano /etc/rc.d/rc.gpm' - nano being an easy to use text editor) in order to replace in the two lines showing :
Code:
  /usr/sbin/gpm -m /dev/mouse -t <mouse type>
whichever mouse type shows at the end of the line with "synps2" (without the quotes),
then save the updated file (if you use nano: Ctrl+o to save then Ctrl+x to quit)
2) So that the change takes effect, type, still as root:
/etc/rc.d/rc.gpm restart

You can do all that in a raw terminal, see what have changed in the touchpad's behavior, then 'startx' and again see what have changed.

I also was wondering if some of your problems could be at least partially due to the fact that you have two graphic cards, but one thing at a time

PS I didn't see anything worrying in the files I looked at.

Last edited by Didier Spaier; 07-04-2012 at 05:49 PM. Reason: Typos corrected
 
1 members found this post helpful.
Old 07-05-2012, 08:33 AM   #44
Kallaste
Member
 
Registered: Nov 2011
Posts: 343

Original Poster
Rep: Reputation: Disabled
Alas, it did not work. It was using "ps2" as the mouse type in the /etc/rc.d/rc.gpm file, so I changed those two lines to "synps2," as you said (without quotes of course ). Then I issued the restart command, and nothing had changed either in the raw console or in X.

When I type 'modinfo psmouse,' the description on my machine is exactly the same as yours. I also went through the man and help pages you mentioned, and in both cases found the information to be identical to what you described.

About the graphics cards, yes, I do have two. The computer came with "switchable" graphics, which is supposed to preserve my battery life by allowing me to switch to the slower one when I am not playing graphics-intensive games or the like (which I never do). Do you think this might be causing a conflict of some sort with the mouse driver? If the faster card could be disabled then that would be fine with me, since I have never noticed the slightest difference in performance between them. I was wanting to deal with this issue first because I did not think the two were related, but now that you mention it, there is definitely a problem with my graphics. They are of very poor quality, and I also saw that error in the messages file I attached earlier about it.

Also, about 30 % of the time, I get about halfway through the boot process and then hang at a black screen, so I have to restart. I thought this was a problem with the VESA settings, because I read that not all the options (I choose between 20 or so of them at every start-up) are compatible with all cards and that I would need to "experiment" to see which one would be best for my hardware. (I did not know about the VESA module being overridden by the Intel one, and I still do not know if this happens this early in the boot process or if the VESA module is used for a while and thus may still cause problems requiring "experiments.") I planned to look into this later, after the mouse issue was resolved. But perhaps it is more likely that the superfluous card is responsible. Could it be the culprit for the touchpad problem as well?

Last edited by Kallaste; 07-05-2012 at 08:51 AM.
 
Old 07-05-2012, 11:19 AM   #45
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware-14.0 on a Lenovo T61 6457-4XG
Posts: 3,651

Rep: Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828
Out of curiosity, could you list all the options you choose at every start-up? Do you type it or are they included in /etc/lilo.conf? Anyhow, please send your lilo.conf.

To make sure vesa be not used at boot time, simply include 'vga=normal' in your /etc/lilo.conf (instead of "vga=<some number>" as it probably is). You won't have fancy small characters on the raw console, but I guess you don't really need that.

To make sure that the intel driver be used by X, the simplest way is to include following line in a new file /etc/X1/rc.d/video.conf (or any filename ending in .conf):
Code:
Section "Device"
Identifier "whatever"
Driver "intel"
EndSection
If you want to use another driver, adapt accordingly.

By the way, I noticed that though kernel drivers for your two cards be loaded at start-up (namely, i915 for INTEL and radeon for ATI), X doesn't load a driver for ATI.

I don't know why but I guess that then your ATI card is not used under X at all.

EDIT To make sure the above video.conf file works, there shouldn't exist any other file ending in .conf in /etc/X11 and /etc/X11/rc.d. "man xorg.conf" will tell you more in case you didn't look at it already.

Also, to switch between your graphic cards the "switcheroo" feature is available (it is built-in Slackware kernels as shows output of 'grep -i switcheroo config*'). I didn't see any reference about its use with Slackware (maybe I didn't search enough) but this article looks interesting.

Last edited by Didier Spaier; 07-05-2012 at 12:00 PM.
 
1 members found this post helpful.
  


Reply

Tags
mouse


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mouse cursor jumping erratically + takes clicking action when not moved? JZL240I-U Linux - Software 23 04-30-2008 08:54 AM
mouse cursor goes crazy during network activity TMKroeger Linux - General 0 03-12-2006 06:39 PM
Belkin KDM & MS scoll mouse solution (jumping mouse) otchie1 Linux - Hardware 2 03-02-2006 01:16 PM
startx on Debian gives grey background - cannot move mouse cursor or type fdac Linux - Newbie 7 05-04-2005 03:11 PM
(STRANGE) Mouse get's crazy when holding a key and moving mouse(Update to 2.6.10) the-copy Linux - Hardware 2 02-08-2005 12:07 PM


All times are GMT -5. The time now is 01:51 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration