LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   cpu frequency scaling with Pentium(R) Dual-Core CPU E5200 @ 2.50GHz (http://www.linuxquestions.org/questions/slackware-14/cpu-frequency-scaling-with-pentium-r-dual-core-cpu-e5200-%40-2-50ghz-747712/)

tramni1980 08-15-2009 02:20 AM

cpu frequency scaling with Pentium(R) Dual-Core CPU E5200 @ 2.50GHz
 
Hello!
I am configuring the 2.6.30.4 kernel for the hardware on my system. The
problem is that I cannot determine whether the cpufrequency scaling
driver for my processor is supported. Here is some info on my processor:

Code:

cat /proc/cpuinfo
processor      : 0
vendor_id      : GenuineIntel
cpu family      : 6
model          : 23
model name      : Pentium(R) Dual-Core  CPU      E5200  @ 2.50GHz
stepping        : 6
cpu MHz        : 2499.990
cache size      : 2048 KB
physical id    : 0
siblings        : 2
core id        : 0
cpu cores      : 2
apicid          : 0
initial apicid  : 0
fdiv_bug        : no
hlt_bug        : no
f00f_bug        : no
coma_bug        : no
fpu            : yes
fpu_exception  : yes
cpuid level    : 10
wp              : yes
flags          : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts pni monitor ds_cpl est tm2 ssse3 cx16 xtpr lahf_lm
bogomips        : 4999.98
clflush size    : 64
power management:

processor      : 1
vendor_id      : GenuineIntel
cpu family      : 6
model          : 23
model name      : Pentium(R) Dual-Core  CPU      E5200  @ 2.50GHz
stepping        : 6
cpu MHz        : 2499.990
cache size      : 2048 KB
physical id    : 0
siblings        : 2
core id        : 1
cpu cores      : 2
apicid          : 1
initial apicid  : 1
fdiv_bug        : no
hlt_bug        : no
f00f_bug        : no
coma_bug        : no
fpu            : yes
fpu_exception  : yes
cpuid level    : 10
wp              : yes
flags          : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts pni monitor ds_cpl est tm2 ssse3 cx16 xtpr lahf_lm
bogomips        : 4999.94
clflush size    : 64
power management:

My question is whether my processor is supported by the linux kernel and if yes, which option I need to enable?

Thank you very much for your attention.
Regards,
Martin

easuter 08-15-2009 06:06 AM

Hi tramni1980,

Try inserting the kernel module and see if any errors occur:

Code:

modprobe acpi_cpufreq
If you get no error messages then you should be ok.
Then you must install cpufreq-utils to actually fiddle with the CPU clock/mode. You can download the Slackbuild here: http://slackbuilds.org/repository/12.../cpufrequtils/

Hope that helps :)

catkin 08-15-2009 06:33 AM

This page may be helpful too. Please update this thread with your experience; I'm planning on following it myself some time. :)

sahko 08-15-2009 11:00 PM

You don't need cpufrequtils for cpu frequency scaling anymore.
The modern linux desktops do it through HAL, pm-utils and the desktop enviroments power manager.
I think all modern processors support it.

chuckie 08-16-2009 01:16 AM

The Pentium Dual-Core looks similar to the Core2 I use. Here is how I configured cpu scaling. In kernel configuration under "Power management and APCI options"

enable ACPI
enable CPU Frequency scaling
set "ondemand" as Default CPUFreq governor
enable as module "ACPI Processor P-States driver"

then build new kernel and install.
Edit file /etc/rc.d/rc.modules, near the bottom uncomment the line
/sbin/modprobe acpi-cpufreq

reboot computer.

tramni1980 08-16-2009 08:29 AM

Thank you all very much for your advice.
The module acpi-cpufreq did the job.

Now I have a working ondemand cpu frequency scaling.

Thank you all very much again.

Regards,
Martin


All times are GMT -5. The time now is 05:11 AM.