LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   CPU frequency control Cool n'Quiet in Slackware64 13 (http://www.linuxquestions.org/questions/slackware-14/cpu-frequency-control-cool-nquiet-in-slackware64-13-a-751469/)

arubin 08-31-2009 07:46 AM

CPU frequency control Cool n'Quiet in Slackware64 13
 
In 12.2 I have cpu frequency control working. When there is no load cpu frequency is cut back to 1000.

I cannot get this to work in 13. In particular there is a file /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor which is present in 12.2 and absent in 13.

Any ideas?

arubin 08-31-2009 08:11 AM

I have worked out a way round this

rc.modules has
Quote:

CPUFREQ=battery

# If CPUFREQ=battery and the battery module is loaded, turn on CPUfreq.
if [ "$CPUFREQ" = "battery" ]; then
if /sbin/lsmod | grep -wq battery ; then
# CPUFREQ=battery and a battery was detected, so change CPUFREQ
# to 'on' so that the block of script below will try to enable it.
CPUFREQ=on
fi
fi

### Enable CPU frequency scaling if requested:
if [ "$CPUFREQ" = "on" ]; then
so it seems that cpu governor is not invoked on a desktop.

I changed the initial CPUFREQ=battery to CPUFREQ=on and it is working properly and my cpu is running some 30 degrees Celsius cooler.

Woodsman 08-31-2009 12:22 PM

Quote:

Any ideas?
Yes, this bit me too. You have to manually edit rc.modules.

As is:
CPUFREQ=battery

Change to:
CPUFREQ=on


All times are GMT -5. The time now is 01:57 PM.