LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-09-2008, 11:56 PM   #1
mrclisdue
Senior Member
 
Registered: Dec 2005
Distribution: Slackware -current, 14.1
Posts: 1,046

Rep: Reputation: 170Reputation: 170
cpu frequency concerns


Toshiba Satellite M70 -DL4

cat /proc/cpuinfo:

Code:
processor	: 0
vendor_id	: GenuineIntel
cpu family	: 6
model		: 13
model name	: Intel(R) Pentium(R) M processor 1.86GHz
stepping	: 8
cpu MHz		: 600.000
cache size	: 2048 KB
fdiv_bug	: no
hlt_bug		: no
f00f_bug	: no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 2
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss tm pbe up bts est tm2
bogomips	: 1598.06
clflush size	: 64
cpufreq-info:

Code:
driver: p4-clockmod
  CPUs which need to switch frequency at the same time: 0
  hardware limits: 75.0 MHz - 600 MHz
  available frequency steps: 75.0 MHz, 150 MHz, 225 MHz, 300 MHz, 375 MHz, 450 MHz, 525 MHz, 600 MHz
  available cpufreq governors: ondemand, performance, powersave, userspace
  current policy: frequency should be within 75.0 MHz and 600 MHz.
                  The governor "userspace" may decide which speed to use
                  within this range.
  current CPU frequency is 600 MHz
I'm very green when it comes to this aspect of computing.
What do I need to do in order to have the kernel recognize and operate with the correct cpu frequency?

thank you,
 
Old 10-10-2008, 02:19 AM   #2
nigelc
Member
 
Registered: Oct 2004
Location: Sydney, Australia
Distribution: Mageia 4
Posts: 301
Blog Entries: 4

Rep: Reputation: 52
Hello,
It's a bug with cat /proc/cpuinfo
It even does it with lots of different distros/ kernel versions
My fedora does it.


Code:
bogomips	: 1598.06
clflush size	: 64
the bogomips are probably closer to go on.
If you search for it lots of other people have had similar findings.
 
Old 10-10-2008, 05:46 AM   #3
mrclisdue
Senior Member
 
Registered: Dec 2005
Distribution: Slackware -current, 14.1
Posts: 1,046

Original Poster
Rep: Reputation: 170Reputation: 170
thank you kindly
 
Old 10-10-2008, 07:28 AM   #4
bassmadrigal
Member
 
Registered: Nov 2003
Location: Newport News, VA
Distribution: Slackware
Posts: 211

Rep: Reputation: 41
Mine shows up properly...

Code:
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 13
model name      : Intel(R) Pentium(R) M processor 1.60GHz
stepping        : 6
cpu MHz         : 1600.000
cache size      : 2048 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr mce cx8 sep mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss tm pbe up bts est tm2
bogomips        : 3191.83
clflush size    : 64
Code:
cpufrequtils 003: cpufreq-info (C) Dominik Brodowski 2004-2006
Report errors and bugs to cpufreq@lists.linux.org.uk, please.
analyzing CPU 0:
  driver: acpi-cpufreq
  CPUs which need to switch frequency at the same time: 0
  hardware limits: 600 MHz - 1.60 GHz
  available frequency steps: 1.60 GHz, 1.40 GHz, 1.20 GHz, 1000 MHz, 800 MHz, 600 MHz
  available cpufreq governors: performance, ondemand, powersave, userspace
  current policy: frequency should be within 600 MHz and 1.60 GHz.
                  The governor "ondemand" may decide which speed to use
                  within this range.
  current CPU frequency is 600 MHz.
I just have these in my rc.local file

Code:
/sbin/modprobe acpi_cpufreq
/sbin/modprobe cpufreq_powersave
/sbin/modprobe cpufreq_ondemand
/sbin/modprobe cpufreq_performance
Also I have cpufreq-daemon running which allows me to set the speed based on certain power status.
 
Old 10-10-2008, 06:02 PM   #5
mrclisdue
Senior Member
 
Registered: Dec 2005
Distribution: Slackware -current, 14.1
Posts: 1,046

Original Poster
Rep: Reputation: 170Reputation: 170
Thanks all for your input. As usual, your contributions have pointed me in the right direction.

I was getting a fatal error when attempting to load the acpi_cpufreq module, because the p4-clockmod was being loaded. After blacklisting that module, I was able to load acpi_cpufreq.

Secondly, my bios was incorrectly set to allow frequency scaling, so I changed that. Hence:

cat /proc/cpuinfo:

Code:
processor	: 0
vendor_id	: GenuineIntel
cpu family	: 6
model		: 13
model name	: Intel(R) Pentium(R) M processor 1.86GHz
stepping	: 8
cpu MHz		: 1867.000
cache size	: 2048 KB
fdiv_bug	: no
hlt_bug		: no
f00f_bug	: no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 2
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss tm pbe up bts est tm2
bogomips	: 3727.92
clflush size	: 64
and cpufreq-info:

Code:
 driver: acpi-cpufreq
  CPUs which need to switch frequency at the same time: 0
  hardware limits: 800 MHz - 1.87 GHz
  available frequency steps: 1.87 GHz, 1.60 GHz, 1.33 GHz, 1.07 GHz, 800 MHz
  available cpufreq governors: ondemand, performance, powersave, userspace
  current policy: frequency should be within 800 MHz and 1.87 GHz.
                  The governor "userspace" may decide which speed to use
                  within this range.
  current CPU frequency is 1.87 GHz
cheers,
 
Old 10-10-2008, 06:15 PM   #6
bassmadrigal
Member
 
Registered: Nov 2003
Location: Newport News, VA
Distribution: Slackware
Posts: 211

Rep: Reputation: 41
One thing I can highly recommend doing is building cpufreq-daemon. This has been extremely beneficial in saving my battery life. You basically set the config on how you want it to scale your processor at various power stages. ie on mine, on AC min and max are set to 1.6GHz, from 100%-50% on the battery it will sit at 600MHz unless something needs the proc, then it will bump it up the various levels up to 1.6GHz, from 25%-50% it will only go up to 1GHz, and anything below that will stay at the 600MHz range.

You have even more options than I covered here, as you can also specify the userspace governor (ie. performance, ondemand, etc).

But I am glad you got it squared away. It took me forever to get this working in 10.2 and it has been getting ever easier with each slack release. Pretty soon, I will just have to carry over my conf file and not have to build anything.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CPU Frequency Scaling runa Linux - Hardware 5 04-24-2011 11:23 AM
CPU frequency scaling PatrickMay16 General 10 07-10-2007 08:07 PM
P4 and CPU Frequency scaling tkalfaoglu Linux - Kernel 3 05-31-2006 09:56 AM
CPU frequency problem septanla Linux - Hardware 1 04-20-2006 09:59 PM
CPU frequency-scaling cccc Linux - Hardware 1 03-22-2006 12:13 AM


All times are GMT -5. The time now is 08:54 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration