LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Copy Files Between Drives Causes Kernel Panic/Freeze of the System (http://www.linuxquestions.org/questions/slackware-14/copy-files-between-drives-causes-kernel-panic-freeze-of-the-system-78893/)

php 08-04-2003 12:18 PM

Copy Files Between Drives Causes Kernel Panic/Freeze of the System
 
I have noticed that on a default install of slackware 9, I can't copy large amounts of files between hard drives without the kernel panic and the whole computer freezing up. The caps lock and scroll lock lights on the keyboard both blink when this happens. Has anyone else noticed this?

fancypiper 08-04-2003 02:38 PM

Any hints in the system log (/var/log/messages)?

# Watch error messages as they happen (sysklog needed)
as root, tail -f /var/log/messages (shows last 10 lines, use a number in front of f for more lines)

zero_copy 08-06-2003 04:09 AM

what filesystems are u trying to read and write from/to. there are some (like NTFS) that are read only shoudl not be written to....check the kernel config to see if that particular fs is deemed "dangerous/experimental"

php 08-07-2003 05:45 PM

It doesn't leave anything in the logs.. Well, in this particular instance its reading/writing from a ReiserFS to FAT32, but I have had the same problem with ReiserFS to EXT3, and vice versa, I don't think its a file system problem really, as it doesn't seem to matter which file system because they all lock up at some point anyway...

php 08-12-2003 01:20 PM

sucks

fancypiper 08-12-2003 01:31 PM

What are your hdparm settings for the drive(s)? My conservative settings:
Code:

root@uilleann # hdparm /dev/hda

/dev/hda:
 multcount    = 16 (on)
 I/O support  =  0 (default 16-bit)
 unmaskirq    =  0 (off)
 using_dma    =  1 (on)
 keepsettings =  0 (off)
 nowerr      =  0 (off)
 readonly    =  0 (off)
 readahead    =  8 (on)
 geometry    = 4865/255/63, sectors = 78165360, start = 0
 busstate    =  1 (on)
root@uilleann # hdparm /dev/hdc

/dev/hdc:
 multcount    = 16 (on)
 I/O support  =  0 (default 16-bit)
 unmaskirq    =  0 (off)
 using_dma    =  1 (on)
 keepsettings =  0 (off)
 nowerr      =  0 (off)
 readonly    =  0 (off)
 readahead    =  8 (on)
 geometry    = 9729/255/63, sectors = 156301488, start = 0
 busstate    =  1 (on)

Using some agressive settings that may freeze drives:

hdparm -X69 -d1 -u1 -m16 -c3 /dev/hd<X>

php 08-14-2003 08:10 PM

bash-2.05b# hdparm /dev/hda

/dev/hda:
multcount = 0 (off)
IO_support = 0 (default 16-bit)
unmaskirq = 0 (off)
using_dma = 1 (on)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 8 (on)
geometry = 59554/16/63, sectors = 60030432, start = 0

bash-2.05b# hdparm /dev/hdb

/dev/hdb:
multcount = 0 (off)
IO_support = 0 (default 16-bit)
unmaskirq = 0 (off)
using_dma = 1 (on)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 8 (on)
geometry = 9345/255/63, sectors = 150136560, start = 0
bash-2.05b# hdparm /dev/hdd

/dev/hdd:
multcount = 0 (off)
IO_support = 0 (default 16-bit)
unmaskirq = 0 (off)
using_dma = 1 (on)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 8 (on)
geometry = 9929/240/63, sectors = 150136560, start = 0

fancypiper 08-14-2003 08:30 PM

I would try changing some paramaters and see if it still occurs.

Try changing these settings back and forth and see if that fixes it.

hdparm -d1 -u1 -m16 -c3 /dev/hd<X>

Speeding up Linux Using hdparm
Not mentioned in the article:
UDMA 33/66/100. Add the -X option, and then this number i.e. (-X 69)
-X 33 ====> Multiword DMA
-X 66 ====> ATA-33 (UDMA2)
-X 68 ====> ATA-66 (UDMA4)
-X 69 ====> ATA-100 (UDMA 5)


All times are GMT -5. The time now is 11:24 AM.