Go Job Hunting at the LQ Job Marketplace
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 02-10-2003, 10:21 AM   #1
LQ Newbie
Registered: Dec 2002
Location: nigeria
Distribution: slackware 8.1
Posts: 12

Rep: Reputation: 0
console/X mouse problem

my computer boots at runlevel 3 and gpm is always started at boot time. i use a 3-button wheelmouse which works fine at the terminal mode. Now whenever i start X and the switch back to terminal, the mouse goes berserk. why?

i use IMPS/2 as my mouse protocol for X but i don't see how my XF86Config should affect the terminal.
Old 02-10-2003, 11:01 AM   #2
Registered: Dec 2002
Location: Plains
Distribution: Slackware 13
Posts: 465

Rep: Reputation: 30
Do you have this line in your /etc/X11/XF86config in Mouse1 the last line?

Option "ZAxismapping" "4 5"
Old 02-10-2003, 12:23 PM   #3
Registered: Feb 2003
Location: Belgium
Distribution: Debian
Posts: 166

Rep: Reputation: 31
when you install slackware they warn you this might happen... you mouse goes berserk because you are running gpm at startup... i'm not running it... don't know how to help you however
Old 02-10-2003, 12:50 PM   #4
Registered: Dec 2002
Location: Plains
Distribution: Slackware 13
Posts: 465

Rep: Reputation: 30
/etc/rc.d/rc.M comment out:

# Start the GPM mouse server:
if [ -x /etc/rc.d/rc.gpm ]; then
. /etc/rc.d/rc.gpm start
Old 02-12-2003, 11:25 PM   #5
LQ Newbie
Registered: Feb 2003
Posts: 14

Rep: Reputation: 0

Mine did the same when I switched from ps/2 to usb (same mouse different prot)

try adding this into your /etc/rc.d/rc.gpm:

gpm -m /dev/input/mice -t imps2

should go just under "echo "Staring GPM..."

dont know if you've tried this or not but hey, its worth a shot



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
console mouse noir911 *BSD 2 11-01-2005 04:36 PM
How can i use mouse under console??? harlemno1 Linux - Software 1 11-04-2004 08:35 PM
console mouse error corbis_demon Linux - Newbie 0 07-03-2004 09:05 AM
USB mouse, keyboard, hid, console mouse problems jqcaducifer Linux - General 1 08-05-2003 09:43 AM
Unwanted Console-mouse Config Slackware 12 07-06-2002 05:37 AM

All times are GMT -5. The time now is 12:56 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration