LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Console resolution problem after compiling 2.6.2 ... (http://www.linuxquestions.org/questions/slackware-14/console-resolution-problem-after-compiling-2-6-2-a-144102/)

Cdzin 02-09-2004 01:18 PM

Console resolution problem after compiling 2.6.2 ...
 
Hii, well, it's a silly question ... I compiled the new kernel (2.6.2) and i can't get the console working in 1024x768 or any other resolution. On the former kernel, i needed just to pass 'vga=790' to lilo.conf to make it work. Any clue?! Thanks!

bnice 02-09-2004 02:29 PM

Re: Console resolution problem after compiling 2.6.2 ...
 
Quote:

Originally posted by Cdzin
Hii, well, it's a silly question ... I compiled the new kernel (2.6.2) and i can't get the console working in 1024x768 or any other resolution. On the former kernel, i needed just to pass 'vga=790' to lilo.conf to make it work. Any clue?! Thanks!

I'll see your silly question and raise you one:

Did you compile video selection support into your kernel?

From xconfig help screen:

Quote:

Video mode selection support (VIDEO_SELECT)

This enables support for text mode selection on kernel startup. If
you want to take advantage of some high-resolution text mode your
card's BIOS offers, but the traditional Linux utilities like
SVGATextMode don't, you can say Y here and set the mode using the
"vga=" option from your boot loader (lilo or loadlin) or set
"vga=ask" which brings up a video mode menu on kernel startup. (Try
"man bootparam" or see the documentation of your boot loader about
how to pass options to the kernel.)

Cdzin 02-09-2004 03:59 PM

I did. :( I compiled this kernel 3 times and on the first i already noticed this problem and then i saw 'Video selection support' and thought it was going to work but it did nothing. Thanks anyway. :)

bnice 02-09-2004 04:34 PM

hmmm, that should work.


try adding the following to your lilo.conf:

Code:

vga = ask
run:

/sbin/lilo

reboot

after kernel starts loading you will see something like

"choose video mode <enter> to see a list or <space> to continue"

hit enter

then at the next prompt type:

scan

it will scan all available video modes and present you with a list of what (should) work.
don't be alarmed if your screen goes blank, it'll be back

choose one

NOTE: if nothing works, just reboot, hit spacebar at prompt to boot normal vga and change lilo.conf back to vga=normal then rerun lilo to save changes.

let us know, as this is a common question at LQ

Cdzin 02-10-2004 04:44 PM

Hi bnice, i had already tested "vga=ask" but not with "scan". Okk, i scanned for video modes and it found some strange things like 80x25, 100x25, 132x44 and others :( ... I appreciate your help ...

bnice 02-10-2004 05:18 PM

those are columns : rows

standard vga 80X25

1234.........................................80
2
3
4
5
.
.
.
.
25


Edit:
I just got curious enough to compare the .configs for the canned 2.4.x & my 2.6.2 kernels.:study:
This is what I did to make it work, :o
These options are under "Graphics Support"

[list=1][*]disable video selection support - seems to work without it[*]enable framebuffer support in kernel[*]enable framebuffer console support (this is the one that bit me in the a$$)[*](optional) enable bootup logo[*] make install && make modules_install - or use your favorite method, it's all good[/list=1]

Cdzin 02-11-2004 11:32 AM

Hii, i finally discovered what was going wrong. :) Well, i was compiling the atyfb (i have a ATi Rage Pro Turbo) as the framebuffer device. I don't know why it doesn't work but after i tried to use the generic VESA VGA device, it worked perfectly. Thank you, bnice!


All times are GMT -5. The time now is 07:22 PM.