LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   console frame buffer @ 640x480 only (http://www.linuxquestions.org/questions/slackware-14/console-frame-buffer-%40-640x480-only-220915/)

edM 08-22-2004 11:29 AM

console frame buffer @ 640x480 only
 
gfx = Radeon 9800pro

After a rebuild of my kernal a few weeks ago (trying to get my agp support to work properly, which i did) it now starts up in 640x480. i went into the lilo config to check that correct vga mode was selected ( vga=791) which my usual res of 1024.

when you start up X windows theres no problem, it runs at 1280.

So it must be that i have a kernal conflict?

i had this problem before when setting up the video on this PC, where i had selected the new Radeon driver and the old one, once i deselected the old driver it was fine.

i have been on holiday so i have forgotten how the kernal was configured before, and i FUBAR`d my backup :rolleyes:


kernal settings -

Graphics Support >
<*> vga 16-color graphics
<*> VESA VGA
<*> ATI Radeon display support
Console display drivers>[*] video mode selection support
<*> frame buffer console support



in character devices, i turned off [M] agpart with [M] ATI chipset, and[*]Direct Rendering Manager with[*] ATI Radeon.

I tried a rebuild with these options [above] turned off, but the same thing happened.


thanks for your help. :)

mdg 08-22-2004 11:38 AM

Did you also compile in the VGA 8x16 font?

synaptical 08-22-2004 11:44 AM

Re: console frame buffer @ 640x480 only
 
Quote:

Originally posted by edM
Graphics Support >
<*> vga 16-color graphics
<*> VESA VGA
<*> ATI Radeon display support
Console display drivers>[*] video mode selection support
<*> frame buffer console support

in character devices, i turned off [M] agpart with [M] ATI chipset, and[*]Direct Rendering Manager with[*] ATI Radeon.

I tried a rebuild with these options [above] turned off, but the same thing happened.


thanks for your help. :)

try changing agpgart to <*>, keeping ATI as [M], and where is your motherboard chipset module option? also build <*> ATI Radeon display support as a module [M]. those are the settings i have, and i get the good resolution framebuffer mode. :cool:

btw, do you have the "select the compiled in fonts" option selected? it's under the framebuffer console support option, i believe. make sure you also select the two vga fonts.

synaptical 08-22-2004 11:50 AM

p.s. build in the vga fonts first before changing your other settings, as long as everything else is working fine. you might also want to build ATI as a module under DRI -- imho there's really no point in building in things like that and wasting the space, since you're not likely to need DRI before you get to X anyway. :p

edM 08-22-2004 12:18 PM

"select the compiled in fonts", i did have that compiled, the two deafault ones, VGA 8x16 and the other one, on the second rebuild with apart off, i aslo deseletect it.

oops! i never thought you had to select your chipset, its i865pe, should i compile it as built in or have it as a module like the Radeon as you suggest?

final edit:

got it back to 1024 hera!!

thanks

synaptical 08-23-2004 12:29 AM

Quote:

Originally posted by edM
"select the compiled in fonts", i did have that compiled, the two deafault ones, VGA 8x16 and the other one, on the second rebuild with apart off, i aslo deseletect it.

oops! i never thought you had to select your chipset, its i865pe, should i compile it as built in or have it as a module like the Radeon as you suggest?

final edit:

got it back to 1024 hera!!

thanks

cool! what finally did it?

btw, to answer your question, i definitely would build it as a module.

edM 08-23-2004 09:29 AM

i just followed what you said.

compiled the 2 fonts first, then changed then the rest, with the mobo chipset as a module, it work no probs!


All times are GMT -5. The time now is 11:17 PM.