LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-03-2013, 02:42 AM   #16
clubslacker
LQ Newbie
 
Registered: Feb 2013
Posts: 19

Original Poster
Rep: Reputation: Disabled

ok so i checked lsmod | less and did not see anything 'tulip' anywhere.

however i did do this:
cp /lib/modprobe.d/tulip.conf /etc/modprobe.d/tulip.conf
and then did
nano /etc/modprobe.d/tulip.conf and commented out
#blacklist dmfe

saved computer restarted and it is working! THANK U

ps. do u know why it was blacklisted?
 
Old 02-03-2013, 03:43 AM   #17
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,408

Rep: Reputation: 834Reputation: 834Reputation: 834Reputation: 834Reputation: 834Reputation: 834Reputation: 834
Glad it all worked out for you.
I do not know why it was blacklisted, but the likely reason is that it causes conflicts with other modules.
 
Old 02-04-2013, 01:37 PM   #18
clubslacker
LQ Newbie
 
Registered: Feb 2013
Posts: 19

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by allend View Post
Glad it all worked out for you.
I do not know why it was blacklisted, but the likely reason is that it causes conflicts with other modules.
websites are working slow / timing out 90% of the time.

I tried setting resolve.conf to use opendns and that fixed the problem immediately, however the fix was temporary??? because when i restart my pc it reverts back to the old resolv.conf file.

1. is there a way to make my internet run properly with my normal DNS settings?
2. if no, then how do i make it remember to use opendns or google dns settings so that my internet is not broken every time i restart the computer.

thanks...

edit:
so my current resolv.conf file looks like this:
Quote:
# Generated by Network Manager
domain ftrdhcpuser.net
search ftrdhcpuser.net
nameserver 192.168.1.1
nameserver 68.238.0.14
and when i change it to the following my internet works great, until i restart the pc:
Quote:
# Generated by Network Manager
domain ftrdhcpuser.net
search ftrdhcpuser.net
nameserver 208.67.222.222
nameserver 208.67.220.220

Last edited by clubslacker; 02-04-2013 at 01:47 PM.
 
Old 02-04-2013, 02:05 PM   #19
NeoMetal
Member
 
Registered: Aug 2004
Location: MD
Distribution: Slackware
Posts: 105

Rep: Reputation: 19
Network manager is overwriting the dns configuration so you could either,
reconfigure the network without networkmanager now that you've got the driver problem taken care of so it will keep your settings, or tell network manager which servers to try.

I think to configure dns in network manager the GUI way is right click on the networkmanager icon - click edit connections - click your connection in the appropriate tab and select edit -> go to the ip{4,6} settings tabs and set method to dhcp/automatic addresses only -> the dns server box ungreys and you can add them there. (I don't know how to configure network manager via CLI/conf files off the top of my head)
 
Old 02-04-2013, 02:09 PM   #20
clubslacker
LQ Newbie
 
Registered: Feb 2013
Posts: 19

Original Poster
Rep: Reputation: Disabled
i see... does anyone know why my default dns settings are not working on linux, though? seems strange to me
 
Old 02-04-2013, 02:11 PM   #21
jostber
Member
 
Registered: Jul 2001
Location: Skien, Norway
Distribution: Slackware 14.0 64-bit
Posts: 228

Rep: Reputation: 41
Some nice tips here as well:

https://wiki.archlinux.org/index.php/Resolv.conf
 
1 members found this post helpful.
Old 02-04-2013, 02:37 PM   #22
NeoMetal
Member
 
Registered: Aug 2004
Location: MD
Distribution: Slackware
Posts: 105

Rep: Reputation: 19
Quote:
Originally Posted by clubslacker View Post
i see... does anyone know why my default dns settings are not working on linux, though? seems strange to me

I'm not sure - maybe check out the router config, ping those isp dns servers to verify they are all up, maybe reboot the router. Those dns servers are working OK on other setups?
 
Old 02-04-2013, 02:56 PM   #23
clubslacker
LQ Newbie
 
Registered: Feb 2013
Posts: 19

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by NeoMetal View Post
I'm not sure - maybe check out the router config, ping those isp dns servers to verify they are all up, maybe reboot the router. Those dns servers are working OK on other setups?
i tried rebooting the router. i tried pinging the dns servers. everything works fine on my other windows systems. ubuntu worked fine before. something is goofed up in my settings it has to be i just dont know...
 
Old 02-04-2013, 03:03 PM   #24
jostber
Member
 
Registered: Jul 2001
Location: Skien, Norway
Distribution: Slackware 14.0 64-bit
Posts: 228

Rep: Reputation: 41
Can you post the output of these as root?

traceroute 192.168.1.1
traceroute 68.238.0.14
nmap -sS 192.168.2.1-3

Try to mark the output with your mouse and then use the middle button to paste it in.
 
Old 02-04-2013, 03:10 PM   #25
n1x4
LQ Newbie
 
Registered: Jan 2013
Distribution: Salckware
Posts: 10

Rep: Reputation: Disabled
Try making rc.networkmanager non-executable.
Code:
chmod -x /etc/rc.d/rc.networkmanager
Also helps to remove/comment out the 'search' parameter in resolv.conf
 
Old 02-04-2013, 03:59 PM   #26
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,251

Rep: Reputation: 630Reputation: 630Reputation: 630Reputation: 630Reputation: 630Reputation: 630
I don't know much about networkmanager but if you are back to using the stock DHCP options from netconfig then you will need to edit /etc/rc.d/rc.inet1.conf to add
Code:
DHCP_KEEPRESOLV[0]="yes"
under the 'Config information for eth0' section. This will prevent /etc/resolv.conf from being overwritten by the DHCP lease and you will be able to permanently use an external DNS server there.
 
Old 02-04-2013, 04:58 PM   #27
clubslacker
LQ Newbie
 
Registered: Feb 2013
Posts: 19

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by jostber View Post
thank you all for your help i wouldn't have figured this out without you guys.

i double checked everything 3x and the exact same DNS settings that my windows computers got from the router are what linux was set up to use too, but they just didn't want to work with linux. all i did was edit my resolv.conf file to use the google dns servers how it shows in the link above, and i locked the file with chattr +i /etc/resolv.conf and the internet is working beautifully. strange, but solution works. it does bother me a little that I can't get it to run with my own stock DNS nameservers but I CBF to work on this anymore
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
connect: Network is unreachable pvtplt Linux - Networking 6 03-06-2008 03:30 PM
[SOLVED] connect: Network is unreachable phahn Linux - Networking 3 01-06-2008 11:53 AM
connect: network is unreachable xeebeeeeeee Linux - Networking 6 03-22-2007 04:03 AM
connect: Network is unreachable teach42 Fedora 1 08-10-2004 06:16 PM
connect: Network is unreachable joenomad Linux - Networking 11 04-21-2002 10:33 AM


All times are GMT -5. The time now is 12:17 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration