LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-20-2013, 02:28 PM   #16
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,082

Rep: Reputation: 799Reputation: 799Reputation: 799Reputation: 799Reputation: 799Reputation: 799Reputation: 799

Look: here's what you need from SlackBuilds.org (and in the order you need to build and install them using the appropriate SlackBuild in each package):
  1. lua 5.1.5
  2. imlib2 1.4.5 (this installs alongside the Slackware-provided imlib 1.9.15)
  3. scons 2.2.0
  4. tolua++ 1.0.93
  5. conky 1.9.0
From the conky page at SlackBuilds.org:
Quote:
To enable lua scripting engine support, you will need lua, imlib2, and
tolua++, and run this script like this: LUA=yes ./conky.SlackBuild
As I and others have tried to point out to you, do it this way and it'll work and no amount of arguing will make any difference.

Hope this helps some.
 
1 members found this post helpful.
Old 06-20-2013, 05:14 PM   #17
flyinggeorge
Member
 
Registered: Feb 2012
Location: United States
Distribution: Slackware 14.0
Posts: 160

Original Poster
Rep: Reputation: 3
I'm not trying to be argumentative, but as I have previously stated, I have all of those, and they were *built from the slackbuilds* except for cairo. Everyone seems to be ignoring the actual error I am getting. I built Lua, tolua++, imlib2, and scons from the slackbuilds, then when I try to run the conky slackbuild I get:

Code:
configure: error: tolua_error not found
After running

Code:
# ./conky.SlackBuild
 
Old 06-20-2013, 05:38 PM   #18
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,412

Rep: Reputation: 1122Reputation: 1122Reputation: 1122Reputation: 1122Reputation: 1122Reputation: 1122Reputation: 1122Reputation: 1122Reputation: 1122
See this thread.
 
Old 06-22-2013, 08:46 AM   #19
zrdc28
Member
 
Registered: Dec 2007
Location: Alabama USA
Distribution: Slackware current
Posts: 251

Rep: Reputation: 40
http://ponce.cc/slackware/slackware-14.0/packages/

If you are a lazy guy like me just go to the above and get the package. He also has a compat32 conky.
I am using both the 32 & 64 bit versions with no problems. I could never get tolou from slackbuilds to work.
I understand that it was probably my fault but that is how it was done for me.

bash-4.2# conky
conky: error while loading shared libraries: libaudcore.so.1: wrong ELF class: ELFCLASS64

I got the the same error that you did when I used ponces build on the 32 and 64 bit, on 2 different machines.
I found that libaudcore.so.1 was a dependency of audacious and that audacious was not working on either of my computers,
the answer was to reinstall audacious and get it to work then conky worked.
 
Old 06-22-2013, 09:54 AM   #20
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,082

Rep: Reputation: 799Reputation: 799Reputation: 799Reputation: 799Reputation: 799Reputation: 799Reputation: 799
If you've installed from SlackBuilds, this is what you should have in /var/log/packages:
Code:
cd /var/log/packages
ls -l cairo*
-rw-r--r-- 1 root root  5086 Oct 18  2012 cairo-1.10.2-x86_64-2
ls -l lua*
-rw-r--r-- 1 root root 2837 Nov 29  2012 lua-5.1.5-x86_64-1_SBo
ls -l imlib2*
-rw-r--r-- 1 root root 3403 Jun 19 16:18 imlib2-1.4.5-x86_64-1_SBo
ls -l scons* 
-rw-r--r-- 1 root root 18630 Jun 19 16:05 scons-2.2.0-x86_64-1_SBo
ls -l tolua*
-rw-r--r-- 1 root root 1100 Jun 19 16:06 tolua++-1.0.93-x86_64-1_SBo
Note that all the above are 64-bit (no 32-bit!). Also, note that cairo is the library that comes with Slackware -- with "stock" Slackware you should see
Code:
locate libcairo
/opt/libreoffice3.6/program/libcairo.so.2
/usr/lib64/libcairo-script-interpreter.la
/usr/lib64/libcairo-gobject.so.2
/usr/lib64/libcairo-script-interpreter.so.2.11000.2
/usr/lib64/libcairo-gobject.la
/usr/lib64/libcairo.so.2.11000.2
/usr/lib64/libcairomm-1.0.la
/usr/lib64/libcairo-script-interpreter.so.2
/usr/lib64/libcairomm-1.0.so.1
/usr/lib64/libcairomm-1.0.so.1.4.0
/usr/lib64/libcairo-script-interpreter.so
/usr/lib64/libcairo.la
/usr/lib64/libcairomm-1.0.so
/usr/lib64/libcairo.so
/usr/lib64/libcairo.so.2
/usr/lib64/libcairo-gobject.so
/usr/lib64/libcairo-gobject.so.2.11000.2
That is, other than the line from LibreOffice, the above are the only things should should see -- if there are more files (from, say, your manual build of cairo), you might want to remove cairo entirely (with removepkg or make uninstall, depending upon how your built and installed) then get out you distribution media and install the "stock" cairo from it.

You appear to have multilib on your system; however, none of the above should have built as 32-bit packages, if they are, removepkg and redo the SlackBuild making sure that the packages are built 64-bit (they should just default to 64-bit). If you're getting any messages about wrong ELF class, you're trying to mix 32-bit and 64-bit and that don't and will not work.

Something else you can do to make sure you have the correct ELF class is
Code:
file $(locate libcairo) 
/opt/libreoffice3.6/program/libcairo.so.2:           ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped
/usr/lib64/libcairo-script-interpreter.la:           libtool library file, 
/usr/lib64/libcairo-gobject.so.2:                    symbolic link to `libcairo-gobject.so.2.11000.2'
/usr/lib64/libcairo-script-interpreter.so.2.11000.2: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped
/usr/lib64/libcairo-gobject.la:                      libtool library file, 
/usr/lib64/libcairo.so.2.11000.2:                    ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped
/usr/lib64/libcairomm-1.0.la:                        libtool library file, 
/usr/lib64/libcairo-script-interpreter.so.2:         symbolic link to `libcairo-script-interpreter.so.2.11000.2'
/usr/lib64/libcairomm-1.0.so.1:                      symbolic link to `libcairomm-1.0.so.1.4.0'
/usr/lib64/libcairomm-1.0.so.1.4.0:                  ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped
/usr/lib64/libcairo-script-interpreter.so:           symbolic link to `libcairo-script-interpreter.so.2.11000.2'
/usr/lib64/libcairo.la:                              libtool library file, 
/usr/lib64/libcairomm-1.0.so:                        symbolic link to `libcairomm-1.0.so.1.4.0'
/usr/lib64/libcairo.so:                              symbolic link to `libcairo.so.2.11000.2'
/usr/lib64/libcairo.so.2:                            symbolic link to `libcairo.so.2.11000.2'
/usr/lib64/libcairo-gobject.so:                      symbolic link to `libcairo-gobject.so.2.11000.2'
/usr/lib64/libcairo-gobject.so.2.11000.2:            ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped
Notice in both the above locate output that there is no /usr/lib, they're all /usr/lib64 (except the LibreOffice line)?

It's the same for lua:
Code:
file $(locate liblua)  
/usr/lib64/liblua.so.5.1:   symbolic link to `liblua.so.5.1.5'
/usr/lib64/liblua.so.5:     symbolic link to `liblua.so.5.1.5'
/usr/lib64/liblua.so:       symbolic link to `liblua.so.5.1.5'
/usr/lib64/liblua.so.5.1.5: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped
/usr/lib64/liblua.a:        current ar archive
And all the other required libraries: they will not be in /usr/lib and they will not be 32-bit.

Maybe the above won't help, maybe it will, but it's worth checking, methinks.

Hope this helps some.

Last edited by tronayne; 06-22-2013 at 10:07 AM.
 
Old 06-28-2013, 09:19 PM   #21
flyinggeorge
Member
 
Registered: Feb 2012
Location: United States
Distribution: Slackware 14.0
Posts: 160

Original Poster
Rep: Reputation: 3
Please excuse me for taking so long to get around to this. I have been in the middle of some "making ends meet" scenarios. But anyway, I did exactly as was suggested. I removed all the packages I had installed and instead replaced them with the packages from SlackBuilds.org. Here is what it looks like in my /var/packages: (I also removed all the 32-bit packages)

Code:
bash-4.2# cd /var/log/packages
bash-4.2# ls -l cairo*
-rw-r--r-- 1 root root 5057 Jun 28 21:58 cairo-1.10.2-x86_64-2
bash-4.2# ls -l lua*
-rw-r--r-- 1 root root 2837 Jun 28 21:47 lua-5.1.5-x86_64-1_SBo
bash-4.2# ls -l imlib2*
-rw-r--r-- 1 root root 3403 Jun 28 21:49 imlib2-1.4.5-x86_64-1_SBo
bash-4.2# ls -l scons*
-rw-r--r-- 1 root root 18630 Jun 28 21:50 scons-2.2.0-x86_64-1_SBo
bash-4.2# ls -l tolua*
-rw-r--r-- 1 root root 1100 Jun 28 21:51 tolua++-1.0.93-x86_64-1_SBo
bash-4.2#
Again, just to show I have no 32bit version of lua installed any more:

Code:
bash-4.2# locate liblua
/usr/lib64/liblua.so.5.1.5
/usr/lib64/liblua.a
/usr/lib64/liblua.so.5.1
/usr/lib64/liblua.so
/usr/lib64/liblua.so.5
/usr/lib64/vlc/plugins/lua/liblua_plugin.so
/usr/lib64/vlc/plugins/lua/liblua_plugin.la
And cairo

Code:
bash-4.2# locate libcairo
/usr/lib64/libcairo.so.2.11000.2
/usr/lib64/libcairo-script-interpreter.so.2
/usr/lib64/libcairo-script-interpreter.so
/usr/lib64/libcairo-gobject.so
/usr/lib64/libcairo-script-interpreter.so.2.11000.2
/usr/lib64/libcairo-gobject.la
/usr/lib64/libcairo.so
/usr/lib64/libcairo.la
/usr/lib64/libcairo-gobject.so.2.11000.2
/usr/lib64/libcairo-gobject.so.2
/usr/lib64/libcairo-script-interpreter.la
/usr/lib64/libcairo.so.2
And for lua (making sure I have the right ELF class)

Code:
bash-4.2# file $(locate liblua)                                                                                                                                                                                                                                               
/usr/lib64/liblua.so.5.1.5:                  ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped
/usr/lib64/liblua.a:                         current ar archive
/usr/lib64/liblua.so.5.1:                    symbolic link to `liblua.so.5.1.5'
/usr/lib64/liblua.so:                        symbolic link to `liblua.so.5.1.5'
/usr/lib64/liblua.so.5:                      symbolic link to `liblua.so.5.1.5'
/usr/lib64/vlc/plugins/lua/liblua_plugin.so: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped
/usr/lib64/vlc/plugins/lua/liblua_plugin.la: libtool library file,
Doing the same for libcairo spits out a bunch of stuff that doesn't make as much sense, but since conky doesn't complain about cairo at all, I don't think it is the problem:

Code:
bash-4.2# file $(locate libcairo)
/usr/lib64/libcairo.so.2.11000.2:                                                                                                                                                                                                                                                                           ELF 64-bit LSB shared object, x86-64, version 1 (SY                                                                                                                                                                                               SV), dynamically linked, stripped
/usr/lib64/libcairo-script-interpreter.so.2:                                                                                                                                                                                                                                                                symbolic link to `libcairo-script-interpreter.so.2.                                                                                                                                                                                               11000.2'
/usr/lib64/libcairo-script-interpreter.so:                                                                                                                                                                                                                                                                  symbolic link to `libcairo-script-interpreter.so.2.                                                                                                                                                                                               11000.2'
/usr/lib64/libcairo-gobject.so:                                                                                                                                                                                                                                                                             symbolic link to `libcairo-gobject.so.2.11000.2'
/usr/lib64/libcairo-script-interpreter.so.2.11000.2:                                                                                                                                                                                                                                                        ELF 64-bit LSB shared object, x86-64, version 1 (SY                                                                                                                                                                                               SV), dynamically linked, stripped
/usr/lib64/libcairo-gobject.la:                                                                                                                                                                                                                                                                             libtool library file, 
/usr/lib64/libcairo.so:                                                                                                                                                                                                                                                                                     symbolic link to `libcairo.so.2.11000.2'
/usr/lib64/libcairo.la:                                                                                                                                                                                                                                                                                     libtool library file, 
/usr/lib64/libcairo-gobject.so.2.11000.2:                                                                                                                                                                                                                                                                   ELF 64-bit LSB shared object, x86-64, version 1 (SY                                                                                                                                                                                               SV), dynamically linked, stripped
/usr/lib64/libcairo-gobject.so.2:                                                                                                                                                                                                                                                                           symbolic link to `libcairo-gobject.so.2.11000.2'
/usr/lib64/libcairo-script-interpreter.la:                                                                                                                                                                                                                                                                  libtool library file, 
/usr/lib64/libcairo.so.2:                                                                                                                                                                                                                                                                                   symbolic link to `libcairo.so.2.11000.2'
/home/gene/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/share/doc/libca                                                                                                                                                                                               iro2:                        directory
/home/gene/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/share/doc/libca                                                                                                                                                                                               iro2/README.gz:              gzip compressed data, from Unix, max compression
/home/gene/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/share/doc/libca                                                                                                                                                                                               iro2/changelog.Debian.gz:    gzip compressed data, from Unix, max compression
/home/gene/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/share/doc/libca                                                                                                                                                                                               iro2/AUTHORS.gz:             gzip compressed data, from Unix, max compression
/home/gene/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/share/doc/libca                                                                                                                                                                                               iro2/changelog.gz:           gzip compressed data, from Unix, max compression
/home/gene/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/share/doc/libca                                                                                                                                                                                               iro2/copyright:              ASCII text
/home/gene/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/share/doc/libca                                                                                                                                                                                               iro2/NEWS.gz:                gzip compressed data, from Unix, max compression
/home/gene/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-                                                                                                                                                                                               gnu/libcairo.so.2.11000.2:   ELF 32-bit LSB shared object, Intel 80386, version                                                                                                                                                                                                1 (SYSV), dynamically linked, BuildID[sha1]=0x72c933979ed0c6cea3b54ecf23479de8aa                                                                                                                                                                                               3636cf, stripped
/home/gene/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-                                                                                                                                                                                               gnu/libcairo.so.2:           symbolic link to `libcairo.so.2.11000.2'
/home/gene/.local/share/Steam/ubuntu12_32/steam-runtime/i386/installed/libcairo2                                                                                                                                                                                               _1.10.2-6.1ubuntu3_i386.md5: ASCII text
/home/gene/.local/share/Steam/ubuntu12_32/steam-runtime/i386/installed/libcairo2                                                                                                                                                                                               bash-4.2# file $(locate libcairo)
/usr/lib64/libcairo.so.2.11000.2:                                                                                                                                                                                                                                                                           ELF 64-bit LSB shared object, x86-64, version 1 (SY                                                                                                                                                                                               SV), dynamically linked, stripped
/usr/lib64/libcairo-script-interpreter.so.2:                                                                                                                                                                                                                                                                symbolic link to `libcairo-script-interpreter.so.2.                                                                                                                                                                                               11000.2'
/usr/lib64/libcairo-script-interpreter.so:                                                                                                                                                                                                                                                                  symbolic link to `libcairo-script-interpreter.so.2.                                                                                                                                                                                               11000.2'
/usr/lib64/libcairo-gobject.so:                                                                                                                                                                                                                                                                             symbolic link to `libcairo-gobject.so.2.11000.2'
/usr/lib64/libcairo-script-interpreter.so.2.11000.2:                                                                                                                                                                                                                                                        ELF 64-bit LSB shared object, x86-64, version 1 (SY                                                                                                                                                                                               SV), dynamically linked, stripped
/usr/lib64/libcairo-gobject.la:                                                                                                                                                                                                                                                                             libtool library file, 
/usr/lib64/libcairo.so:                                                                                                                                                                                                                                                                                     symbolic link to `libcairo.so.2.11000.2'
/usr/lib64/libcairo.la:                                                                                                                                                                                                                                                                                     libtool library file, 
/usr/lib64/libcairo-gobject.so.2.11000.2:                                                                                                                                                                                                                                                                   ELF 64-bit LSB shared object, x86-64, version 1 (SY                                                                                                                                                                                               SV), dynamically linked, stripped
/usr/lib64/libcairo-gobject.so.2:                                                                                                                                                                                                                                                                           symbolic link to `libcairo-gobject.so.2.11000.2'
/usr/lib64/libcairo-script-interpreter.la:                                                                                                                                                                                                                                                                  libtool library file, 
/usr/lib64/libcairo.so.2:                                                                                                                                                                                                                                                                                   symbolic link to `libcairo.so.2.11000.2'
/home/gene/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/share/doc/libca                                                                                                                                                                                               iro2:                        directory
/home/gene/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/share/doc/libca                                                                                                                                                                                               iro2/README.gz:              gzip compressed data, from Unix, max compression
/home/gene/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/share/doc/libca                                                                                                                                                                                               iro2/changelog.Debian.gz:    gzip compressed data, from Unix, max compression
/home/gene/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/share/doc/libca                                                                                                                                                                                               iro2/AUTHORS.gz:             gzip compressed data, from Unix, max compression
/home/gene/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/share/doc/libca                                                                                                                                                                                               iro2/changelog.gz:           gzip compressed data, from Unix, max compression
/home/gene/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/share/doc/libca                                                                                                                                                                                               iro2/copyright:              ASCII text
/home/gene/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/share/doc/libca                                                                                                                                                                                               iro2/NEWS.gz:                gzip compressed data, from Unix, max compression
/home/gene/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-                                                                                                                                                                                               gnu/libcairo.so.2.11000.2:   ELF 32-bit LSB shared object, Intel 80386, version                                                                                                                                                                                                1 (SYSV), dynamically linked, BuildID[sha1]=0x72c933979ed0c6cea3b54ecf23479de8aa                                                                                                                                                                                               3636cf, stripped
/home/gene/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-                                                                                                                                                                                               gnu/libcairo.so.2:           symbolic link to `libcairo.so.2.11000.2'
/home/gene/.local/share/Steam/ubuntu12_32/steam-runtime/i386/installed/libcairo2                                                                                                                                                                                               _1.10.2-6.1ubuntu3_i386.md5: ASCII text
/home/gene/.local/share/Steam/ubuntu12_32/steam-runtime/i386/installed/libcairo2                                                                                                                                                                                               _1.10.2-6.1ubuntu3_i386:     ASCII text
/home/gene/Downloads/cairo-5c-1.5/debian/libcairo5c-0.install:                                                                                                                                                                                                                                              ASCII text
/home/gene/Downloads/cairomm-1.10.0/cairomm/.libs/libcairomm-1.0.so:                                                                                                                                                                                                                                        symbolic link to `libcairomm-1.0.so.1.4.0'
/home/gene/Downloads/cairomm-1.10.0/cairomm/.libs/libcairomm-1.0.so.1:                                                                                                                                                                                                                                      symbolic link to `libcairomm-1.0.so.1.4.0'
/home/gene/Downloads/cairomm-1.10.0/cairomm/.libs/libcairomm-1.0.so.1.4.0:                                                                                                                                                                                                                                  ELF 64-bit LSB shared object, x86-64, version 1 (SY                                                                                                                                                                                               SV), dynamically linked, not stripped
/home/gene/Downloads/cairomm-1.10.0/cairomm/.libs/libcairomm-1.0.la:                                                                                                                                                                                                                                        symbolic link to `../libcairomm-1.0.la'
/home/gene/Downloads/cairomm-1.10.0/cairomm/.libs/libcairomm-1.0.lai:                                                                                                                                                                                                                                       libtool library file, 
/home/gene/Downloads/cairomm-1.10.0/cairomm/libcairomm-1.0.la:                                                                                                                                                                                                                                              libtool library file, 
/home/gene/Downloads/conky-1.9.0/lua/libcairo-helper.h:                                                                                                                                                                                                                                                     C source, ASCII text
/home/gene/Downloads/conky-1.9.0/lua/libcairo.c:                                                                                                                                                                                                                                                            C source, ASCII text
/home/gene/Downloads/conky-1.9.0/lua/.deps/libcairo_la-libcairo.Plo:                                                                                                                                                                                                                                        ASCII text
It looks like steam uses the 32-bit cairo package, hopefully that still runs. Anyway, even after all of this, I am getting the exact same error with the slackbuild.

Code:
bash-4.2# ./conky.SlackBuild

checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking for objdir... .libs
checking if x86_64-slackware-linux-gcc supports -fno-rtti -fno-exceptions... no
checking for x86_64-slackware-linux-gcc option to produce PIC... -fPIC -DPIC
checking if x86_64-slackware-linux-gcc PIC flag -fPIC -DPIC works... yes
checking if x86_64-slackware-linux-gcc static flag -static works... yes
checking if x86_64-slackware-linux-gcc supports -c -o file.o... yes
checking if x86_64-slackware-linux-gcc supports -c -o file.o... (cached) yes
checking whether the x86_64-slackware-linux-gcc linker (/usr/x86_64-slackware-linux/bin/ld -m elf_x86_64) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
checking whether x86_64-slackware-linux-gcc and cc understand -c and -o together... yes
checking for pkg-config... yes
checking for x86_64-slackware-linux-pkg-config... no
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.19... yes
checking for fopencookie... yes
checking for funopen... no
checking ncurses.h usability... yes
checking ncurses.h presence... yes
checking for ncurses.h... yes
checking for Audacious... yes
checking audacious/audctrl.h usability... yes
checking audacious/audctrl.h presence... yes
checking for audacious/audctrl.h... yes
checking audacious/dbus.h usability... yes
checking audacious/dbus.h presence... yes
checking for audacious/dbus.h... yes
checking glib.h usability... yes
checking glib.h presence... yes
checking for glib.h... yes
checking glib-object.h usability... yes
checking glib-object.h presence... yes
checking for glib-object.h... yes
checking for X11... yes
checking for Imlib2... yes
checking for LUA... yes
checking for cairo... yes
checking for cairo_xlib... yes
checking for tolua++... tolua++
checking for library containing tolua_error... no
configure: error: tolua_error not found
Thank you for the suggestions, but tolua_error is either inside of a package I have not installed for some reason, or ... I don't know.
 
Old 06-28-2013, 11:04 PM   #22
glorsplitz
Member
 
Registered: Dec 2002
Distribution: slackware!
Posts: 253

Rep: Reputation: 27
I've been curious about conky, checked it out at slackbuilds, followed dependencies, works fine, no errors.

I have all the exact packages mentioned in previous posts here installed.

Found this thread. Maybe helps?
 
Old 06-28-2013, 11:48 PM   #23
flyinggeorge
Member
 
Registered: Feb 2012
Location: United States
Distribution: Slackware 14.0
Posts: 160

Original Poster
Rep: Reputation: 3
In an attempt to follow that thread, I installed tolua, so now I have tolua and tolua++ (both 64bit)

Code:
bash-4.2# ls /var/log/packages/ | grep tolua
tolua++-1.0.93-x86_64-1_SBo
tolua-5.1b-x86_64-1an
And I tried adding LUA51_LIBS="-llua -lm" to the slackbuild, maybe I put it in the wrong place?

Code:
if [ "${LUA:-yes}" = "yes" ]; then
  lua_params="--enable-lua --enable-lua-cairo --enable-imlib2 --enable-lua-imlib2 LUA51_LIBS='-llua'"
else
  lua_params="--disable-lua"
fi
I added it to this code block because later in the script, the variable $lua_params is called upon when enabling lua support. From what I understood from the thread linked, that is where this should go.

Code:
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
  --prefix=/usr \
  --libdir=/usr/lib${LBIDIRSUFFIX} \
  --sysconfdir=/etc \
  --mandir=/usr/man \
  --enable-shared=yes \
  --enable-static=no \
  --enable-ibm \
  --enable-hddtemp \
  --enable-xft \
  --enable-weather-metar \
  --enable-weather-xoap \
  --enable-portmon \
  --enable-audacious \
  --enable-mpd=yes \
  --enable-rss=yes \
  --enable-wlan=yes \
  $lua_params \
  --build=$ARCH-slackware-linux \
  --host=$ARCH-slackware-linux
But I am still getting the same error. I am thoroughly stumped.

*Edit, forgot to mention that the -lm switch in $lua_params breaks the build returning:

Code:
configure: error: unrecognized option: `-lm''
Try `./configure --help' for more information
*Edit #2, Maybe the -lm switch is why the whole thing is breaking? What library/dependency is that switch trying to access? Perhaps that is the reason I cannot build.

Last edited by flyinggeorge; 06-28-2013 at 11:55 PM.
 
Old 06-29-2013, 03:26 AM   #24
nick_th_fury
Member
 
Registered: Jun 2003
Location: Texas
Distribution: Slackware, NetBSD
Posts: 151

Rep: Reputation: 23
Quote:
Originally Posted by flyinggeorge View Post
I tried the conky i486 package, but it crashes on startup telling me:


I don't see a 64bit package on that site

Is there an i486 audacious package, or an option I'm not aware of to run conky without support for libaudcore.so? This seems to have gotten me one step closer though, and for that, I thank you.
The 64bit packages are in a different directory,
http://ponce.cc/slackware/slackware6..._64-1ponce.txz
 
Old 06-29-2013, 07:29 AM   #25
flyinggeorge
Member
 
Registered: Feb 2012
Location: United States
Distribution: Slackware 14.0
Posts: 160

Original Poster
Rep: Reputation: 3
Quote:
Originally Posted by nick_th_fury View Post
The 64bit packages are in a different directory,
http://ponce.cc/slackware/slackware6..._64-1ponce.txz
I ended up finding this out. Thank you though for making me look a little harder! :P
 
Old 06-30-2013, 01:33 PM   #26
flyinggeorge
Member
 
Registered: Feb 2012
Location: United States
Distribution: Slackware 14.0
Posts: 160

Original Poster
Rep: Reputation: 3
Okay, I'm not exactly sure how I managed to fix this, but here is what I did. I abandoned the slackbuild and built conky-1.9 from source. Like this:

Code:
#./configure --enable-imlib2 --enable-lua-cairo
...
#make
...
#make install
Now when I type conky -v I get:

Code:
bash-4.2$ conky -v
Conky 1.9.0 compiled Sun Jun 30 13:36:36 EDT 2013 for Linux 3.2.29 (x86_64)

Compiled in features:

System config file: /usr/local/etc/conky/conky.conf
Package library path: /usr/local/lib/conky

 X11:
  * Xdamage extension
  * XDBE (double buffer extension)
  * Xft
  * ARGB visual

 Music detection:
  * MPD
  * MOC

 General:
  * math
  * hddtemp
  * portmon
  * config-output
  * Imlib2
  * apcupsd
  * iostats
  * ncurses
  * Lua

  Lua bindings:
   * Cairo
   * Imlib2
And I have successfully installed a cairo/lua theme. Everything works like a charm.
 
Old 06-30-2013, 02:12 PM   #27
glorsplitz
Member
 
Registered: Dec 2002
Distribution: slackware!
Posts: 253

Rep: Reputation: 27
good to hear flyinggeorge, conky -v for shows almost same for me. I included conkyforecast

System config file: /etc/conky/conky.conf
Package library path: /usr/lib64/conky

under Music detection: I also have
* Audacious

under General: I also have
* Curl
* RSS
* Weather (METAR)
* Weather (XOAP)
* wireless
* support for IBM/Lenovo notebooks

now I just have to figure out how get out all the bells and whistles pretty.
 
Old 06-30-2013, 02:46 PM   #28
flyinggeorge
Member
 
Registered: Feb 2012
Location: United States
Distribution: Slackware 14.0
Posts: 160

Original Poster
Rep: Reputation: 3
I don't currently use Curl or Audacious and all that other stuff, and wlan0 is the only internet interface I'm using right now, and the graph works perfectly fine. I finally found a theme I was happy with and tweaked it a little to suit my liking. Thank you everyone for trying to help!

The theme I found is just this:

http://harshit1990.deviantart.com/ar...nity-306921086

I adjusted it for my resolution, and changed the backtrack logo to a slackware one. Screenshot attached.
Attached Images
File Type: jpg conky.jpg (183.8 KB, 16 views)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Conky with lua. flyinggeorge Linux - Software 6 06-19-2013 03:00 PM
LXer: Configure conky-Lua in Ubuntu (11.10 & 12.04), Fedora, debian and LinuxMint | Howto Conky LXer Syndicated Linux News 0 03-06-2012 12:40 PM
Conky + lua flyinggeorge Linux - Software 6 03-05-2012 08:47 PM
lua with cairo doesnt work in conky Bindestreck Slackware 15 08-19-2011 03:35 AM
Trying to get Lua to work with Conky AbsoluteZ3r0 Linux - Software 0 08-17-2011 10:01 AM


All times are GMT -5. The time now is 12:49 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration