LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 10-27-2009, 03:40 PM   #1
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Configuring Wake-On-LAN With Slackware 12.2


I'm trying to enable wake-on-lan (wol) with two of my machines. I've read many web pages and forum threads. I am finding little useful information with respect to troubleshooting, especially with Slackware.

The machine I am trying to awaken uses an Asus M3N78-EM motherboard. I'm using the latest BIOS. In the BIOS I enabled Onboard LAN Boot ROM and Power On By PCI/PCIE Device. Suspend mode is configured to Auto.

I built and installed the wol package from slackbuilds.org. For proof-of-concept and testing purposes, I temporarily modified rc.d/rc.6. Just after the rc.inet1 stop command I added:

ethtool -s $INET_IFACE wol g

At the end of rc.6, just before the reboot/halt commands are issued, I added

ethtool $INET_IFACE

I added the latter command to verify the wol change took place during shutdown. Watching the shutdown screen reveals the ethtool command does indeed enable wol.

The machine is shutdown with the command:

/bin/shutdown -t1 -h now

From another machine I issue the wol command:

wol -v $MAC_ADDRESS

The stdout message is Waking up $MAC_ADDRESS with 255.255.255.255:40000....

The other machine never awakens. The machine NIC LED is on and my network switch shows the cable is connected. I know the machine is on with the +5v supply enabled because I can successfully set a wakeup time and the machine awakens from that mode. The machine also awakens with a PS/2 connected keyboard using the wake-on-keyboard BIOS setting.

The on-board NIC uses the forcedeth driver. Although a bit dated and possibly no longer related, I read several reports that wol is broken with that driver unless the MAC address is reversed. I tried reversing the address with no success.

There are no relevant messages in the logs.

At this point I am not looking for fancy scripts. At this point I only want proof-of-concept with manual usage of the commands.

Any ideas?

Thanks again.

Solved here.

Last edited by Woodsman; 03-22-2010 at 12:27 PM.
 
Old 10-27-2009, 09:12 PM   #2
ljb643
Member
 
Registered: Nov 2003
Posts: 293

Rep: Reputation: Disabled
It works OK for me. (Slackware 13.0, but that should not matter.) Suggestions that might help you troubleshoot:

Quote:
In the BIOS I enabled Onboard LAN Boot ROM and Power On By PCI/PCIE Device. Suspend mode is configured to Auto.
Different BIOSes, but this doesn't feel right to me. The BIOSes I've used specifically have an option Wake on LAN that you turn on. Nothing to do with LAN Boot ROM or PCI power-on. That's all I needed to do, Wake on LAN enabled.

Quote:
ethtool -s $INET_IFACE wol g
I didn't have to do that, or change my rc.* files. When I checked with 'ethtool eth0' it told me that it "supports Wake-on: g", and "Wake-on: g". Which I took to mean that wake-on with magic packet was on by default (but it could be just my NIC/driver).

If you have wireshark on the PC you are trying to wake up, you could use it to make sure the packet is getting through. Just in case something is blocking it.

If you still can't wake up the PC, then to me it starts to look like an unhappy NIC/driver setup for WOL.
 
Old 10-27-2009, 09:52 PM   #3
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Original Poster
Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Quote:
It works OK for me.
Are you using the same motherboard?

Quote:
Different BIOSes, but this doesn't feel right to me. The BIOSes I've used specifically have an option Wake on LAN that you turn on. Nothing to do with LAN Boot ROM or PCI power-on. That's all I needed to do, Wake on LAN enabled.
I haven't found anything in the BIOS specifically using the wake-on-lan terms. From what I have read online, one of the options I have listed is the correct one.

Quote:
I didn't have to do that, or change my rc.* files. When I checked with 'ethtool eth0' it told me that it "supports Wake-on: g", and "Wake-on: g". Which I took to mean that wake-on with magic packet was on by default (but it could be just my NIC/driver).
I would surmise the same. That is, seems to me if the BIOS wol option is enabled correctly, then ethtool should detect that automatically. I'll check the BIOS again. Perhap the wol is cleverly hidden.

Quote:
If you have wireshark on the PC you are trying to wake up, you could use it to make sure the packet is getting through.
I ran wireshark on the target PC and I saw the magic packet request. Therfore nothing is blocking the packet broadcast.

Last edited by Woodsman; 10-27-2009 at 10:21 PM.
 
Old 10-28-2009, 09:27 PM   #4
ljb643
Member
 
Registered: Nov 2003
Posts: 293

Rep: Reputation: Disabled
Quote:
Are you using the same motherboard?
No, sorry, I should have said, different motherboard and NIC.

More tests, more info. With Wake on LAN enabled in the BIOS, Slackware 13 (kernel 2.6.29.6) sets this PC's NIC to enable Wake on LAN. But Xubuntu 9.04 (Kernel 2.6.28-16) does not. For Xubuntu I had to use "ethtool -s wol g" to enable it, before shutting down. (I don't have Slackware 12.2 on that PC so I can't try it. I don't know if it is kernel dependent or something else in Xubuntu is doing it.)

In all cases, if my network switch link light (and NIC link light) are on when the PC is off, then Wake on LAN worked. But I don't think that is always true. (Well, you proved it isn't.) I think a PC can be off with the NIC "hot" but not responding to magic packet wake-up.

Bottom line, to me, is that if the network switch light is on with the target PC off, and you confirmed (with the target PC on) that the magic packet can get through, but you still can't wake the PC up, then your motherboard/BIOS/NIC aren't going to do it.
 
Old 12-10-2009, 11:28 PM   #5
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Original Poster
Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Solved

Solved!

The fix was straightforward. In the BIOS, I had to change the Suspend Mode option from "Auto" to "S3 Only." The other option is "S1 (POS) Only." I don't know why Auto failed but I just finished waking my M3N78-EM system five times in a row. Woot!

According the user guide, "Auto" means detected by the operating system. Anybody know how the operating system is supposed to detect (or control) the suspend state? Is there a config option I need to set to make the "Auto" mode function correctly?

WOL works with my M2NPV-VM too. The weird part is I have to send the MAC address backwards. A bug in the forcedeth NIC driver that was supposed to have been fixed some time ago but apparently hasn't or has been reintroduced.

P.S. Would somebody please remind me how to insert the word "Solved" in the heading of my original thread post? Thanks.

Last edited by Woodsman; 12-10-2009 at 11:55 PM.
 
Old 12-11-2009, 07:11 PM   #6
mRgOBLIN
Slackware Contributor
 
Registered: Jun 2002
Location: New Zealand
Distribution: Slackware
Posts: 999

Rep: Reputation: 227Reputation: 227Reputation: 227
Well I've never actually started a thread but I think it's in the "Thread Tools" dropdown at the top of your first post.
 
Old 12-11-2009, 10:34 PM   #7
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Original Poster
Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Thread Tools.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wake on Lan & Sleep on lan? ufmale Linux - Networking 1 06-25-2008 06:34 PM
Wake On LAN on Slackware 12 alpha_hack Slackware 3 04-14-2008 07:29 PM
wake on lan magic packet does not wake. albean Linux - Networking 1 06-30-2007 04:57 PM
wake on lan with slackware mangel Slackware 3 06-18-2006 02:59 PM
configuring lan to connect thru slackware 10.2 caghiebe Linux - Networking 1 11-28-2005 05:05 PM


All times are GMT -5. The time now is 10:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration