LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Configuring the mouse buttons? (http://www.linuxquestions.org/questions/slackware-14/configuring-the-mouse-buttons-51679/)

Seph64 03-25-2003 01:03 PM

Configuring the mouse buttons?
 
I got a MS Intellimouse Explorer 3.0a, it has 5 buttons; Right click, middle click, and left click (I got the wheel to work), then it has 2 thumb buttons. It's those thumb buttons that I want to change. I want one of them to act like like the page up button and the other to act like the page down button (you know, the pgup and pgdwn buttons on the keyboard).

Is this possible?

trn 03-25-2003 01:13 PM

use the search button on this site.. there is already a great thread about this in the hardware fourm or somewhere like that.

hecresper 03-25-2003 01:25 PM

Re: Configuring the mouse buttons?
 
Quote:

Originally posted by Seph64
I got a MS Intellimouse Explorer 3.0a, it has 5 buttons; Right click, middle click, and left click (I got the wheel to work), then it has 2 thumb buttons. It's those thumb buttons that I want to change. I want one of them to act like like the page up button and the other to act like the page down button (you know, the pgup and pgdwn buttons on the keyboard).

Is this possible?

Go here: http://p-two.net :)

Seph64 03-25-2003 01:52 PM

Thanks for the tips, but everything you both suggest don't work. I tried to type in (after editing the XF86Config file) xmodmap -e "pointer = 1 2 3 6 7 4 5" But that gives me the error: illegal number of buttons (something like this) 7, must use 5.

And I am not the only one who had received that error, many other people have as well.

For now, I'll just keep my current settings..

hecresper 03-25-2003 04:19 PM

That error message comes up because X needs to restarted. As in exit out of KDE or GNOME and go back in them. If you're going straight to graphical login, then it might require a restart of the computer but don't quote me on that. I did get that message, but after exiting KDE and going back in, everything worked.

On a different note, instead of typing that xmodmap command everytime, this is what I did:

pico /etc/X11/.Xmodmap

And added this line inside that file:

pointer = 1 2 3 6 7 4 5

Now X will read that file at startup and implement those settings for me. I've yet to figure out how to make the imwheel command run automatically at startup. :-)


All times are GMT -5. The time now is 12:28 AM.