-   Slackware (
-   -   Configuring the mouse!! (

maginotjr 06-29-2005 01:10 AM

Configuring 2 mouses!! [solved]
Thats the deal, my mouse works perfectly! The problem is that I use a notebook, so when I plug a mouse in my usb port the led turns on, in dmesg it see my mouse ( microsoft intellimouse usb ) buuuut doesnt work! nice isnt ? To make my mouse usb mouse work I have to go in the xorg.conf file and change some lines in the InputDevice section but when I do this my notebook's mouse stops.

I remmember never had this problem with debian, I just plug the mouse and the 2 works perfectly, even the Wheel... now I cant get the 2 working together... this is very frustrating :/ :confused:

Im using kernel 2.4 here... but I dont think this may be a kernel problem.

Any ideia?


maginotjr 06-29-2005 01:54 AM

yeah! Problem solved!

Lets share with the community:

making 2 mouse work, this is my Mouse section in the xorg.conf file:


Section "ServerLayout"
Identifier    " Configured"
Screen      0  "Screen0" 0 0
InputDevice    "Mouse0" "CorePointer"
InputDevice    "Mouse1"
InputDevice    "Keyboard0" "CoreKeyboard"

Section "InputDevice"
Identifier  "Mouse0"
Driver      "mouse"
Option      "Protocol" "auto"
Option      "Device" "/dev/mouse"
Option      "Core

Section "InputDevice"
Identifier  "Mouse1"
Driver      "mouse"
Option      "Protocol" "auto"
Option      "Device" "/dev/psaux"
Option      "SendCoreEvents"

Lets explain, when you see CorePointer or CoreKeyboard its what identifies your default keyboard and mouse, you cant have 2 default but you can have an other input device to Send Core Events, its where the Option "SendCoreEvents" with this option Xorg will not ignore the second section.


I hope to help someone with this...

ps: now lets go try make my mouse wheel work! O_o

Namaseit 06-29-2005 02:58 AM

<mouse device section>

Option "ZAxisMapping" "4 5"

maginotjr 06-29-2005 09:28 AM

Two corrections for a good working, Mouse0 must be the default mouse, so change the Mouse1 to Mouse0
Because the PS/2 mouse is default in the notebook, it cant me removed. And change the Link /dev/mouse to the real device to avoid problems, like the most the right place is /dev/input/mice


this is all. Now you can use with or without the external mouse without any screen in the start saying that your mouse is not configured.

All times are GMT -5. The time now is 10:34 PM.