LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-10-2004, 11:23 AM   #1
plisken
Member
 
Registered: Dec 2001
Location: Scotland
Distribution: Slackware 9.1/13.37/14 RedHat 6.2/7/EL6.5 SuSE 8.2/11.1
Posts: 454

Rep: Reputation: 30
Configuring sendmail on slack 9.1


I have been trying for a few days and getting no where with this, it is really bugging me too, as I have successfully setup sendmail on a few different machines in the past.

I am running Slackware 9.1

I can send mail from the box to other users on the box.
I can send mail through the box, from my Windows clients to the internet.
I can NOT send mail from the box to the internet.

What I get, and I think this is the problem, is returned mail, with a 550 cannot route to sender, and the address is as follows:

user@boxname.mydomain.com

I think I need to remove the boxname here, but can't for the life of me remember how to do it.
Obviously mydomain.com is registered and I can receive mail from the internet for users on the box, but boxname.mydomain.com is not registered and I think this is where the problem is...


All help would be very greatly appreciated...
 
Old 03-10-2004, 12:46 PM   #2
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
Clearly someone with 190 posts should realize we don't allow double posting.

Your other thread is found here: http://www.linuxquestions.org/questi...hreadid=155435

This one has been reported and will be closed.

Regards.
 
Old 03-11-2004, 01:48 AM   #3
plisken
Member
 
Registered: Dec 2001
Location: Scotland
Distribution: Slackware 9.1/13.37/14 RedHat 6.2/7/EL6.5 SuSE 8.2/11.1
Posts: 454

Original Poster
Rep: Reputation: 30
aggrrrrrrrr

HELP.... I am contemplating a Windows 2003 server install...LOL

Sorry, says I in a sheepish voice...
 
Old 03-11-2004, 03:30 AM   #4
ricardson
LQ Newbie
 
Registered: Mar 2004
Location: Dongguan - China
Distribution: Slackware 14, i3(4.2)
Posts: 22

Rep: Reputation: 16
You need to change the /etc/mail/local-host-name and put name off your machine like below:

mydomain.com
boxname.mydomain.com

And check if you MX pointed to the same ip that your machine.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
configuring sendmail.. piyushiitk Linux - Newbie 2 08-20-2005 10:40 AM
need help configuring sendmail blish_blash Linux - Software 0 10-29-2004 07:38 AM
help with configuring sendmail bluestorm Linux - General 5 12-05-2003 10:30 AM
configuring sendmail artur Linux - Software 1 04-03-2002 11:04 PM
configuring sendmail rameshks Linux - General 3 05-20-2001 02:56 AM


All times are GMT -5. The time now is 05:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration