LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   ./configure --prefix= (http://www.linuxquestions.org/questions/slackware-14/configure-prefix%3D-218925/)

plan9 08-17-2004 04:04 PM

./configure --prefix=
 
I'm trying to install a Openssh into it's default location in slack-current. i have noticed that if I use "./configure --prefix=/" I get some crazy looking info after ./configure runs:

OpenSSH has been configured with the following options:
User binaries: //bin
System binaries: //sbin
Configuration files: //etc
Askpass program: //libexec/ssh-askpass
Manual pages: //man/manX
PID file: /var/run
Privilege separation chroot path: /var/empty
sshd default user PATH: /usr/bin:/bin:/usr/sbin:/sbin://bin
Manpage format: doc


where as if i type "./configure --prefix=" all seems to be correct:

OpenSSH has been configured with the following options:
User binaries: /bin
System binaries: /sbin
Configuration files: /etc
Askpass program: /libexec/ssh-askpass
Manual pages: /man/manX
PID file: /var/run
Privilege separation chroot path: /var/empty
sshd default user PATH: /usr/bin:/bin:/usr/sbin:/sbin
Manpage format: doc

so what do you think? i should go with the second command b/c that seems to put everything into the correct location, right?

thanks,
plan9 <slightly nervous b/c he's never really messed with configure>

david_ross 08-17-2004 04:12 PM

Either option should work fine.

plan9 08-17-2004 09:11 PM

Thank you, i'll give it a go and let you know how it works out for me!

plan9

vksingh 01-03-2013 03:26 AM

check echo $PREFIX.

It looks like $PREFIX=/ in your system

ponce 01-03-2013 04:42 AM

hi vksingh.

unfortunately this topic is 8 years and an half old and plan9 isn't connecting to linuxquestion since seven years.

please, don't resurrect old threads, if you want to help respond only to recent ones.

Alien Bob 01-03-2013 04:44 AM

If you want to mess with one of the stock Slackware packages without knowing what you are doing then at least check the Slackware-provided build script. It will show you that in Slackware, the default prefix is "/usr".

Why can you not just download and install the Slackware openssh package instead of compiling it with random parameters?

Eric

Edit: O sh*t, did not see that this thread was so old... the second today.


All times are GMT -5. The time now is 11:16 AM.