LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-18-2014, 02:07 PM   #1
nivieru
Member
 
Registered: Feb 2008
Posts: 48

Rep: Reputation: 7
configure preferred sound device for all applications


Hi all,
I'm having a bit of trouble telling programs to use my external usb sound card.
The card is working correctly, I can select it as default in the phonon settings and get kde and amarok (and probably other kde applications) to use it.
However, everything else (clementine, firefox, vlc) insist on using the internal card.

how can I get clementine, vlc etc to use the external sound card like kde does?

thanks,
niv
 
Old 03-18-2014, 02:18 PM   #2
ml4711
Member
 
Registered: Aug 2012
Location: Ryomgård, Danmark
Distribution: Slackware64
Posts: 83

Rep: Reputation: 37
This works for me.

Create .asoundrc in your home dir with this contents:

Code:
pcm.!default {
    type hw
    card Audio
}

ctl.!default {
    type hw
    card Audio
}
use aplay -l to show the real name of the card

aplay -l
card 2: Audio [USB Audio], device 0: USB Audio [USB Audio]
Subdevices: 0/1
Subdevice #0: subdevice #0

Last edited by ml4711; 03-18-2014 at 02:21 PM.
 
3 members found this post helpful.
Old 03-18-2014, 02:53 PM   #3
nivieru
Member
 
Registered: Feb 2008
Posts: 48

Original Poster
Rep: Reputation: 7
Thanks, that worked!

just to be more verbal for anyone else who might need it,
in the solution above replace "Audio" with the name that aplay -l gives you
Code:
card #: Name_of_card ...
 
Old 04-01-2014, 07:09 PM   #4
Snerk
LQ Newbie
 
Registered: Dec 2012
Location: COlorado Springs
Distribution: Linux Mint
Posts: 2

Rep: Reputation: Disabled
So in the example given, would you put

Code:
card Audio
or
Code:
card Audio [USB Audio]
?
 
Old 04-02-2014, 03:12 AM   #5
ml4711
Member
 
Registered: Aug 2012
Location: Ryomgård, Danmark
Distribution: Slackware64
Posts: 83

Rep: Reputation: 37
Code:
card Audio
 
  


Reply

Tags
kde, phonon, sound


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to define preferred applications on mate-desktop? gtludwig Slackware 14 04-22-2013 05:50 PM
Multiple applications cannot access the sound device at the same time ninioArg Debian 5 07-31-2012 12:21 PM
Multiple applications accessing sound device slackiz Linux - Desktop 1 10-27-2007 06:43 AM
Configure audio device for some applications paraiso Linux - Newbie 3 10-18-2005 02:47 PM
htmlview and preferred applications zyzzyr Fedora 0 12-21-2003 09:28 AM


All times are GMT -5. The time now is 06:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration