LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-06-2012, 10:38 PM   #1
afreitascs
Member
 
Registered: Aug 2004
Location: Brasil
Distribution: Slackware_Cur-64_mult
Posts: 433

Rep: Reputation: 30
".config" directory in my root


".config" directory in my root .

There is also a directory "run" ( !? )

look

Quote:
base1@base1:~$ ls -a /
./ bin/ etc/ lib64/ mnt/ root/ srv/ usr/
../ boot/ home/ lost+found/ opt/ run/ sys/ var/
.config/ dev/ lib/ media/ proc/ sbin/ tmp/
base1@base1:~$

How do I remove it? I think this is not his place ...

thanks

ps: I use 64bit slackware current multilib

Last edited by afreitascs; 07-06-2012 at 11:26 PM.
 
Old 07-07-2012, 12:27 AM   #2
chrisretusn
Member
 
Registered: Dec 2005
Location: Philippines
Distribution: Slackware
Posts: 479

Rep: Reputation: Disabled
Already discussed here: /.config/Trolltech.conf

on the /run directoy from ChangeLog.txt:
Code:
Mon Jun 25 05:17:48 UTC 2012
a/aaa_base-14.0-x86_64-1.txz:  Upgraded.
  Bumped slackware-version to 14.0.
  Added top level /run directory.

Last edited by chrisretusn; 07-07-2012 at 12:29 AM.
 
1 members found this post helpful.
Old 07-07-2012, 01:40 AM   #3
ReaperX7
Senior Member
 
Registered: Jul 2011
Distribution: LFS-SVN, FreeBSD 10.0
Posts: 3,197
Blog Entries: 15

Rep: Reputation: 826Reputation: 826Reputation: 826Reputation: 826Reputation: 826Reputation: 826Reputation: 826
Any file with a "." at the front of it's name is usually a hidden file that part of your user profile configuration on a Linux system. You probably don't want to delete these unless you have uninstalled the package relevant to it.
 
1 members found this post helpful.
Old 07-07-2012, 04:07 PM   #4
afreitascs
Member
 
Registered: Aug 2004
Location: Brasil
Distribution: Slackware_Cur-64_mult
Posts: 433

Original Poster
Rep: Reputation: 30
Thank you guys for replicas

@chrisretusn

Quote:
Already discussed here: /.config/Trolltech.conf

But this does not solve! Only provides a solution to live with it ( /.config ) ... The directory "/.config" should not be there, or should?

What did and did not solve:

slackpkg clean-system did not solve


so I decided to try ...

Quote:
slackpkg remove kde
rm-r /.config
rm-r /etc/kde
rm-r /usr/lib64/kde4
reboot
slackpkg install kde
reboot
but also not solved ....

thanks

Last edited by afreitascs; 07-07-2012 at 04:08 PM.
 
Old 07-08-2012, 12:08 AM   #5
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,244

Rep: Reputation: 1043Reputation: 1043Reputation: 1043Reputation: 1043Reputation: 1043Reputation: 1043Reputation: 1043Reputation: 1043
Many programs use /home/user/.config or /root/.config to store configuration files. You shouldn't worry about that.

EDIT I see now you were speaking about /. Sorry at first I did misread your post

Last edited by Didier Spaier; 07-08-2012 at 03:44 AM.
 
1 members found this post helpful.
Old 07-08-2012, 02:42 AM   #6
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 755

Rep: Reputation: 226Reputation: 226Reputation: 226
Once upon a time the / was also the home for root, this is different to current times where root has it's home in /root

The Trolltech (/.config) thing is nothing more than a throw back to the times of old.
 
1 members found this post helpful.
Old 07-08-2012, 02:55 AM   #7
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 1,754

Rep: Reputation: 169Reputation: 169
Easy solution: Don't use the GUI from within the root account.
 
2 members found this post helpful.
Old 07-08-2012, 03:00 AM   #8
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 755

Rep: Reputation: 226Reputation: 226Reputation: 226
Quote:
Originally Posted by rkelsen View Post
Easy solution: Don't use the GUI from within the root account.
Er Wrong.

This is created by the system when a normal user does something that requires root level access.

In the days of old you would have to run su in an xterm to get root level access for a X windows app, those days are long gone and now when you need that level of access it comes up with a nice dialog asking for the root password.

Unfortunately anything based on Qt will cause this directory to be created, and KDE is based on Qt so there is no avoiding it if you run KDE.
 
1 members found this post helpful.
Old 07-08-2012, 05:49 AM   #9
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 1,754

Rep: Reputation: 169Reputation: 169
Quote:
Originally Posted by wildwizard View Post
This is created by the system when a normal user does something that requires root level access.
Like what? I've never had this happen, and I've been using KDE as my primary desktop since 2001.
 
Old 07-08-2012, 06:34 AM   #10
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 755

Rep: Reputation: 226Reputation: 226Reputation: 226
Quote:
Originally Posted by rkelsen View Post
Like what? I've never had this happen, and I've been using KDE as my primary desktop since 2001.
This is a recent regression, if your not up to date you wont get this, if you upgrade to -current you'll have it.
 
1 members found this post helpful.
Old 07-08-2012, 09:48 AM   #11
afreitascs
Member
 
Registered: Aug 2004
Location: Brasil
Distribution: Slackware_Cur-64_mult
Posts: 433

Original Poster
Rep: Reputation: 30
Hello to all

I'll leave it as is! I learned that there is no problem ... my curiosity

I suppose, not sure, it only appears in slackware current ... but it is a waste in slackware-current.

So there is no solution to prevent its re-creation!

Thank you all for replies
 
Old 07-09-2012, 01:17 AM   #12
chrisretusn
Member
 
Registered: Dec 2005
Location: Philippines
Distribution: Slackware
Posts: 479

Rep: Reputation: Disabled
Quote:
Originally Posted by afreitascs View Post
@chrisretusn
But this does not solve! Only provides a solution to live with it ( /.config ) ... The directory "/.config" should not be there, or should?

but also not solved ....

thanks
I was pointing out that there was an existing thread that discusses the same problem. That is all.

The /.config should not be there, but where to put it is another story. Perhaps you will be interested in this: Bug 249217 kauth helpers create .kde and .config in /
 
Old 07-09-2012, 01:36 AM   #13
astrogeek
Senior Member
 
Registered: Oct 2008
Distribution: Slackware: 12.1, 13.1, 14.1, 64-14.1, -current, FreeBSD-10
Posts: 1,862

Rep: Reputation: 638Reputation: 638Reputation: 638Reputation: 638Reputation: 638Reputation: 638
I am not running -current so have not seen this myself.

If you can't prevent it for the time being, how about making it a symlink to another location so that it would at least not write directly to the root directory?
 
Old 07-09-2012, 02:38 AM   #14
DrTor
LQ Newbie
 
Registered: Jan 2010
Posts: 6

Rep: Reputation: 2
This directory always appears when you use KDE packages from Alien Bob http://alien.slackbook.org/blog/kde-...ives/#comments (my post : January 27, 2012 at 21:01)

Last edited by DrTor; 07-09-2012 at 02:56 AM.
 
Old 07-09-2012, 07:24 AM   #15
chrisretusn
Member
 
Registered: Dec 2005
Location: Philippines
Distribution: Slackware
Posts: 479

Rep: Reputation: Disabled
It's not just Slackware that is affect by this. It is a KDE issue, possibly a Qt issue, depending on who you talk to.

Last edited by chrisretusn; 07-09-2012 at 07:29 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
".config" and ".kde" folders are being created under root directory (Slack Current) piratesmack Slackware 8 03-12-2011 11:06 PM
accidentally moved entire linux root "/ " file system to another directory bks2010 Linux - Newbie 8 09-19-2010 05:07 AM
Logging in non-root users fails either with "no shell" or no directory Doc_X_Doc Linux - Newbie 16 03-09-2010 10:27 AM
Standard commands give "-bash: open: command not found" even in "su -" and "su root" mibo12 Linux - General 4 11-11-2007 10:18 PM
what is the difference between "/" root directory and "/root" directory? augustus123 Linux - General 4 11-20-2004 05:22 PM


All times are GMT -5. The time now is 05:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration