LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Compiz with a ATI Xpress 1150 (http://www.linuxquestions.org/questions/slackware-14/compiz-with-a-ati-xpress-1150-a-618109/)

sparker 02-02-2008 01:43 AM

Compiz with a ATI Xpress 1150
 
I'm trying to get compiz to work properly but when I try to start it I get:
Code:

$compiz --replace decoration wobbly fade minimize cube move place resize rotate scale switcher water zoom &
[1] 24136
$compiz: GLX_EXT_texture_from_pixmap is not supported by direct rendering context, trying indirect rendering context instead
compiz: GLX_EXT_texture_from_pixmap is missing
compiz: Failed to manage screen: 0
compiz: No manageable screens found on display :0.0

I'm able to get it to start using:
Code:

$LIBGL_ALWAYS_INDIRECT=1 compiz --replace decoration wobbly fade minimize cube move place resize rotate scale switcher water zoom &
But that makes my taskbar go all weird. For example, the desktop switcher panels stretch very wide.

Here is my xorg.conf:
Code:

Section "ServerLayout"
        Identifier    "X.org Configured"
        Screen      0  "aticonfig-Screen[0]" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
        RgbPath      "/usr/share/X11/rgb"
        ModulePath  "/usr/lib/xorg/modules"
        FontPath    "/usr/share/fonts/TTF"
        FontPath    "/usr/share/fonts/OTF"
        FontPath    "/usr/share/fonts/Type1"
        FontPath    "/usr/share/fonts/misc"
        FontPath    "/usr/share/fonts/75dpi/:unscaled"
EndSection

Section "Module"
        Load  "glx"
        Load  "extmod"
        Load  "xtrap"
        Load  "record"
        Load  "GLcore"
        Load  "dbe"
        Load  "dri"
        Load  "freetype"
        Load  "type1"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option            "XkbModel" "pc101"
        Option            "XkbLayout" "us"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option            "Protocol" "auto"
        Option            "Device" "/dev/input/mice"
        Option            "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
        Identifier  "aticonfig-Monitor[0]"
        Option            "VendorName" "ATI Proprietary Driver"
        Option            "ModelName" "Generic Autodetecting Monitor"
        Option            "DPMS" "true"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[0]"
        Driver      "fglrx"
        Option "DRI" "true"
        Option "ColorTiling" "on"
        Option "EnablePageFlip" "true"
        Option "AccelMethod" "EXA"
        Option "XAANoOffscreenPixmaps"
EndSection

Section "Screen"
        Identifier "aticonfig-Screen[0]"
        Device    "aticonfig-Device[0]"
        Monitor    "aticonfig-Monitor[0]"
        DefaultDepth    24
        SubSection "Display"
                Viewport  0 0
                Depth    24
        EndSubSection
EndSection

Section "DRI"
        Mode        0666
EndSection

Section "Extensions"
        Option            "Composite" "Enable"
EndSection

Does anyone have compiz working with this card???

budword 02-02-2008 07:32 PM

I had to take the desktop switchers off altogether, as they didn't play nice with compiz. I don't know why. I use kde though, so maybe the problems aren't related.

Does everything else work ok ? Have you tried any other distro's ?

David

P.S. Oh, what desktop are you using ?

sparker 02-02-2008 08:22 PM

I'm using KDE. Everything looks like its working fine, although I haven't played around with it much. I haven't tried it on any other distros, but I can't see how another distro would perform much differently.

armanox 02-02-2008 10:36 PM

It is an issue with fglrx (the proprietary ATI driver). I've found that using Emerald instead of KWin for the windows decorator is a workaround. I would recomend installing fusion-icon and emerald and seeing if it works for you.


All times are GMT -5. The time now is 12:15 AM.