LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-02-2007, 01:03 PM   #16
simcox1
Member
 
Registered: Mar 2005
Location: UK
Distribution: Slackware
Posts: 794
Blog Entries: 2

Rep: Reputation: 30

newsbot. See this post. You might need an older version of the nvidia driver.

http://www.linuxquestions.org/questi...d.php?t=536885
 
Old 04-03-2007, 12:26 AM   #17
newsbot
LQ Newbie
 
Registered: Feb 2007
Location: Corsica
Distribution: Slackware
Posts: 28

Rep: Reputation: 15
Hi,

I know about that post but, if with that driver everything goes well ... not the screen resolution !

i'm on 1440x900 ! and this driver don't give it to me ! that's why i try another one ... the last one.

in the help of the last one ... they says that's it's a good one for a big list of nvidia card ... and my card is in the list.

With that new drive it take my card well for resolution ... but not when i stop X !

I drop an eye in the help again (very big help) ... but if there is a lot of things about the starting X ... i've don't find anything about the end of X !

That's why when i saw the high level solution of thinking of that post i think that one of U understand what's happening in my laptop

Amilo M3438G Nvidia GeForce Go 6800
 
Old 04-07-2007, 07:16 PM   #18
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 1,754

Rep: Reputation: 169Reputation: 169
Quote:
Originally Posted by XGizzmo
This is just a quick how to for getting compiz working with a nvidia card and kde on slackware current.It is not meant to be an exhaustive how to and it maybe totally wrong but works for me.
Hey XGizzmo, I followed your instructions and it all works for me too!

Thankyou!
 
Old 04-08-2007, 05:22 AM   #19
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,553

Rep: Reputation: 424Reputation: 424Reputation: 424Reputation: 424Reputation: 424
what's the minimum requirement for the NVidia driver?
I'm using NVidia 1.0.9631 and when i execute xdriinfo, it said
Quote:
LibGL is too old
Here's the error message when i tried to install new NVidia driver with the option you specified

Quote:
nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Sun Apr 8 17:28:01 2007

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
precompiled interfaces : true
no ncurses color : false
query latest version : false
OpenGL header files : true
no questions : false
silent : false
no recursion : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
no kernel module : false
force SELinux : default
no X server check : false
force tls : (not specified)
X install prefix : /usr
X library install path : (not specified)
X module install path : /usr/lib/xorg/modules
OpenGL install prefix : (not specified)
OpenGL install libdir : (not specified)
utility install prefix : (not specified)
utility install libdir : (not specified)
doc install prefix : (not specified)
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : (not specified)
kernel output path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp mirror : ftp://download.nvidia.com
RPM file list : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> There appears to already be a driver installed on your system (version: 1.0-
9631). As part of installing this driver (version: 1.0-9755), the existing
driver will be uninstalled. Are you sure you want to continue? ('no' will a
bort installation) (Answer: Yes)
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: No)
-> No precompiled kernel interface was found to match your kernel; this means
that the installer will need to compile a new kernel interface.
-> Performing CC sanity check with CC="cc".
-> Performing CC version check with CC="cc".
-> Kernel source path: '/lib/modules/2.6.20.3/source'
-> Kernel output path: '/lib/modules/2.6.20.3/build'
ERROR: If you are using a Linux 2.4 kernel, please make sure
you either have configured kernel sources matching your
kernel or the correct set of kernel headers installed
on your system.

If you are using a Linux 2.6 kernel, please make sure
you have configured kernel sources matching your kernel
installed on your system. If you specified a separate
output directory using either the "KBUILD_OUTPUT" or
the "O" KBUILD parameter, make sure to specify this
directory with the SYSOUT environment variable or with
the equivalent nvidia-installer command line option.

Depending on where and how the kernel sources (or the
kernel headers) were installed, you may need to specify
their location with the SYSSRC environment variable or
the equivalent nvidia-installer command line option.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.

Last edited by willysr; 04-08-2007 at 05:34 AM.
 
Old 04-08-2007, 08:43 PM   #20
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 1,754

Rep: Reputation: 169Reputation: 169
Quote:
Originally Posted by willysr
what's the minimum requirement for the NVidia driver?
For me, it works with the 1.0-9755 version of the NVidia driver.

The only problem I have is that after a few minutes, my ~/.xsession-errors file grows to a few megabytes in size. Compiz seems to cause a recurring error, which reads as follows:
Code:
compiz: pixmap 0x180009a can't be bound to texture
compiz: Couldn't bind redirected window 0xe0000e to texture
This error repeats several times per second and causes the ~/.xsession-errors file to grow to large sizes quickly.

I did some Googling, and I think I've found the solution in this thread: Compiz forums

It seems to be relating to the same problem, and the last post on that page (dated 10th March 2007), seems pretty relevant. It says that the issue is actually caused by the NVidia drivers, and will be fixed in an upcoming release.
 
Old 04-09-2007, 01:36 AM   #21
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,553

Rep: Reputation: 424Reputation: 424Reputation: 424Reputation: 424Reputation: 424
yes, i think waiting for the next release of NVidia will be the best solution for now (Slackware-Current is not yet final also). I'm just curious since i cannot install NVidia driver again now
 
Old 04-09-2007, 08:18 PM   #22
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,553

Rep: Reputation: 424Reputation: 424Reputation: 424Reputation: 424Reputation: 424
finally i can install the NVidia driver again. I upgrade to the latest stable kernel and it just solved my problem (but still i can't get the NVidia logo showed up)

And i can also have compiz running now (Thanks XGizzmo)
 
Old 04-20-2007, 09:11 AM   #23
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,438

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
I have been playing with compiz 0.5.0 from Slackware-current ( thanks very much for the guide XGizzmo! ) and would like to share some observations.

I found the zoom plugin interferes with right click menus in applications e.g.Konqueror as well as stopping upward scrolling using the mousewheel in long pages, so I have deleted it from my list of plugins to be loaded by compiz. The right click menus and the scrolling actions could still be accessed by holding down the Ctrl key, but I prefer to do without zoom and avoid the awkwardness.

I found that I needed to edit my ~/.kde/share/config/ksmserverrc file to remove the zoom. It appears that KDE saves the last command used to start compiz in this file and automatically restarts compiz with this line when a KDE session is started. So it is not necessary to create the script files as discussed in the guide. Just start compiz once, and the settings will carry into the next session.

There is also a weird interaction with the pager that I have yet to get a handle on. If you set number of desktops to one, then only one pager window shows on startup. Once in a session, change the number of desktops to four and the number of pager windows becomes sixteen. Change it back to one, and the number of pager windows is four, which is what I want because it corresponds to each face of the cube. Go figure!

Yes, compiz is eye candy and demanding on hardware, but my hardware handles it and the scale function is something that I can get used to very easily. I'm don't know the linux for WOW, but for me it's YOWSER.
 
Old 04-20-2007, 11:09 AM   #24
manwichmakesameal
Member
 
Registered: Aug 2006
Distribution: Slackware
Posts: 800

Rep: Reputation: 100Reputation: 100
compiz-0.5.0-i486-2?

I would love to install compiz-0.5.0-i486-2, but I don't see it anywhere? Any links? Nevermind, I read the version wrong. It's 0.3.6 not 0.5.0. But even with 0.5.0, it still doesn't do kwin-decorations right, or at all for that matter. Anyone else?

Last edited by manwichmakesameal; 04-20-2007 at 11:50 AM.
 
Old 04-25-2007, 07:15 AM   #25
george1509
LQ Newbie
 
Registered: May 2006
Posts: 7

Rep: Reputation: 0
Quote:
Originally Posted by thugic
Does anyone know how to configure compiz? Looks like it has no any other way except gconf2 (which installation on slack is somehow tricky and useless except for this kind of things). I read that there is a new plugin called "ini" which allows compiz configuration through a flat-file, but can't seem to find it. Anyone?
You need compiz-0.5.0 from current

First create a directory for the configuration files:

Code:
# mkdir $HOME/.compiz
Start compiz with the ini plugin from konsole or whatever your
prefered terminal app is:
Code:
# compiz --replace ini decoration wobbly fade minimize cube
switcher move resize place rotate zoom scale &
# kde-window-decorator --replace &
Now you should have a lot of .conf files in ~/.compiz/options.

General and individual plugin settings

By editing the .conf files you can now change the settings of your
compiz. A good list of options and what they do can be found
here:
https://help.ubuntu.com/community/Co...figuringCompiz
The option names in the .conf files are the same as they appear in
gconf.

Most important, edit ~/.compiz/options/general-allscreens.conf and
change active_plugins to active_plugins=ini,<your plugin1,your
plugin2,...>.

HTH
 
Old 12-10-2007, 02:16 PM   #26
STARHARVEST
Member
 
Registered: Nov 2005
Location: Russia, republic of Bashkiria
Distribution: Slackware 12.1
Posts: 294

Rep: Reputation: 31
I'm getting this -
compiz (core) - no managable screens found on display : 0.0
Any solution?
 
Old 12-13-2007, 07:06 AM   #27
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
You probably need to export DISPLAY variable with correct DISPLAY location set.

Last edited by Alien_Hominid; 12-13-2007 at 08:40 AM.
 
Old 12-14-2007, 06:28 AM   #28
STARHARVEST
Member
 
Registered: Nov 2005
Location: Russia, republic of Bashkiria
Distribution: Slackware 12.1
Posts: 294

Rep: Reputation: 31
Can you please tell how to do that?
 
Old 12-15-2007, 04:02 PM   #29
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
http://www.hungry.com/~jamie/xexport.html

export DISPLAY=:displaynumber.screennumber /e.g. export DISPLAY=:0.0 (this is default)
You probably have screen running on different display or your screen might be not 0. How do you start X?

Last edited by Alien_Hominid; 12-15-2007 at 04:05 PM.
 
Old 12-17-2007, 05:58 AM   #30
STARHARVEST
Member
 
Registered: Nov 2005
Location: Russia, republic of Bashkiria
Distribution: Slackware 12.1
Posts: 294

Rep: Reputation: 31
How do I start X... what do you mean?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tv Out on Nvidia Ti200 and Slackware Current 180906 fdahl_009 Slackware 13 04-13-2007 03:12 PM
Wootness! Etch + KDE + Xgl + Compiz + NVIDIA working! pda_h4x0r Debian 12 11-06-2006 06:26 PM
kde 3.5.1 in Slackware/current BCarey Slackware 2 02-26-2006 06:57 PM
slackware-current and nVidia drivers... X won't start mattlacey Slackware 9 05-31-2005 02:32 PM
slackware current and NVIDIA drivers Xavius Slackware 13 11-13-2004 03:59 PM


All times are GMT -5. The time now is 01:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration