LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-27-2007, 09:46 AM   #61
urka58
Member
 
Registered: Nov 2003
Distribution: slackware 14
Posts: 535

Rep: Reputation: 30

Quote:
Originally Posted by mRgOBLIN View Post
if you are runlevel 4 then you can also use "~/.xprofile"

Oh and a little tip so you don't have to jump through sed hoops...

Code:
ps ax |grep "[c]ompiz"
Nice tip, it works perfectly well, but you woken up my curiosity, how ?
Ciao
 
Old 10-27-2007, 11:15 AM   #62
trebek
Member
 
Registered: Feb 2005
Location: Costa Rica
Distribution: Ubuntu, gOS, Debian & Slack 12
Posts: 426

Rep: Reputation: 30
Quote:
Originally Posted by urka58 View Post
So..you have many options. I'd say they should go in /usr/local/bin in order they are in your PATH.
Sorry, I don't know your level of skill, so I'm going to start from the very beginning...
- Copy the script compiz+emerald into your favourite text editor (ie Kwrite) and save as compiz_emerald
- Give execution perm to the file just saved by "chmod a+x compiz_emerald"
- su as root and change owner to compiz_emerald by "chown root:root compiz_emerald"
- stay root and move compiz_emerald to /usr/local/bin by "mv compiz_emerald /usr/local/bin"
Do the same for the remaining two scripts

Once done launch the script in a Virtual Terminal (ie Konsole).
If you like you can also add the scripts to your Kmenu and launch them from there..
Hope this helps
Ciao

PS: Compiz is a little tricky, so if you want to avoid to be started with KDE just do this:
Launch a session of kde with all programs you want to be started with (ie Kmix, Karamba...) but compiz.
Go to Control Center -> Kde Components -> Session manager -> Restore manually saved session.
From Kmenu - > save session.
This avoid compiz to be started when you lanch KDE
Thanks a lot. I also read somewhere that in order for compiz to be loaded during kde launch, i should be putting some scripts in .kde directory, should i remove them from there? I created them when attempting another manual before the one you suggested.
 
Old 10-27-2007, 05:03 PM   #63
urka58
Member
 
Registered: Nov 2003
Distribution: slackware 14
Posts: 535

Rep: Reputation: 30
Is up to you...
Remove the old script from ~/user/.kde/Autostart as I beleive it won't work.
I'd suggest you run the script starting compiz (ie compiz_emerald) manually for a while. Once you see it works properly you can put it to ~/user/.kde/Autostart in order you get it started automatically.
Ciao
 
Old 10-27-2007, 05:09 PM   #64
trebek
Member
 
Registered: Feb 2005
Location: Costa Rica
Distribution: Ubuntu, gOS, Debian & Slack 12
Posts: 426

Rep: Reputation: 30
I got twinview working here, two monitors connected to the same card. I set up compiz and once i start it, i get a really weird desktop. I get the first screen normally with all the gadgets, but the second screen has a blank page like 3/4's across and the last quarter in black, at the end having like the start of the side face of the cube.

So, my question here is, is there another set of configuration lines i need to add to my xorg.conf file so that compiz works with two screens? Here's an output of the device section of my xorg.conf file so that you can have a clearer idea of what i mean.

Section "Device"
Identifier "VESA Framebuffer"
Driver "nvidia"
Option "TwinView"
Option "MetaModes" "1600x1200"
Option "TwinViewOrientation" "RigtOf"
Option "RenderAccel" "true"
Option "AllowGLXWithComposite" "true"
#VideoRam 4096
# Insert Clocks lines here if appropriate
EndSection
 
Old 10-27-2007, 05:57 PM   #65
mRgOBLIN
Slackware Contributor
 
Registered: Jun 2002
Location: New Zealand
Distribution: Slackware
Posts: 999

Rep: Reputation: 227Reputation: 227Reputation: 227
Quote:
Originally Posted by urka58 View Post
Nice tip, it works perfectly well, but you woken up my curiosity, how ?
Ciao
because ps doesn't do the shell expansion before displaying the command and displays it as you type it.

Look here.

Code:
mrgoblin@sonic:~> ps ax |grep "[g]rep"                       
17254 pts/8    S+     0:00 grep [g]rep
 
Old 10-28-2007, 07:12 AM   #66
urka58
Member
 
Registered: Nov 2003
Distribution: slackware 14
Posts: 535

Rep: Reputation: 30
It took me a while to understand, but at last I got it ...I believe
Thank you
Ciao

Last edited by urka58; 10-28-2007 at 07:14 AM.
 
Old 10-28-2007, 02:41 PM   #67
ramskens
LQ Newbie
 
Registered: Oct 2007
Posts: 6

Rep: Reputation: 0
to install compiz-fusion 0.5.2 do i have to install gconf?, is any way to avoid that?
 
Old 10-28-2007, 02:52 PM   #68
ramskens
LQ Newbie
 
Registered: Oct 2007
Posts: 6

Rep: Reputation: 0
to install compiz-fusion 0.5.2 do i have to install gconf?
and other question, i read that to install a new version of compiz i have to uninstall the old one (the one that came with slack 12), but, how do i do this?
 
Old 10-28-2007, 05:24 PM   #69
SqdnGuns
Member
 
Registered: Aug 2005
Location: Fountain Valley, CA / Thailand
Distribution: Slackware64 14.0
Posts: 981

Rep: Reputation: 88
Quote:
Originally Posted by ramskens View Post
to install compiz-fusion 0.5.2 do i have to install gconf?
and other question, i read that to install a new version of compiz i have to uninstall the old one (the one that came with slack 12), but, how do i do this?
Run pkgtool and select compiz.

Sounds like you need to do some research on Slackware, it will pay off for you in the long run.
 
Old 10-29-2007, 02:03 PM   #70
urka58
Member
 
Registered: Nov 2003
Distribution: slackware 14
Posts: 535

Rep: Reputation: 30
No, gconf is not required at all. The package from slacky.eu is compiled without gconf support.
Ciao
 
Old 10-30-2007, 10:03 PM   #71
ramskens
LQ Newbie
 
Registered: Oct 2007
Posts: 6

Rep: Reputation: 0
ok, thanks, i have already installed the compiz 0.5.2 and fusion and the other stuff with the package of slacky.
But i still have the same problem before. After a while, and for no reason particurally (i dont know how does that word write, im from argentina..), the system hangs, its not a problem of hardware because before i enable composite that never happens. When i dont call compiz (i mean,, composite enable, but i dont activate "compiz -replace bla bla bla"), it takes a lot more to hang,, but, eventually it does...
Any suggestion?
And thanks for the previous answers
 
Old 10-31-2007, 03:56 PM   #72
trebek
Member
 
Registered: Feb 2005
Location: Costa Rica
Distribution: Ubuntu, gOS, Debian & Slack 12
Posts: 426

Rep: Reputation: 30
QUESTION!!!

Does anybody know why konqueror would not open when compiz is running? It hasn't opened since i enabled compiz. Every other application opens up just fine. When trying to open konqueror, be it home folder, the trash or konqueror itself, i just get the bouncy icon for like 20 seconds but nothing shows up. By the way, where would the error messages for this problem be in /var/log (dmesg, syslog)?

Thanks for the help.

Last edited by trebek; 10-31-2007 at 04:00 PM.
 
Old 10-31-2007, 06:27 PM   #73
urka58
Member
 
Registered: Nov 2003
Distribution: slackware 14
Posts: 535

Rep: Reputation: 30
Quote:
Originally Posted by ramskens View Post
ok, thanks, i have already installed the compiz 0.5.2 and fusion and the other stuff with the package of slacky.
But i still have the same problem before. After a while, and for no reason particurally (i dont know how does that word write, im from argentina..), the system hangs, its not a problem of hardware because before i enable composite that never happens. When i dont call compiz (i mean,, composite enable, but i dont activate "compiz -replace bla bla bla"), it takes a lot more to hang,, but, eventually it does...
Any suggestion?
And thanks for the previous answers
Try editing the startup script this way

Start compiz+emerald

#!/bin/sh

export LIBGL_ALWAYS_INDIRECT=1 # add this

if ! ps ax | sed '/grep/ d' | grep compiz 1> /dev/null 2> /dev/null ; then
/usr/bin/compiz --replace ccp &
/usr/bin/emerald --replace &
else
/usr/bin/emerald --replace &
fi

Hope this helps
Ciao
 
Old 10-31-2007, 11:42 PM   #74
ramskens
LQ Newbie
 
Registered: Oct 2007
Posts: 6

Rep: Reputation: 0
Try editing the startup script this way

Start compiz+emerald

#!/bin/sh

export LIBGL_ALWAYS_INDIRECT=1 # add this

if ! ps ax | sed '/grep/ d' | grep compiz 1> /dev/null 2> /dev/null ; then
/usr/bin/compiz --replace ccp &
/usr/bin/emerald --replace &
else
/usr/bin/emerald --replace &
fi

Hope this helps
Ciao

------------------------
well... it didnt work. the truth, i installed compiz0.5.2 with fusion, so i dont have emerald. The other thing,,i have that problem without running compiz.

Here is the last part of my xorg.conf

Section "Device"

#VideoRam 2048
# Insert Clocks lines here if appropriate
Identifier "* Generic VESA compatible"
Driver "nvidia"
EndSection
Section "Screen"
Identifier "Screen 1"
Device "* Generic VESA compatible"
Monitor "s"
DefaultDepth 24
Option "AllowGLXWithComposite" "true"
Option "TripleBuffer" "true"
Option "RenderAccel" "True"
Option "AddARGBGLXVisuals" "True"
Option "DisableGLXRootClipping" "True
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

any suggestion?
 
Old 11-01-2007, 06:56 AM   #75
urka58
Member
 
Registered: Nov 2003
Distribution: slackware 14
Posts: 535

Rep: Reputation: 30
So.. you have to install a window decorator (emerald, kde-window-decorator), otherwise no chances you can get compiz working.
Have you installed all packages I listed ?
If you don't like emerald, install at least kde-window-decorator and replace it into the script.
Your xorg.conf file looks fine, just try removing the line
Option "TripleBuffer" "true"
if your video card has less than 128 MB memory
Ciao
 
  


Reply

Tags
compiz, nvidia, nvidia drivers, slackware12


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Compiz - How do I include the compiz-extra plugins? lostinpurdy Linux - Desktop 2 05-29-2007 03:00 AM
mdv 2007 compiz cube not displaying and pictures not memorised by gset-compiz Emmanuel_uk Mandriva 0 10-10-2006 03:33 AM
Anyone using XGL/Compiz on Slack? Sugarat Slackware 5 09-25-2006 11:08 PM
Anyone using XGL/Compiz on Slack? Sugarat Slackware 1 09-23-2006 06:33 PM
What do you think about XGL/Compiz? Hunter2 Linux - Software 21 07-09-2006 04:52 PM


All times are GMT -5. The time now is 04:40 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration