LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-06-2007, 10:11 PM   #16
kholdstayr
Member
 
Registered: Dec 2003
Distribution: Slackware
Posts: 36

Original Poster
Rep: Reputation: 15

I added that xorg.conf line and tried to test compiz really quickly while remaining in X (which the forums say you can do).

To test I typed:
compiz --replace &

This obviously won't set up any of the "cool" effects but should enable it just to see if it works.

Anyway, as expected, my window decorations disappeared.

I can't get them to reappear though because as soon as I type the compiz command my console window refuses to accept keyboard input and I can't switch to other windows. So, I can't type the other kde line to get my window decorations back.
I am basically stuck doing a three fingered X salute to get out of X.

I'll try messing around with the xinitrc file method of starting it up later.
 
Old 07-06-2007, 10:23 PM   #17
raska
Member
 
Registered: Aug 2004
Location: Aguascalientes, AGS. Mexico.
Distribution: Slackware 13.0 kernel 2.6.29.6
Posts: 816

Rep: Reputation: 30
Quote:
Originally Posted by kholdstayr
........
Anyway, as expected, my window decorations disappeared.

I can't get them to reappear though because as soon as I type the compiz command my console window refuses to accept keyboard input and I can't switch to other windows. So, I can't type the other kde line to get my window decorations back.
I am basically stuck doing a three fingered X salute to get out of X.

I'll try messing around with the xinitrc file method of starting it up later.
That's why you need the kde-window-decorator after the compiz --replace <bunch of plugins as your heart's content> command.

Looks like every now and then the kde-window-decorator crashes without notice and leaves the desktop unusable like you just described it. I have managed to work around this by typing [Alt]+[F2] to bring up the Execute command dialog and I fire again the kde-window-decorator from there, fixing up the windows.

Though, if anyone knows a better method, i.e. to somehow autorespawn the kde-window-decorator, please share the info

Last edited by raska; 07-06-2007 at 10:25 PM.
 
Old 07-07-2007, 03:45 PM   #18
kholdstayr
Member
 
Registered: Dec 2003
Distribution: Slackware
Posts: 36

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by raska
That's why you need the kde-window-decorator after the compiz --replace <bunch of plugins as your heart's content> command.

Looks like every now and then the kde-window-decorator crashes without notice and leaves the desktop unusable like you just described it. I have managed to work around this by typing [Alt]+[F2] to bring up the Execute command dialog and I fire again the kde-window-decorator from there, fixing up the windows.

Though, if anyone knows a better method, i.e. to somehow autorespawn the kde-window-decorator, please share the info
The kde-window-decorator doesn't want to work for me at all. I was just doing some tests and it will not start up and give me my window decorations back. If I try your Alt-2 trick the command box pops up but it won't accept keyboard input.

I found out though that if I type into it it will still receive the keyboard commands, it just won't show them. Still, the kde-window-decorator won't bring back the decorations.
 
Old 07-07-2007, 05:22 PM   #19
janhe
Member
 
Registered: Jul 2007
Location: Belgium
Distribution: slackware64 13.1, slackware 13.1
Posts: 369

Rep: Reputation: 45
I used a script to start compiz.
Guess where I found it?
a thread on the LinuxQuestions Slackware forum

This works fine for me
 
Old 07-08-2007, 05:02 AM   #20
Caifan_Morriz
LQ Newbie
 
Registered: Nov 2004
Location: Aguascalientes, MX.
Distribution: Slackware
Posts: 1

Rep: Reputation: 0
Quote:
Originally Posted by randomsel
Anyone know how to set up skydome and top image on the cube for Slackware?
I'm also trying to set the top and bottom images to the cube... anyone knows how?
 
Old 07-08-2007, 07:15 AM   #21
Carpo
Member
 
Registered: Aug 2003
Location: Somewhere
Distribution: Gentoo (for now)
Posts: 364

Rep: Reputation: 30
i have tried everything in this thread and still i cant get it to work - might have something to do with the 32meg onbaord ati card in my laptop
 
Old 07-09-2007, 09:49 AM   #22
kholdstayr
Member
 
Registered: Dec 2003
Distribution: Slackware
Posts: 36

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Carpo
i have tried everything in this thread and still i cant get it to work - might have something to do with the 32meg onbaord ati card in my laptop
Yeah, I am using a laptop too with a low end Intel card that uses standard system RAM for its video memory.
 
Old 07-09-2007, 11:20 AM   #23
ErV
Senior Member
 
Registered: Mar 2007
Location: Russia
Distribution: Slackware 12.2
Posts: 1,202
Blog Entries: 3

Rep: Reputation: 62
Well, thanks a lot for the instructions. I've stumbled upon this thread accidentally, tried compiz, and i must say this thing is amazing (don't think I could run something like that on my machine). However, there are some problems:
1) Compiz ignores shortcuts for switching to another desktop. I'm using this funcionality a lot, so it's a pity
2) Switching to a text console and then back to a graphical desktop hung my system badly - i had only black screen and mouse cursor (It looks like windows were actually present on the screen but were not visible). I've tried to kill X-server, but that also disabled keyboard so I had to reset computer (because I couldn't do anything) No data was lost, though.

Anyway, this thing is great .

Last edited by ErV; 07-09-2007 at 12:01 PM.
 
Old 07-19-2007, 07:50 AM   #24
atkfossiili
Member
 
Registered: Jul 2007
Location: Tyrnävä, Finland
Distribution: Slackware, Debian Etch, WinXP, PCLinuxOS, tried Zenwalk, Ubuntu, etc.
Posts: 30

Rep: Reputation: 15
I have Slackware 12, Nvidia GeForce 6200 display card and a working Nvidia proprietary driver installed. I hope I could have Beryl/Compiz effects in Slackware to demonstrate Linux goodies to my friends.

I started applying advice from http://wiki.beryl-project.org/wiki/I...l_on_Slackware
but that did not work for me, although I started a discussion in
http://www.linuxquestions.org/questi...Beryl%2FCompiz
but I got advice to look here.

I have read carefully what is written in this thread. Until recently I have added to /etc/X11/xorg.conf:
Quote:
Section "Extensions"
Option "Composite" "enable"
EndSection
Then I gave the following command in the terminal:
Code:
bash-3.1$ su
Password:
bash-3.1# compiz --replace decoration wobbly fade minimize cube move place resize rotate scale switcher water zoom
No protocol specified
compiz: Couldn't open display :0
I know those fine Compiz/Beryl effects are a "mowing target" i.e. under development. So to find working advice how to install them could be very difficult. Do I have any hope
 
Old 07-19-2007, 10:42 AM   #25
SCerovec
Member
 
Registered: Oct 2006
Location: Cp6uja
Distribution: Slackware and Porteus
Posts: 648

Rep: Reputation: 45
For Nvidia proprietary driver users:
Quote:
Option "AddARGBGLXVisuals" "true" makes window borders work.
Option "TripleBuffer" "true" gives more fluid graphics
just for the record ;-)
 
Old 07-20-2007, 02:47 AM   #26
SCerovec
Member
 
Registered: Oct 2006
Location: Cp6uja
Distribution: Slackware and Porteus
Posts: 648

Rep: Reputation: 45
Smile

Quote:
Originally Posted by atkfossiili
Code:
bash-3.1$ su
Password:
bash-3.1# compiz --replace decoration wobbly fade minimize cube move place resize rotate scale switcher water zoom
No protocol specified
compiz: Couldn't open display :0
Regarding my experience one can't expect to 'su' and to connect to the running X of any user.
to connect to X one has either be the 'X running user' or to disable all security checks of X (which is unwise...)
So either drop that 'su' switching and start compiz as normal user, or just wait for compiz to become mainstream...
:-)
 
Old 07-20-2007, 10:46 AM   #27
atkfossiili
Member
 
Registered: Jul 2007
Location: Tyrnävä, Finland
Distribution: Slackware, Debian Etch, WinXP, PCLinuxOS, tried Zenwalk, Ubuntu, etc.
Posts: 30

Rep: Reputation: 15
Quote:
Originally Posted by SCerovec
drop that 'su' switching and start compiz as normal user,
Thank you
Now
Code:
bash-3.1$ kde-window-decorator &
[1] 4038
bash-3.1$ compiz --replace decoration wobbly fade minimize cube move place resize rotate scale switcher water zoom
compiz: No GLXFBConfig for depth 32
compiz: No GLXFBConfig for depth 32
compiz: No GLXFBConfig for depth 32
compiz: Failed to load slide: freedesktop
And now I have the floting windows and desktop qube

Still the KDE-desktop is a bit strange. For ex. the pager squares on the panel and it is not possible to change the size of the windows. But let's see!

Last edited by atkfossiili; 07-20-2007 at 10:48 AM.
 
Old 07-20-2007, 11:00 AM   #28
atkfossiili
Member
 
Registered: Jul 2007
Location: Tyrnävä, Finland
Distribution: Slackware, Debian Etch, WinXP, PCLinuxOS, tried Zenwalk, Ubuntu, etc.
Posts: 30

Rep: Reputation: 15
Quote:
Originally Posted by SCerovec
For Nvidia proprietary driver users:
In which Section of /etc/xorg.conf should I add:
Quote:
Option "AddARGBGLXVisuals" "true" - makes window borders work.
Option "TripleBuffer" "true" -gives more fluid graphics
 
Old 07-21-2007, 02:54 AM   #29
SCerovec
Member
 
Registered: Oct 2006
Location: Cp6uja
Distribution: Slackware and Porteus
Posts: 648

Rep: Reputation: 45
the clue ;-)

Quote:
Originally Posted by atkfossiili
In which Section of /etc/xorg.conf should I add:
In the Device section of the nvidia card: right below the line with "nvidia" driver option
 
Old 07-21-2007, 08:35 AM   #30
atkfossiili
Member
 
Registered: Jul 2007
Location: Tyrnävä, Finland
Distribution: Slackware, Debian Etch, WinXP, PCLinuxOS, tried Zenwalk, Ubuntu, etc.
Posts: 30

Rep: Reputation: 15
Now I have added to my /etc/X11/xorg.conf
Quote:
Section "Device"
#VideoRam 256
# Insert Clocks lines here if appropriate
Identifier "NVIDIA GeForce 6200"
Driver "nvidia"
Option "AddARGBGLXVisuals" "true"
Option "TripleBuffer" "true"
EndSection

Section "Extensions"
Option "Composite" "enable"
EndSection
 
  


Reply

Tags
compiz, nvidia, nvidia drivers, slackware12


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Compiz - How do I include the compiz-extra plugins? lostinpurdy Linux - Desktop 2 05-29-2007 02:00 AM
mdv 2007 compiz cube not displaying and pictures not memorised by gset-compiz Emmanuel_uk Mandriva 0 10-10-2006 02:33 AM
Anyone using XGL/Compiz on Slack? Sugarat Slackware 5 09-25-2006 10:08 PM
Anyone using XGL/Compiz on Slack? Sugarat Slackware 1 09-23-2006 05:33 PM
What do you think about XGL/Compiz? Hunter2 Linux - Software 21 07-09-2006 03:52 PM


All times are GMT -5. The time now is 08:23 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration