LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 05-06-2013, 01:39 PM   #1
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,873

Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
compiz and font config error on Slack 14.0


When I start compiz, I get a font config error.

Quote:
compiz --replace ccp & emerald --replace &
[1] 10783
[2] 10784
[cliff@duelie]$ Fontconfig error: "local.conf", line 7: junk after document element

(emerald:10784): GLib-GObject-CRITICAL **: g_object_ref: assertion `G_IS_OBJECT (object)' failed
compiz (core) - Error: Plugin 'text' not loaded.

compiz (ring) - Warn: No compatible text plugin found.
Compiz works, the cube spins, but there are no window decorations. Emerald appears to run.

Quote:
ps ax | egrep '(decorator|emerald)'
10784 pts/0 S 0:00 emerald --replace
10920 pts/0 S+ 0:00 egrep (decorator|emerald
I re-ran pkgtool --> Setup --> mkfontdir and fontconfig. It made no difference.

I have looked at local.conf ; however, I can not see a problem with this file.

This problem has been on my Slack-64 13.37 system, I upgraded it to 14.0, the problem still exists. I have seen the Fontconfig error starting other apps from the command line, so I don't think the error is unique to compiz, its more noticeable in compiz when the there are no window decorations.

Thoughts on how to better determine what causes this font error?

I have removed all the compiz packages, and used sbopkg to re-install them in the correct order. I have the latest Nvidia driver for my on board chip set.

Code:
NVIDIA-Linux-x86_64-304.88.run
I have not seen any problems with 304.88.
 
Old 05-06-2013, 07:38 PM   #2
Diantre
Member
 
Registered: Jun 2011
Distribution: Slackware64 14.1
Posts: 402

Rep: Reputation: 153Reputation: 153
Quote:
Originally Posted by camorri View Post
When I start compiz, I get a font config error.

Fontconfig error: "local.conf", line 7: junk after document element
I'm no expert in fontconfig, but it would be useful if you post your /etc/fonts/local.conf, maybe someone else can help you with it.

Quote:
compiz (core) - Error: Plugin 'text' not loaded.

Compiz works, the cube spins, but there are no window decorations. Emerald appears to run.
Run ccsm and make sure the Text plugin in the "Image Loading" section is enabled. Also, make sure that the Window Decoration plugin in the "Effects" section is enabled as well, and its "Command" field is set to "emerald --replace".

Quote:
I have removed all the compiz packages, and used sbopkg to re-install them in the correct order.
I use the fusion icon to load compiz and emerald, have you tried it? (Don't really know if it would help with your problem, just a suggestion...)
 
Old 05-07-2013, 09:20 AM   #3
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,873

Original Poster
Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
Thank-you for your response.

The /etc/fonts/local.conf file.

Quote:
cat /etc/fonts/local.conf
<!-- Globally use embedded bitmaps in fonts like Calibri? -->
<match target="font" >
<edit name="embeddedbitmap" mode="assign">
<bool>false</bool>
</edit>
</match>
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- /etc/fonts/local.conf file to configure system font access -->
<fontconfig>
<dir>/usr/share/fonts/TTF</dir>
<dir>/usr/share/fonts/OTF</dir>
<dir>/usr/share/fonts/100dpi</dir>
<dir>/usr/share/fonts/75dpi</dir>
</fontconfig>
I ran ccsm, the Text plugin was not enabled. I have enabled it. Yes, I have the Fusion-icon installed. The reason I was using command line, was so I could see any errors that may be generated. The results are the same from the use of fusion-icon.

After enabling Text plugin, this is now the error.

Quote:
compiz --replace ccp & emerald --replace &
[1] 2709
[2] 2710
[cliff@duelie]$ Fontconfig error: "local.conf", line 7: junk after document element

(emerald:2710): GLib-GObject-CRITICAL **: g_object_ref: assertion `G_IS_OBJECT (object)' failed
The Text error is gone, font error remains, and an Emerald error?
 
Old 05-07-2013, 12:21 PM   #4
Diantre
Member
 
Registered: Jun 2011
Distribution: Slackware64 14.1
Posts: 402

Rep: Reputation: 153Reputation: 153
Quote:
Originally Posted by camorri View Post
The /etc/fonts/local.conf file.
It seems to me that fontconfig includes local.conf inside the main fonts.conf file. Probably these lines are unnecessary:

Quote:
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
</fontconfig>
But leave the <dir> tags.

Quote:
I ran ccsm, the Text plugin was not enabled. I have enabled it.
Good. And the "Window Decoration" plugin, is it enabled?
 
Old 05-07-2013, 12:36 PM   #5
phenixia2003
Member
 
Registered: May 2006
Location: France
Distribution: Slackware
Posts: 299

Rep: Reputation: 179Reputation: 179
Hello,

Quote:
Originally Posted by camorri View Post
The /etc/fonts/local.conf file.



I ran ccsm, the Text plugin was not enabled. I have enabled it. Yes, I have the Fusion-icon installed. The reason I was using command line, was so I could see any errors that may be generated. The results are the same from the use of fusion-icon.

After enabling Text plugin, this is now the error.



The Text error is gone, font error remains, and an Emerald error?
Your /etc/fonts/local.conf is malformed. All the elements must be defined inside <fontconfig> .. </fontconfig>. So, the definitions below :
Code:
<!-- Globally use embedded bitmaps in fonts like Calibri? -->
<match target="font" >
<edit name="embeddedbitmap" mode="assign">
<bool>false</bool>
</edit>
</match>
must be moved after the last <dir> element. So, you should have this :

Code:
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- /etc/fonts/local.conf file to configure system font access -->
<fontconfig>
  <dir>/usr/share/fonts/TTF</dir>
  <dir>/usr/share/fonts/OTF</dir>
  <dir>/usr/share/fonts/100dpi</dir>
  <dir>/usr/share/fonts/75dpi</dir>

    <!-- Globally use embedded bitmaps in fonts like Calibri? -->
  <match target="font" >
    <edit name="embeddedbitmap" mode="assign">
      <bool>false</bool>
    </edit>
  </match>

</fontconfig>
--
SeB
 
Old 05-07-2013, 01:36 PM   #6
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,873

Original Poster
Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
I have edited the local.conf file as suggested by phenixia2003, and I no longer get a font error. Thank-you for pointing out the mis-formation of the XML file.

Quote:
Good. And the "Window Decoration" plugin, is it enabled?
Yes, I no longer get a message about no Text plugin, so that is fixed.

Now starting compiz produces just one error:

Quote:
compiz --replace ccp & emerald --replace &
[1] 23862
[2] 23863
[cliff@duelie]$
(emerald:23863): GLib-GObject-CRITICAL **: g_object_ref: assertion `G_IS_OBJECT (object)' failed
Window decorations are still not there.
 
Old 05-07-2013, 01:47 PM   #7
Diantre
Member
 
Registered: Jun 2011
Distribution: Slackware64 14.1
Posts: 402

Rep: Reputation: 153Reputation: 153
Quote:
Originally Posted by camorri View Post
Window decorations are still not there.
Check the "Effects" section in ccsm and make sure the "Window Decoration" plugin is enabled. When you click its icon, the settings page should show a field called "Command". The value for this field should be "emerald --replace". Is it enabled?
 
Old 05-07-2013, 02:00 PM   #8
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,873

Original Poster
Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
Yes, Window Decorations is enabled, and yes, "emerald --replace" is in the command field. It fails with the message in post #6, and there are no window decorations.

Right now I'm googling the error message:

Quote:
GLib-GObject-CRITICAL **: g_object_ref: assertion `G_IS_OBJECT (object)' failed
to see if this has something to do with the decorator failing.
 
  


Reply

Tags
compiz, decorator, error, font


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DBUS / compiz in slack 13.1 freaky3 Slackware 3 07-13-2010 04:27 AM
compiz fusion for slack 12.1 KhaoSlacker Slackware 2 05-04-2008 04:41 AM
compiz and Slack 12? kholdstayr Slackware 77 11-15-2007 04:26 AM
Anyone using XGL/Compiz on Slack? Sugarat Slackware 5 09-25-2006 11:08 PM
Anyone using XGL/Compiz on Slack? Sugarat Slackware 1 09-23-2006 06:33 PM


All times are GMT -5. The time now is 01:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration