-   Slackware (
-   -   Compiling xulrunner 15.0.1: syntax error in VERSION script (

fdelente 09-23-2012 04:03 AM

Compiling xulrunner 15.0.1: syntax error in VERSION script

As stated in the subject, compiling xulrunner 15.0.1 gives

xulrunner-15.0.1/security/nss/lib/util/nssutil.def:1: syntax error in VERSION script

I have googled but not found any clear and definitive solution.

Thanks for any help.

willysr 09-23-2012 10:12 AM

See this commit (fixed)

fdelente 09-23-2012 10:42 AM

Sorry but can't follow your link, it points to


Can you correct it please?


willysr 09-23-2012 10:44 AM

Sorry, i was using my CGIT
Now it's fixed

fdelente 09-23-2012 10:45 AM

Cool, thanks, I'll look into it :^)

rworkman 09-24-2012 12:02 AM

You'll also need libcrmf.a on the system. That library is part of mozilla-nss package, but it got accidentally removed with all the other static libraries (which were intentionally removed). For the time being, you can (re)build mozilla-nss from the Slackware sources and grab the libcrmf.a library from it, put it on the system (in /usr/lib(64)), and go. Either Pat will do a rebuild for 14.0, or we'll host a libcrmf package on SBo.

All times are GMT -5. The time now is 03:28 AM.