LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-04-2012, 03:17 PM   #1
Chelyuk
LQ Newbie
 
Registered: Sep 2012
Posts: 13

Rep: Reputation: Disabled
Compiling pulseaudio on slackware64 14 with multilib


Hi to all,
New slackbuilds for slackware 14 resolved much of problems, but unfortunately not all. Now I can't compile pulseaudio and audacity, maybe something else. In compile process I have the same error:
Code:
/usr/bin/grep: /usr/lib/libFLAC.la: No such file or directory
/usr/bin/sed: can't read /usr/lib/libFLAC.la: No such file or directory
libtool: link: `/usr/lib/libFLAC.la' is not a valid libtool archive
I have flac-1.2.1-x86_64-3 installed, and all flac libs are located in /usr/lib64/
So, what is the right decision?
 
Old 10-04-2012, 03:19 PM   #2
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.1
Posts: 1,220

Rep: Reputation: 177Reputation: 177
http://www.slackbuilds.org/faq/#multilib
 
1 members found this post helpful.
Old 10-04-2012, 03:20 PM   #3
ReaperX7
Senior Member
 
Registered: Jul 2011
Distribution: LFS-SVN, FreeBSD 10.0, CRUX 3.1
Posts: 3,051
Blog Entries: 15

Rep: Reputation: 764Reputation: 764Reputation: 764Reputation: 764Reputation: 764Reputation: 764Reputation: 764
Are you building pulseaudio for 32-bit or 64-bit?
 
Old 10-04-2012, 03:27 PM   #4
Chelyuk
LQ Newbie
 
Registered: Sep 2012
Posts: 13

Original Poster
Rep: Reputation: Disabled
64-bit I guess, I'm just running slackbuild/].
Thank's Daedra, next time I'll read FAQ better.

Last edited by Chelyuk; 10-04-2012 at 03:39 PM.
 
Old 10-04-2012, 08:29 PM   #5
ReaperX7
Senior Member
 
Registered: Jul 2011
Distribution: LFS-SVN, FreeBSD 10.0, CRUX 3.1
Posts: 3,051
Blog Entries: 15

Rep: Reputation: 764Reputation: 764Reputation: 764Reputation: 764Reputation: 764Reputation: 764Reputation: 764
Try using this flag for the slackbuild when building software on Slackware64.:

Code:
ARCH=x86_64 ./pulseaudio.SlackBuild
Setting the script to default to x86_64 will ensure that the x86_64 package is built and not the i486 package.
 
Old 10-04-2012, 09:07 PM   #6
xslc
Member
 
Registered: Jan 2012
Location: korea
Distribution: slackware64
Posts: 32

Rep: Reputation: Disabled
Quote:
Originally Posted by ReaperX7 View Post
Try using this flag for the slackbuild when building software on Slackware64.:

Code:
ARCH=x86_64 ./pulseaudio.SlackBuild

ipt to default to x86_64 will ensure that the x86_64 package is built and not the i486 package.
If architecture is 64 bits or 32 bits, he can recognize automatically. At the beginning
slackbuild script has been given to the detection mechanism
architecture.

Code:
if [ "$ARCH" = "i486" ]; then
  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

Last edited by xslc; 10-04-2012 at 09:08 PM.
 
1 members found this post helpful.
Old 10-04-2012, 09:35 PM   #7
ReaperX7
Senior Member
 
Registered: Jul 2011
Distribution: LFS-SVN, FreeBSD 10.0, CRUX 3.1
Posts: 3,051
Blog Entries: 15

Rep: Reputation: 764Reputation: 764Reputation: 764Reputation: 764Reputation: 764Reputation: 764Reputation: 764
The auto-detect in the script doesn't always work, and realistically you shouldn't just leave things to chance when you are the system admin. In fact, you SHOULD flag the architecture because often I have had it build a i486/i686 package rather than a x86_64 package even without multilib installed.

As a system admin you should use this and other flags when you build packages.
 
Old 10-05-2012, 01:49 PM   #8
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,252

Rep: Reputation: 630Reputation: 630Reputation: 630Reputation: 630Reputation: 630Reputation: 630
Quote:
Originally Posted by ReaperX7 View Post
In fact, you SHOULD flag the architecture because often I have had it build a i486/i686 package rather than a x86_64 package even without multilib installed.
gcc in Slackware is not capable of cross-compiling. In a pure 64-bit Slackware64 installation it is not possible to create x86 packages. A package may fail to compile because the wrong CFLAGS were specified but you will never get an architecture-mismatched package. If you did get the wrong package type, then obviously you had some multilib or cross-compiler setup at the time.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
PulseAudio 2.0 and Slackware64 13.37 Refractor Slackware 2 08-08-2012 09:03 AM
[SOLVED] Slackware64 13.37 Multilib VisionIncision Slackware 8 07-23-2012 12:59 PM
Multilib with Slackware64-bit riganta Slackware 2 06-11-2011 12:57 PM
upgrading slackware64 13.1 multilib to slackware64 -current multilib Cultist Slackware 4 03-12-2011 09:04 AM
[SOLVED] Slackware64 multilib - E17 compiling problem? kukibl Slackware 1 10-08-2009 10:50 AM


All times are GMT -5. The time now is 10:48 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration