LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Compiling pulseaudio on slackware64 14 with multilib (http://www.linuxquestions.org/questions/slackware-14/compiling-pulseaudio-on-slackware64-14-with-multilib-4175430547/)

Chelyuk 10-04-2012 04:17 PM

Compiling pulseaudio on slackware64 14 with multilib
 
Hi to all,
New slackbuilds for slackware 14 resolved much of problems, but unfortunately not all. Now I can't compile pulseaudio and audacity, maybe something else. In compile process I have the same error:
Code:

/usr/bin/grep: /usr/lib/libFLAC.la: No such file or directory
/usr/bin/sed: can't read /usr/lib/libFLAC.la: No such file or directory
libtool: link: `/usr/lib/libFLAC.la' is not a valid libtool archive

I have flac-1.2.1-x86_64-3 installed, and all flac libs are located in /usr/lib64/
So, what is the right decision?

Daedra 10-04-2012 04:19 PM

http://www.slackbuilds.org/faq/#multilib

ReaperX7 10-04-2012 04:20 PM

Are you building pulseaudio for 32-bit or 64-bit?

Chelyuk 10-04-2012 04:27 PM

64-bit I guess, I'm just running slackbuild/].
Thank's Daedra, next time I'll read FAQ better.

ReaperX7 10-04-2012 09:29 PM

Try using this flag for the slackbuild when building software on Slackware64.:

Code:

ARCH=x86_64 ./pulseaudio.SlackBuild
Setting the script to default to x86_64 will ensure that the x86_64 package is built and not the i486 package.

xslc 10-04-2012 10:07 PM

Quote:

Originally Posted by ReaperX7 (Post 4797654)
Try using this flag for the slackbuild when building software on Slackware64.:

Code:

ARCH=x86_64 ./pulseaudio.SlackBuild

ipt to default to x86_64 will ensure that the x86_64 package is built and not the i486 package.

If architecture is 64 bits or 32 bits, he can recognize automatically. At the beginning
slackbuild script has been given to the detection mechanism
architecture.

Code:

if [ "$ARCH" = "i486" ]; then
  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi


ReaperX7 10-04-2012 10:35 PM

The auto-detect in the script doesn't always work, and realistically you shouldn't just leave things to chance when you are the system admin. In fact, you SHOULD flag the architecture because often I have had it build a i486/i686 package rather than a x86_64 package even without multilib installed.

As a system admin you should use this and other flags when you build packages.

T3slider 10-05-2012 02:49 PM

Quote:

Originally Posted by ReaperX7 (Post 4797687)
In fact, you SHOULD flag the architecture because often I have had it build a i486/i686 package rather than a x86_64 package even without multilib installed.

gcc in Slackware is not capable of cross-compiling. In a pure 64-bit Slackware64 installation it is not possible to create x86 packages. A package may fail to compile because the wrong CFLAGS were specified but you will never get an architecture-mismatched package. If you did get the wrong package type, then obviously you had some multilib or cross-compiler setup at the time.


All times are GMT -5. The time now is 10:37 PM.