LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 03-29-2013, 06:05 PM   #1
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0
Posts: 3,256

Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481
Compiling KDE4 KAlarm Without Akonadi


I ran across a wonderful statement in the KDE forums indicating KAlarm can be built without Akonadi support.

I browsed the kdepim 4.10.1 sources. Looks like these options still exist. Seems all that is needed is to add -DKALARM_USE_KRESOURCES=ON to the cmake compile options.

In the KDE4 slackbuilds, how do I set those build options? There is no separate kalarm or kdepim build script. I'm guessing I have to create a kdepim file in the cmake directory? I'm still trying to wrap my mind around how the whole KDE4 build scripts work.

I appreciate all help!

Note: I haven't yet found any such options for KMail.
 
Old 03-30-2013, 02:51 AM   #2
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 749

Rep: Reputation: 225Reputation: 225Reputation: 225
Quote:
Originally Posted by Woodsman View Post
In the KDE4 slackbuilds, how do I set those build options? There is no separate kalarm or kdepim build script. I'm guessing I have to create a kdepim file in the cmake directory?
Your on the right path there, just copy the default cmake file into your kdepim file and add your extra options to it.

Do note that kalarm is still bundled in kdepim so the build script will be called kdepim not kalarm.

To start the rebuild of the package you execute "./KDE.Slackbuild kdepim" to build kdepim

Might also be a good idea to add a build number to the build directory, it works the same as the cmake scripts only all the file contains is the build number.
 
Old 03-30-2013, 06:16 AM   #3
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,114

Rep: Reputation: Disabled
You can find the KDE.SLakBuild framework documented here if you want to know how to change stuff: http://alien.slackbook.org/blog/kde-...de-slackbuild/

Eric
 
Old 03-30-2013, 12:39 PM   #4
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0
Posts: 3,256

Original Poster
Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481
I'm doing something wrong.

I created a cmake/kdepim config file:

Code:
mkdir -p build
cd build
  cmake \
    $KDE_OPT_ARGS \
    -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
    -DCMAKE_C_FLAGS_RELEASE:STRING="$SLKCFLAGS" \
    -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
    -DCMAKE_CXX_FLAGS_RELEASE:STRING="$SLKCFLAGS" \
    -DCMAKE_BUILD_TYPE=Release \
    -DCMAKE_INSTALL_PREFIX=/usr \
    -DMAN_INSTALL_DIR=/usr/man \
    -DSYSCONF_INSTALL_DIR=/etc/kde \
    -DLIB_SUFFIX=${LIBDIRSUFFIX} \
    -DKALARM_USE_KRESOURCES=ON \          <-- The important option
    -DKALARM_USE_AKONADI=OFF \            <-- The important option
    ..
I created a cmake/kdepimlibs config file:

Code:
mkdir -p build
cd build
  cmake \
    $KDE_OPT_ARGS \
    -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
    -DCMAKE_C_FLAGS_RELEASE:STRING="$SLKCFLAGS" \
    -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
    -DCMAKE_CXX_FLAGS_RELEASE:STRING="$SLKCFLAGS" \
    -DCMAKE_BUILD_TYPE=Release \
    -DCMAKE_INSTALL_PREFIX=/usr \
    -DMAN_INSTALL_DIR=/usr/man \
    -DSYSCONF_INSTALL_DIR=/etc/kde \
    -DLIB_SUFFIX=${LIBDIRSUFFIX} \
    -DKDEPIM_NO_KRESOURCES=OFF \          <-- The important option
    ..
I ran the build like this:

BUILD=1a ./KDE.SlackBuild kdepim | tee ./build/kdepim-build-1a.log

After the cmake configuration completed I checked the cmake cache txt file and saw this:

grep -n KALARM_USE $TMP/kde-build/kdepim/kdepim-4.10.1/build/CMakeCache.txt

298:KALARM_USE_AKONADI:BOOL=OFF
301:KALARM_USE_KRESOURCES:UNINITIALIZED=ON

No errors during the build.

I installed the new packages with upgradepkg.

I started KAlarm from the command line to capture any stderr messages. There were no such messages. KAlarm starts (the KAlarm window appears) but is all grey with the infamous red X and the message "The Akonadi personal information management service is not operational."

Here are the errors of the report:

Akonadi Server Self-Test Report
===============================

Test 7: ERROR
--------
Akonadi control process not registered at D-Bus.

Test 8: ERROR
--------
Akonadi server process not registered at D-Bus.

Test 9: ERROR
--------
Nepomuk search service not registered at D-Bus.

Test 11: ERROR
--------
No resource agents found.

I have Nepomuk disabled and I do not start Akonadi, which is part of this whole idea.
 
Old 03-30-2013, 02:26 PM   #5
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0
Posts: 3,256

Original Poster
Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481
Update:

Regarding my previous post, I wasn't rebuilding kdepimlibs.

I rebuilt again in this order:

BUILD=1b ./KDE.SlackBuild kdepimlibs | tee ./build/kdepimlibs-build-1b.log
BUILD=1b ./KDE.SlackBuild kdepim | tee ./build/kdepim-build-1b.log

That created three packages.

Unfortunately, same results. KAlarm wants to start Akonadi and fails to start.
 
Old 03-30-2013, 11:14 PM   #6
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 749

Rep: Reputation: 225Reputation: 225Reputation: 225
I had a look at the source to see if there was anything else and it requires DEPRECATED features to be enabled and the build scripts in Slackware turn it all off.

Your going to have to go into the cmake directory and check everything in there for the option to turn them off and remove it and then rebuild the whole thing from scratch.
 
Old 03-31-2013, 01:10 PM   #7
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0
Posts: 3,256

Original Poster
Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481
Okay, but I'm not a cmake guru. Which features need to be enabled?

Rebuild from scratch: do you mean the entire KDE package set and deps or just the PIM packages?

Thanks.
 
Old 03-31-2013, 02:44 PM   #8
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0
Posts: 3,256

Original Poster
Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481
One note: I had the KALARM_USE_KRESOURCES=ON option in the kdepim config rather than kdepimlibs. After correcting kdepimlibs built fine but kdepim failed to build:

Code:
[ 70%] Building CXX object kalarm/CMakeFiles/kalarm_bin.dir/kalarmapp.o
/dev/shm/kde-build/kdepim/kdepim-4.10.1/kalarm/kalarmapp.cpp: In member function 'QStringList KAlarmApp::scheduledAlarmList()':
/dev/shm/kde-build/kdepim/kdepim-4.10.1/kalarm/kalarmapp.cpp:1212:48: error: no matching function for call to 'KAlarmCal::AlarmText::summary(KAlarmCal::KAEvent*&, int)'
/dev/shm/kde-build/kdepim/kdepim-4.10.1/kalarm/kalarmapp.cpp:1212:48: note: candidates are:
In file included from /dev/shm/kde-build/kdepim/kdepim-4.10.1/kalarm/editdlg.h:24:0,
                 from /dev/shm/kde-build/kdepim/kdepim-4.10.1/kalarm/commandoptions.h:24,
                 from /dev/shm/kde-build/kdepim/kdepim-4.10.1/kalarm/kalarmapp.cpp:28:
/usr/include/kalarmcal/alarmtext.h:136:17: note: QString KAlarmCal::AlarmText::summary() const
/usr/include/kalarmcal/alarmtext.h:136:17: note:   candidate expects 0 arguments, 2 provided
/usr/include/kalarmcal/alarmtext.h:171:24: note: static QString KAlarmCal::AlarmText::summary(const KAlarmCal::KAEvent&, int, bool*)
/usr/include/kalarmcal/alarmtext.h:171:24: note:   no known conversion for argument 1 from 'KAlarmCal::KAEvent*' to 'const KAlarmCal::KAEvent&'
make[2]: *** [kalarm/CMakeFiles/kalarm_bin.dir/kalarmapp.o] Error 1
make[1]: *** [kalarm/CMakeFiles/kalarm_bin.dir/all] Error 2
make: *** [all] Error 2
kdepim failed to build.
I noticed in the default cmake/cmake the build option KDE_PLATFORM_FEATURE_DISABLE_DEPRECATED=TRUE. I don't know whether that has to be changed to FALSE.
 
Old 03-31-2013, 06:10 PM   #9
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 749

Rep: Reputation: 225Reputation: 225Reputation: 225
Quote:
Originally Posted by Woodsman View Post
I noticed in the default cmake/cmake the build option KDE_PLATFORM_FEATURE_DISABLE_DEPRECATED=TRUE. I don't know whether that has to be changed to FALSE.
That is the option I was talking about. Though I'm not sure about the errors you got in your last post.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: How to disable Nepomuk, Strigi and Akonadi in KDE4 LXer Syndicated Linux News 0 03-22-2012 12:40 AM
Another KDE4/Akonadi/Stringi/Neopunk Thread (okay, mostly KDE4...) JimBrewster Slackware 3 01-19-2012 05:15 PM
KAlarm's times are off in Intrepid adanedhel728 Ubuntu 4 02-28-2009 02:32 PM
NetBSD 5.0 - Error Compiling KDE4 c!oud *BSD 2 01-14-2009 02:37 PM
Compiling KDE4.0 on Fedora 7 fails on building kdepimlibs-3.92.0 fooks Fedora 0 09-03-2007 08:10 AM


All times are GMT -5. The time now is 07:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration