LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-13-2010, 08:22 AM   #1
babai
LQ Newbie
 
Registered: Dec 2009
Location: kolkata,India
Distribution: Arch Linux, Slackware
Posts: 8

Rep: Reputation: 0
compiling conky: tolua_errors not found


I've trying to compile conky 1.7.2 in slack 13 with lua-cairo and lua-imlib2 bindings, have lua 5.1.4 installed and also installed tolua++-1.0.93 from der site installed it through scons..
here's my config_linux.py

Code:
## This is the linux configuration file
# This file was adapted to be used with ArchLinux
# Use 'scons -h' to see the list of command line options available

# Compiler flags (based on ArchLinux's installation of lua)
#LINKFLAGS = ['-g']
CCFLAGS = ['-O2', '-ansi', '-Wall' ]

#CCFLAGS = ['-g']

# this is the default directory for installation. Files will be installed on
# <prefix>/bin, <prefix>/lib and <prefix>/include when you run 'scons install'
#
# You can also specify this directory on the command line with the 'prefix'
# option
#
# You can see more 'generic' options for POSIX systems on config_posix.py

prefix = '/usr'

# libraries (based on ArchLinux's installation of lua)
LIBS = ['lua', 'dl', 'm']
tolua_bin = 'tolua++5.1'
tolua_lib = 'tolua+5.1'
TOLUAPP = 'tolua++5.1'
and still its giving me tolua_errors missing(i also tried with tolua_bin = tolua++ and so on)

ne ideas whats wrong here?
 
Old 03-13-2010, 10:20 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,560

Rep: Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512
' tolua++ ' is not "tolua" http://www.codenix.com/~tolua/
QUOTE: "tolua++ is an extended version of tolua,.."
( Latest tolua++ is 1.0.93, and you have that.)
tolua http://www.tecgraf.puc-rio.br/~celes/tolua/
Latest = tolua-5.1.3
http://www.tecgraf.puc-rio.br/~celes...a-5.1.3.tar.gz

The version available as a package for Slackware 13 :
tolua-5.1b-i486-1an.txz

> > http://repository.slacky.eu/slackwar...es/tolua/5.1b/
> http://repository.slacky.eu/slackwar...b-i486-1an.txz

Slacky.eu home http://www.slacky.eu/

.....

Last edited by knudfl; 03-13-2010 at 10:31 AM.
 
Old 03-13-2010, 11:03 AM   #3
babai
LQ Newbie
 
Registered: Dec 2009
Location: kolkata,India
Distribution: Arch Linux, Slackware
Posts: 8

Original Poster
Rep: Reputation: 0
well, i installed it from the link u gave me (thnks for that)

Code:
bash-3.1$ ls /var/log/packages/ | grep tolua
tolua-5.1b-i486-1an
but its still giving me the same error

Code:
checking for tolua++... tolua++
checking for library containing tolua_error... no
configure: error: tolua_error not found
 
Old 03-13-2010, 11:44 AM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,560

Rep: Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512
Google .. error: tolua_error not found ..
http://www.google.com/search?hl=en&s...&aqi=&aql=&oq=

The hits on the first page all seem to be about conky.
.....
 
Old 03-13-2010, 12:06 PM   #5
babai
LQ Newbie
 
Registered: Dec 2009
Location: kolkata,India
Distribution: Arch Linux, Slackware
Posts: 8

Original Poster
Rep: Reputation: 0
ya, but i'm using the same in arch(which is compiled and packaged thru makepkg) without any probs. Following arch's pkgbuild(with suitable mods) i'm trying to compile conky here in slack but no luck.
 
Old 03-13-2010, 02:04 PM   #6
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,560

Rep: Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512
error: tolua_error not found

Google .. error: tolua_error not found ..
http://www.google.com/search?hl=en&s...&aqi=&aql=&oq=

> > http://lists.mandriva.com/bugs/2009-11/msg05297.php
[Bug 55649] conky, NEW: conky has lua support disabled | bugs ...

I.e. conky 1.7.2 has a bug / or you can say, that lua/cairo is disabled.
Conky can be compiled only without the "lua/cairo" libraries.

This source http://packages.debian.org/sid/utils/conky
> [conky_1.7.1.1.orig.tar.gz], [conky_1.7.1.1-1.diff.gz]
works OK with :
./configure --prefix=/usr/ --enable-imlib2 --enable-lua-cairo

.....
 
Old 03-13-2010, 11:43 PM   #7
babai
LQ Newbie
 
Registered: Dec 2009
Location: kolkata,India
Distribution: Arch Linux, Slackware
Posts: 8

Original Poster
Rep: Reputation: 0
k, but here's the archlinux pkgbuild

http://aur.archlinux.org/packages/co...y-lua/PKGBUILD

i guess they are downloading conky 1.7.2 and compiling it with --enable-lua-cairo. So how are they succeeding?
 
Old 03-14-2010, 08:11 AM   #8
jostber
Member
 
Registered: Jul 2001
Location: Skien, Norway
Distribution: Slackware 14.0 64-bit
Posts: 228

Rep: Reputation: 41
You can try this:

http://linux-hardcore.com/index.php?topic=2564.0
 
Old 03-14-2010, 12:13 PM   #9
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,560

Rep: Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512
One more time .. Google ..
http://www.google.com/search?hl=en&s...&aqi=&aql=&oq=

The first hit http://bbs.archlinux.org/viewtopic.php?id=79616
.. says "solved", by using : LUA51_LIBS='-llua -lm'

.. but so far I haven't been able to make it work.
May be you can ?
.....
 
Old 03-15-2010, 01:09 AM   #10
babai
LQ Newbie
 
Registered: Dec 2009
Location: kolkata,India
Distribution: Arch Linux, Slackware
Posts: 8

Original Poster
Rep: Reputation: 0
fsck me! all these time i was compiling with LUA51_LIBS='llua -lm' and not LUA51_LIBS='-llua -lm' (there's an '-' missing)

neway got it to succesfully compile, thanks!!!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
conky question: passing conky-variable to shell-script zlin50 Linux - Software 2 12-29-2012 06:47 PM
libGL.so not found when compiling amarok Mistreated Linux - Software 2 12-31-2006 06:04 AM
Conky on Suse 10.0 - *** buffer overflow detected *** conky terminated Slidex Linux - Software 1 03-17-2006 11:50 AM
Compiling - libXext not found? badbunny Linux - Newbie 2 08-11-2005 11:42 AM
qt not found when compiling simeandrews Mandriva 9 06-05-2005 05:35 PM


All times are GMT -5. The time now is 02:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration