LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-27-2010, 07:53 AM   #16
sahko
Senior Member
 
Registered: Sep 2008
Distribution: Slackware
Posts: 1,041

Rep: Reputation: Disabled

Cairo with XCB support? Not a good idea

Last edited by sahko; 09-27-2010 at 07:55 AM.
 
Old 02-22-2013, 10:30 AM   #17
vectrum
Member
 
Registered: Jul 2011
Posts: 59

Rep: Reputation: Disabled
Have you any answer so far?

Have you any answer so far? I am facing the same problem. If you've resolved it then please let me know about it. I've tried on slack 14.
Thanks

Quote:
Originally Posted by Telumehtar View Post
Hi,

I've tried recompiling cairo with xcb enabled, but when I try to build awesome (v. 3.4.7), it still complains about missing cairo-xcb. Does anybody know how to fix this - or alternatively where I can find a slackbuild for awesome on slack 13.1?
 
Old 02-22-2013, 07:24 PM   #18
jkirchner
Member
 
Registered: Apr 2007
Location: West Virginia
Posts: 651

Rep: Reputation: 141Reputation: 141
Maybe this thread will help: http://www.linuxquestions.org/questi...cb-4175428047/
 
Old 02-23-2013, 03:08 PM   #19
vectrum
Member
 
Registered: Jul 2011
Posts: 59

Rep: Reputation: Disabled
jkirchner

Thanks but I couldn't understand anything from those posts.
I've enabled xcb support in cairo and installed it. I installed
xcb but getting the same message.

 
Old 02-26-2013, 02:23 PM   #20
bobzilla
Member
 
Registered: Nov 2005
Location: Serbia
Distribution: Slackware
Posts: 196

Rep: Reputation: Disabled
Awesome 3.x has several other dependencies. You might want to look at README. Last time I installed Awesome for testing, I think it required lua, oopango, oocairo, and 2 or three additional xcb packages. On 13.1 that list might be even longer.

On the other side, old 2.x works nicely on 14.0. But I'm not sure about 13.1 or 13.37.

But, I have to note I'm not using Awesome. Last time I tried it was on 13.37. But I was looking into archives to see if some older version works without recompiled cairo on 14.0, and it does. But I gues 2.x legacy series are pretty behind 3.x.

Anyways, recompiled Cairo is not enough.
 
Old 02-26-2013, 03:18 PM   #21
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,478

Rep: Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904
awesome's deps for version 3.5 (I have updated the original Chess Griffin's script) are confuse, imlib2, lgi and xdg-basedir (I've prepared slackbuilds for these last two).

you can install the latest version on -current, as xcb there fits it: I haven't tried at all updating xcb on 14.0, this is tested on a -current full installation.

for confuse, imlib2 and lua (needed by lgi) you can use slackbuilds.org's build scripts

http://cgit.ponce.cc/slackbuilds/commit/?h=lgi
( http://cgit.ponce.cc/slackbuilds/pla...ies/lgi/?h=lgi )

http://cgit.ponce.cc/slackbuilds/commit/?h=xdg-basedir
( http://cgit.ponce.cc/slackbuilds/pla...?h=xdg-basedir )

http://cgit.ponce.cc/slackbuilds/commit/?h=awesome
( http://cgit.ponce.cc/slackbuilds/pla...ome/?h=awesome )

if you're already on -current with sbopkg and you are using my SBo-git repository for -current, you can also create a /var/lib/sbopkg/queue/awesome.sqf file with this content
Code:
confuse
imlib2
lua
lgi
xdg-basedir
awesome
run a
Code:
sbopkg -i awesome
select the queue and process it

Last edited by ponce; 02-27-2013 at 12:24 AM.
 
1 members found this post helpful.
Old 03-01-2013, 07:21 PM   #22
bobzilla
Member
 
Registered: Nov 2005
Location: Serbia
Distribution: Slackware
Posts: 196

Rep: Reputation: Disabled
Thanx for the additional info.
 
  


Reply

Tags
awesome, compiling, slack13


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Seeking opinion: Xmonad (& Hask-hell deps), or AwesomeWM ? GrapefruiTgirl Linux - Desktop 14 03-01-2010 01:03 PM
Attempting to install xcb 1.4 and other AwesomeWM deps on Slack64 13 conartist6 Linux - Software 6 11-09-2009 10:25 PM
Compiling Ekiga on Slack 12.1 Slackovado Slackware 6 07-08-2008 08:55 PM
compiling slack 9.x abs Slackware 6 01-31-2004 04:18 AM
Compiling on slack vs mdk and others zarathustra674 Linux - Distributions 4 01-23-2004 05:47 PM


All times are GMT -5. The time now is 05:20 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration