LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 12-25-2007, 03:36 PM   #1
gmartin
Member
 
Registered: Mar 2003
Location: PA
Distribution: Slackware 13.37 Linux Reg # 341245
Posts: 285

Rep: Reputation: 40
Compiling audacity


I'm trying to compile audacity 1.3.3 using the script from
slackbuilds.org

During the confnigure step I get this error:
"configure: error: You requested using the system libraries for LIBFLAC but they are not available"

Earlier in the configure it reports:

Code:
checking for FLAC__file_decoder_new in -lFLAC... no
checking FLAC/format.h usability... yes
checking FLAC/format.h presence... yes
checking for FLAC/format.h... yes
configure: FLAC/FLAC++ libraries are NOT available as system libraries
checking for ./lib-src/libflac/include/FLAC/format.h... no
checking for ./lib-src/libflac/include/FLAC++/decoder.h... no
configure: FLAC libraries are NOT available in this source tree
I currently have flac-1.2.1 installed and the following lib files as it was needed to build easytag. Should I revert back to flac-1.1.2?

Thanks, all & Merry Christmas!

Last edited by gmartin; 12-25-2007 at 03:46 PM.
 
Old 12-25-2007, 05:23 PM   #2
dissociative
Member
 
Registered: Jul 2007
Posts: 36

Rep: Reputation: 15
I think that audacity uses flac 1.1.2, flac-1.2.1 is not supported yet
 
Old 12-25-2007, 06:50 PM   #3
gmartin
Member
 
Registered: Mar 2003
Location: PA
Distribution: Slackware 13.37 Linux Reg # 341245
Posts: 285

Original Poster
Rep: Reputation: 40
Quote:
Originally Posted by dissociative View Post
I think that audacity uses flac 1.1.2, flac-1.2.1 is not supported yet
I suspect you are right, but I cannot confirm via their website or wiki. I'll compile without flac for now.

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
trouble compiling wxGTK and audacity BCarey Slackware 18 06-22-2007 02:25 PM
Error compiling Audacity: says I need wxGTK-2.4, but I do have it vasudevadas Linux - Software 4 01-22-2007 04:24 AM
Error compiling audacity vharishankar Slackware 12 04-05-2006 11:20 AM
Compiling Audacity 1.2.3 in Linux Mandrake 10.1 nightrider Linux - Newbie 2 08-17-2005 12:50 AM
Why do I get compile errors while compiling audacity? pujolasdf Linux - Software 9 06-27-2005 02:02 PM


All times are GMT -5. The time now is 11:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration