LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 07-11-2011, 07:24 PM   #1
skubik
Member
 
Registered: May 2003
Location: A dark corner in Canada
Distribution: Slackware 10.1
Posts: 100

Rep: Reputation: 17
Compiling Audacious in multilib Slack64


I'm running GSB 3.0 on my Slack64 13.37 system and it's been running great, but Gnome 3 uses Pulseaudio for audio playback, which seems to work ok with Flash & sound effects, but when I play anything in Audacious, I get errors which I assume has to do with the absence of a Pulseaudio Output Plugin in the Slackbuild of Audacious. (I was able to download an xmms-pulse plugin and use it successfully using xmms, but I'm not quite prepared to jump back to xmms from Audacious if I don't have to)

So I've downloaded the necessary files from a Slackware mirror from the source/audacious/ directories and have run the audacious.Slackbuild script, but I'm getting the following error when building audtool:

Quote:
/usr/lib64/gcc/x86_64-slackware-linux/4.5.2/../../../../x86_64-slackware-linux/bin/ld: skipping incompatible /usr/lib/libgdk_pixbuf-2.0.so when searching for -lgdk_pixbuf-2.0
/usr/lib64/gcc/x86_64-slackware-linux/4.5.2/../../../../x86_64-slackware-linux/bin/ld: cannot find -lgdk_pixbuf-2.0
I HAVE installed multilib as per Alien's instructions, and everything seems to be running well, but in this case it seems like ld is finding the 32bit libs first and causing the error instead of using the 64bit libs.
I've looked and I *do* have both:
/usr/lib/libgdk_pixbuf-2.0.so.0 AND
/usr/lib64/libgdk_pixbuf-2.0.so.0

How can I force ld to use the 64bit library in /usr/lib64 and not the 32bit one in /usr/lib?
I've tried setting ARCH=x86_64 and CFLAGS=-m64 to no avail.

Thoughts?
 
Old 07-11-2011, 08:07 PM   #2
Mike_M
Member
 
Registered: Mar 2011
Location: California
Distribution: Slackware
Posts: 116

Rep: Reputation: 50
Try adding the following to your build script:

Code:
LDFLAGS="-L/usr/lib${LIBDIRSUFFIX}" \
prior to the configure line so that it looks something like this:

Code:
LDFLAGS="-L/usr/lib${LIBDIRSUFFIX}" \
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
   ... etc ...
 
  


Reply

Tags
audacious, multilib, slackware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Broffice not compile on Slack64(multilib or no multilib);SlackBuild afreitascs Slackware 4 06-14-2010 08:16 AM
Multilib slack64 wingevil Slackware 6 02-21-2010 08:53 PM
printing from firefox with slack64 and multilib BCarey Slackware 3 01-11-2010 11:30 AM
slack64: help for repair AlienBobs multilib wingevil Slackware 14 10-29-2009 06:52 AM
libdrm from git - Slack64 multilib? kukibl Slackware 1 10-14-2009 04:16 PM


All times are GMT -5. The time now is 02:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration