LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Compiling Audacious in multilib Slack64 (http://www.linuxquestions.org/questions/slackware-14/compiling-audacious-in-multilib-slack64-891174/)

skubik 07-11-2011 06:24 PM

Compiling Audacious in multilib Slack64
 
I'm running GSB 3.0 on my Slack64 13.37 system and it's been running great, but Gnome 3 uses Pulseaudio for audio playback, which seems to work ok with Flash & sound effects, but when I play anything in Audacious, I get errors which I assume has to do with the absence of a Pulseaudio Output Plugin in the Slackbuild of Audacious. (I was able to download an xmms-pulse plugin and use it successfully using xmms, but I'm not quite prepared to jump back to xmms from Audacious if I don't have to)

So I've downloaded the necessary files from a Slackware mirror from the source/audacious/ directories and have run the audacious.Slackbuild script, but I'm getting the following error when building audtool:

Quote:

/usr/lib64/gcc/x86_64-slackware-linux/4.5.2/../../../../x86_64-slackware-linux/bin/ld: skipping incompatible /usr/lib/libgdk_pixbuf-2.0.so when searching for -lgdk_pixbuf-2.0
/usr/lib64/gcc/x86_64-slackware-linux/4.5.2/../../../../x86_64-slackware-linux/bin/ld: cannot find -lgdk_pixbuf-2.0
I HAVE installed multilib as per Alien's instructions, and everything seems to be running well, but in this case it seems like ld is finding the 32bit libs first and causing the error instead of using the 64bit libs.
I've looked and I *do* have both:
/usr/lib/libgdk_pixbuf-2.0.so.0 AND
/usr/lib64/libgdk_pixbuf-2.0.so.0

How can I force ld to use the 64bit library in /usr/lib64 and not the 32bit one in /usr/lib?
I've tried setting ARCH=x86_64 and CFLAGS=-m64 to no avail.

Thoughts?

Mike_M 07-11-2011 07:07 PM

Try adding the following to your build script:

Code:

LDFLAGS="-L/usr/lib${LIBDIRSUFFIX}" \
prior to the configure line so that it looks something like this:

Code:

LDFLAGS="-L/usr/lib${LIBDIRSUFFIX}" \
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
  ... etc ...



All times are GMT -5. The time now is 05:50 PM.