LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-27-2013, 07:10 AM   #1
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,868

Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
Compiling 2ManDVD on Slackware 14.0 - failing on patch.


As the title suggests, 2ManDVD fails to compile on 14.0, it worked on 13.37.

Here are the last few lines:

Code:
patching file mainfrm.cpp
Hunk #1 succeeded at 1324 (offset 279 lines).
/usr/lib64/qt/bin/uic mainfrm.ui -o ui_mainfrm.h
g++ -c -O2 -fPIC -O2 -Wall -W -D_REENTRANT -D__STDC_CONSTANT_MACROS -DQT_NO_DEBUG -DQT_OPENGL_LIB -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/lib64/qt/mkspecs/linux-g++-64 -I. -I/usr/lib64/qt/include/QtCore -I/usr/lib64/qt/include/QtGui -I/usr/lib64/qt/include/QtOpenGL -I/usr/lib64/qt/include -I/usr/include/ffmpeg/ -I/usr/include -Imoc -I. -o obj/main.o main.cpp
In file included from mainfrm.h:26:0,
                 from main.cpp:2:
tetrahedron.h:147:5: error: 'GLUquadricObj' does not name a type
make: *** [obj/main.o] Error 1
I also can not find a listing for the program in slackbuild for 14.0. Not sure if this means it will not run on 14, or not.

I looked through the slackbuild but did not see anything outstanding; ( I'm no expert ).
 
Old 04-27-2013, 08:06 AM   #2
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,617

Rep: Reputation: 444Reputation: 444Reputation: 444Reputation: 444Reputation: 444
If it isn't listed in slackbuild 14.0 while it was in 13.37, then it wasn't buildable in 14.0
That's why it was removed
 
Old 04-27-2013, 08:08 AM   #3
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,617

Rep: Reputation: 444Reputation: 444Reputation: 444Reputation: 444Reputation: 444
Try use newer version 1.8.4
Hope it works with slackware 14.0
 
Old 04-27-2013, 08:32 AM   #4
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,495

Rep: Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912
no, it doesn't work, it's not compatible with the ffmpeg on SBo.
 
Old 04-27-2013, 09:17 AM   #5
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,868

Original Poster
Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
Thank-you for the responses. There are other options for slideshows on DVD's. I will look into those options.
 
Old 04-27-2013, 11:15 AM   #6
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,495

Rep: Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912
Just had another look at it and found some patches in the gentoo sources: build goes fine on -current, but it segfaults at launch.
If you want to have a try with it on 14.0 (I haven't got one to test it ATM) sources are here

http://ponce.cc/slackware/testing/2ManDVD/

if it fails go with dvdstyler (that works fine).
 
Old 04-27-2013, 01:27 PM   #7
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,868

Original Poster
Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
I'll give it a try, and post back. Thank-you.
 
Old 04-27-2013, 01:41 PM   #8
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,868

Original Poster
Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
The package builds fine here too. Unfortunately, it seg-faults on launch.

Quote:
2ManDVD
Fontconfig error: "local.conf", line 7: junk after document element
LOCALE : "en"
COPY 2MANDVD LIBRARY INTO "/home/cliff/.2ManDVD_Library/"
Segmentation fault
When I launch 2ManDVD, I see an image on the monitor for less than a second, it disappears.

I have also installed dvdstyler, and it is working.

Last edited by camorri; 04-27-2013 at 01:43 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] DVDStyler fails with Slackbuild; and 2ManDVD won't load. camorri Slackware 5 12-27-2011 04:49 PM
Xorg failing after patch install ADxD_7 Solaris / OpenSolaris 4 08-27-2007 07:42 PM
Compiling Programs - Always Failing? mEo Linux - Newbie 9 05-01-2006 05:06 AM
ezmlm patch failing ewlnxnewB Linux - Software 0 11-30-2003 11:05 PM
ACPI patch ... hunks failing Ianed Linux - Hardware 4 09-04-2003 08:04 PM


All times are GMT -5. The time now is 09:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration