LinuxAnswers - the LQ Linux tutorial section.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 01-02-2011, 11:52 AM   #1
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),OpenSuse 13.2 (Laptop & Desktop),, OpenSuse 13.2 on the wifes lappy
Posts: 774

Rep: Reputation: 97
Compile error when building SBOPKG for libsoup

Hi all,

Trying to get Midori browser from SBOpkg's and one of the dependencies is libsoup.

However, when building libsoup I am getting this compile error

checking for GLIB - version >= 2.21.3... 
*** 'pkg-config --modversion glib-2.0' returned 2.26.0, but GLIB (2.26.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
configure: error: GLIB 2.21.3 or later is required to build libsoup
Anyone able to give me a pointer in the right direction to overcome this.

Old 01-02-2011, 01:00 PM   #2
Alien Bob
Slackware Contributor
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,793

Rep: Reputation: Disabled
Perhaps you have two versions of glib installed?

On Slackware 13.1:
$ pkg-config --modversion glib-2.0
while on Slackware-current:
$ pkg-config --modversion glib-2.0
It appears that you are running a Slackware -current that is somewhat broken.

1 members found this post helpful.
Old 01-02-2011, 01:35 PM   #3
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),OpenSuse 13.2 (Laptop & Desktop),, OpenSuse 13.2 on the wifes lappy
Posts: 774

Original Poster
Rep: Reputation: 97
Thanks Alien Bob. Pointed me in the right direction. Last upgrade I failed to upgrade glib to the current version. Done that and the compile works fine.

many thanks


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
sbopkg error message. glore2002 Slackware 23 09-18-2009 05:27 PM
webkit compile error on libsoup borsaman Linux - Software 1 08-17-2009 08:27 AM
Sbopkg error adriv Slackware 5 04-09-2009 04:11 PM
building lfs 6.1.1 ,compile glibc error godsad Linux From Scratch 3 03-19-2009 09:54 AM
libsoup-2.2.91 compile error mushk45 Slackware 2 03-29-2006 03:13 PM

All times are GMT -5. The time now is 02:22 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration