Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 01-21-2013, 04:47 AM   #1
LQ Newbie
Registered: Jan 2013
Posts: 6

Rep: Reputation: Disabled
Colour issue with webcam on Thinkpad X230; Slackware 14.0

Well, I had a few issues with this computer initially, but I upgraded the kernel to 3.6.11 and most of them disappeared except for this one. Basically the video just appears fuzzy and the colour looks a bit off. I get the following output when I run “mplayer tv://”:

MPlayer 1.1-4.7.1 (C) 2000-2012 MPlayer Team

Playing tv://.
TV file format detected.
Selected driver: v4l2
name: Video 4 Linux 2 input
author: Martin Olschewski <>
comment: first try, more to come ;-)
v4l2: your device driver does not support VIDIOC_G_STD ioctl, VIDIOC_G_PARM was used instead.
Selected device: Integrated Camera
Capabilities: video capture streaming
supported norms:
inputs: 0 = Camera 1;
Current input: 0
Current format: YUYV
v4l2: ioctl set format failed: Invalid argument
v4l2: ioctl set format failed: Invalid argument
v4l2: ioctl set format failed: Invalid argument
tv.c: norm_from_string(pal): Bogus norm parameter, setting default.
v4l2: ioctl enum norm failed: Invalid argument
Error: Cannot set norm!
Selected input hasn't got a tuner!
v4l2: ioctl set mute failed: Invalid argument
Opening video decoder: [raw] RAW Uncompressed Video
Movie-Aspect is undefined - no prescaling applied.
VO: [xv] 640x480 => 640x480 Packed YUY2
Selected video codec: [rawyuy2] vfm: raw (RAW YUY2)
Audio: no sound
Starting playback...
Here's the relevant portion of dmesg:

[ 5.466621] usb 1-1.6: New USB device found, idVendor=5986, idProduct=02d2
[ 5.466718] usb 1-1.6: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 5.466853] usb 1-1.6: Product: Integrated Camera
[ 5.466942] usb 1-1.6: Manufacturer: Ricoh Company Ltd.
[ 5.479048] Linux video capture interface: v2.00
[ 5.482364] uvcvideo: Found UVC 1.00 device Integrated Camera (5986:02d2)
[ 5.484907] input: Integrated Camera as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.6/1-1.6:1.0/input/input7
[ 5.485180] usbcore: registered new interface driver uvcvideo
[ 5.485276] USB Video Class driver (1.1.1)
Any help would be greatly appreciated.
Old 01-22-2013, 04:16 PM   #2
LQ Newbie
Registered: Aug 2012
Location: Germany
Distribution: Slackware64-current, Slackware64 14.0
Posts: 28

Rep: Reputation: Disabled
I got a x230 myself. I tested the webcam with:

mplayer -fps 30 -tv driver=v4l2:width=1280:height=720:device=/dev/video0 tv://
You should adjust your resolution in your command.
Still the picture is not the best but its only 720p.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Howto change black background colour in conky with transparency color in slackware 14 imanulyaqin Linux - Desktop 2 12-19-2012 12:52 AM
beep(1) not working on ThinkPad X230 tarverator Linux - Hardware 12 09-17-2012 08:20 AM
GE Webcam issue rswier Linux - Hardware 1 07-11-2007 07:31 AM
Sound Issue, SuSE 9.3 IBM Thinkpad Toolbox Linux - Hardware 9 10-08-2005 01:54 AM
XFree86 colour depth (Slackware 8.0) bluskyambition Linux - Newbie 6 01-17-2002 01:38 PM

All times are GMT -5. The time now is 09:19 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration