LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Colour issue with webcam on Thinkpad X230; Slackware 14.0 (http://www.linuxquestions.org/questions/slackware-14/colour-issue-with-webcam-on-thinkpad-x230%3B-slackware-14-0-a-4175446556/)

dh_ 01-21-2013 03:47 AM

Colour issue with webcam on Thinkpad X230; Slackware 14.0
 
Well, I had a few issues with this computer initially, but I upgraded the kernel to 3.6.11 and most of them disappeared except for this one. Basically the video just appears fuzzy and the colour looks a bit off. I get the following output when I run “mplayer tv://”:

Quote:

MPlayer 1.1-4.7.1 (C) 2000-2012 MPlayer Team

Playing tv://.
TV file format detected.
Selected driver: v4l2
name: Video 4 Linux 2 input
author: Martin Olschewski <olschewski@zpr.uni-koeln.de>
comment: first try, more to come ;-)
v4l2: your device driver does not support VIDIOC_G_STD ioctl, VIDIOC_G_PARM was used instead.
Selected device: Integrated Camera
Capabilities: video capture streaming
supported norms:
inputs: 0 = Camera 1;
Current input: 0
Current format: YUYV
v4l2: ioctl set format failed: Invalid argument
v4l2: ioctl set format failed: Invalid argument
v4l2: ioctl set format failed: Invalid argument
tv.c: norm_from_string(pal): Bogus norm parameter, setting default.
v4l2: ioctl enum norm failed: Invalid argument
Error: Cannot set norm!
Selected input hasn't got a tuner!
v4l2: ioctl set mute failed: Invalid argument
==========================================================================
Opening video decoder: [raw] RAW Uncompressed Video
Movie-Aspect is undefined - no prescaling applied.
VO: [xv] 640x480 => 640x480 Packed YUY2
Selected video codec: [rawyuy2] vfm: raw (RAW YUY2)
==========================================================================
Audio: no sound
Starting playback...
Here's the relevant portion of dmesg:

Quote:

[ 5.466621] usb 1-1.6: New USB device found, idVendor=5986, idProduct=02d2
[ 5.466718] usb 1-1.6: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 5.466853] usb 1-1.6: Product: Integrated Camera
[ 5.466942] usb 1-1.6: Manufacturer: Ricoh Company Ltd.
[ 5.479048] Linux video capture interface: v2.00
[ 5.482364] uvcvideo: Found UVC 1.00 device Integrated Camera (5986:02d2)
[ 5.484907] input: Integrated Camera as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.6/1-1.6:1.0/input/input7
[ 5.485180] usbcore: registered new interface driver uvcvideo
[ 5.485276] USB Video Class driver (1.1.1)
Any help would be greatly appreciated.

comfree 01-22-2013 03:16 PM

I got a x230 myself. I tested the webcam with:

Code:

mplayer -fps 30 -tv driver=v4l2:width=1280:height=720:device=/dev/video0 tv://
You should adjust your resolution in your command.
Still the picture is not the best but its only 720p.


All times are GMT -5. The time now is 02:09 AM.