LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-07-2009, 08:28 AM   #1
~sHyLoCk~
Senior Member
 
Registered: Jul 2008
Location: /dev/null
Posts: 1,173
Blog Entries: 12

Rep: Reputation: 129Reputation: 129
Cmake error


Hi. I'm using a fresh install of slackware64 with vbatts 4.3.1 kde packages on stable. While building a kde plugin with cmake I get this error:

Code:
# cmake ../ -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix`                                                                                                                      
-- Found Qt-Version 4.5.1 (using /usr/bin/qmake)                                                                             
-- Found X11: /usr/lib64/libX11.so                                                                                           
-- Phonon Version: 4.3.0                                                                                                     
CMake Error at /usr/share/apps/cmake/modules/FindKDE4Internal.cmake:1098 (message):                                          
  Qt compiled without support for -fvisibility=hidden.  This will break                                                      
  plugins and linking of some applications.  Please fix your Qt installation.                                                
Call Stack (most recent call first):                                                                                         
  /usr/share/cmake-2.6/Modules/FindKDE4.cmake:81 (FIND_PACKAGE)                                                              
  CMakeLists.txt:4 (find_package)       
-- Configuring incomplete, errors occurred!
i am fully updated with the stable patches/upgrades. Do I need to install anything else?
 
Old 12-07-2009, 08:53 AM   #2
JokerBoy
Member
 
Registered: Sep 2009
Posts: 140

Rep: Reputation: 23
have you tried with qt and phonon from -current?
 
Old 12-07-2009, 09:27 AM   #3
~sHyLoCk~
Senior Member
 
Registered: Jul 2008
Location: /dev/null
Posts: 1,173
Blog Entries: 12

Original Poster
Rep: Reputation: 129Reputation: 129
No I haven't. i am downloading them now. Thanks or the clue.
 
Old 12-07-2009, 10:04 AM   #4
~sHyLoCk~
Senior Member
 
Registered: Jul 2008
Location: /dev/null
Posts: 1,173
Blog Entries: 12

Original Poster
Rep: Reputation: 129Reputation: 129
Nope still the same error. Any other packages I need to install?
 
Old 12-07-2009, 10:10 AM   #5
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,404

Rep: Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852
found this.
 
Old 12-07-2009, 11:01 AM   #6
~sHyLoCk~
Senior Member
 
Registered: Jul 2008
Location: /dev/null
Posts: 1,173
Blog Entries: 12

Original Poster
Rep: Reputation: 129Reputation: 129
Thanks poncez.
How can I ad the -fvisibility=hidden flag?
I tried adding: -fvisibility-hidden \ in Slackbuild but doesn't work.
Or shall I just use:
./qt.Slackbuild -fvisibility=hidden, will that work?
 
Old 12-07-2009, 11:05 AM   #7
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,404

Rep: Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852
I think you have to add it to SLKCFLAGS variable inside qt.SlackBuild: on stock slackbuild for x86_64 is
Code:
SLKCFLAGS="-O2 -fPIC"
but, I think, it has to become
Code:
SLKCFLAGS="-O2 -fPIC -fvisibility=hidden"
not sure if this will fix your issue (let you compile plugins) but it's worth a try.

just notice that that error happens also if you try to build the plugin on a filesystem with the noexec flag set.

Last edited by ponce; 12-07-2009 at 11:13 AM.
 
Old 12-07-2009, 11:12 AM   #8
~sHyLoCk~
Senior Member
 
Registered: Jul 2008
Location: /dev/null
Posts: 1,173
Blog Entries: 12

Original Poster
Rep: Reputation: 129Reputation: 129
Hi, thanks for the reply.I am getting:

Code:
Creating qmake. Please wait...
g++ -c -o project.o -m64 -pipe -DQMAKE_OPENSOURCE_EDITION -I. -Igenerators -Igenerators/unix -Igenerators/win32 -Igenerators/mac -I/tmp/qt-4.5.3_063bded/include -I/tmp/qt-4.5.3_063bded/include/QtCore -I/tmp/qt-4.5.3_063bded/src/corelib/global -I/tmp/qt-4.5.3_063bded/src/script -DQT_NO_PCRE -DQT_BUILD_QMAKE -DQT_BOOTSTRAPPED -DQT_NO_TEXTCODEC -DQT_NO_UNICODETABLES -DQT_NO_COMPONENT -DQT_NO_STL -DQT_NO_COMPRESS -I/tmp/qt-4.5.3_063bded/mkspecs/linux-g++-64 -DHAVE_QCONFIG_CPP -DQT_NO_THREAD -DQT_NO_QOBJECT -DQT_NO_GEOM_VARIANT -O2 -fPIC -fvisibility-hidden project.cpp
cc1plus: error: unrecognized command line option "-fvisibility-hidden"
gmake: *** [project.o] Error 1
make: *** No targets specified and no makefile found.  Stop.
make: *** No targets specified and no makefile found.  Stop.
 
Old 12-07-2009, 11:15 AM   #9
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,404

Rep: Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852
sorry, i edited above, it's -fvisibility=hidden, but check also about the noexec attribute (read above) for the filesystem where you are building the plugin (should be in /etc/fstab).

Last edited by ponce; 12-07-2009 at 11:17 AM.
 
Old 12-07-2009, 11:20 AM   #10
~sHyLoCk~
Senior Member
 
Registered: Jul 2008
Location: /dev/null
Posts: 1,173
Blog Entries: 12

Original Poster
Rep: Reputation: 129Reputation: 129
Hi, yeah I realised that and it's compiling now after making the edit.
Anyway, I'm building it on /home , I just have a single partition for slack here ,besides swap.

Code:
/dev/hda3        /                ext4        defaults         1   1
EDIT: It still shows the same error. I'm guessing cmake is messed up?

EDIT2: Things are done. I had to delete ~/.kde and reboot.

Last edited by ~sHyLoCk~; 12-07-2009 at 12:49 PM.
 
Old 12-07-2009, 01:00 PM   #11
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,404

Rep: Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852
happy you solved it
maybe you needed only to remove the file in .kde with qt settings (don't remember now the exact name and position) and restart X but this way everything is cleaner

Last edited by ponce; 12-07-2009 at 01:09 PM.
 
  


Reply

Tags
cmake, error, qt


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CMAKE error, some help needed here! Rasmus Linux - Software 1 10-26-2009 09:35 AM
PBuilder error after cmake Patrick793 Linux - Software 0 10-13-2008 05:11 PM
CMake error: QT qmake not found sean_zhang Linux - Software 4 02-19-2008 11:34 AM
CMake error -- needs full path of compiler Penguin of Wonder Programming 2 01-31-2006 03:22 PM
CMake Error: Cannot find wx-config anywhere on the system. corso64 Linux - Software 0 10-04-2004 04:21 PM


All times are GMT -5. The time now is 05:00 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration