LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-25-2005, 12:14 PM   #1
killahsmurf
Member
 
Registered: Mar 2005
Distribution: Slackware
Posts: 50

Rep: Reputation: 15
CLI copy is greater than GUI copy ?? 0_o


so the lady friend blesses me with a cool mp3 player on this lovely xmas morning... great! now all i have to do is 'mount /dev/sda1 /mnt/mp3 and copy n paste my heart away! . i couldnt be any more wrong. for some strange reason when it mounts fine. but when i go to to take a song from my song dir and place it in the mounted dir. it get an access denied error. however when i copy something from the command line to the mounted dir, all is well.

why would copying from konqueror be so different from the cli? and how to i get around that. i certainly dont remember having a problem like this in the past.
not only that though, but when i chown the mounted dir. it doesnt stick, it changes back to root . theres gotta be a reason for this. any help here would be greatly appreciated as usual. its probably something really small that im missing. thanks anyway fellas.
 
Old 12-25-2005, 12:20 PM   #2
killahsmurf
Member
 
Registered: Mar 2005
Distribution: Slackware
Posts: 50

Original Poster
Rep: Reputation: 15
nevermind -_-

disregard that last post... im an idiot, ill just leave it at that.
 
Old 12-25-2005, 04:03 PM   #3
Dankles
Member
 
Registered: May 2004
Location: /dev/null
Distribution: Slackware
Posts: 245

Rep: Reputation: 31
Quote:
Originally Posted by killahsmurf
disregard that last post... im an idiot, ill just leave it at that.
If you dont mind me asking, what was the problem?
 
Old 12-25-2005, 05:09 PM   #4
killahsmurf
Member
 
Registered: Mar 2005
Distribution: Slackware
Posts: 50

Original Poster
Rep: Reputation: 15
nope, dont mind the asking at all. the prollem is a permissions deal. i mount the mp3 player, but only root can write to it. originally when i first tried to do it from the command line, i was already doing everything as root, therefore causing me to believe that the cp command would only work from cli.

however this problem is still going on, and i really cant figure out why i cant get users to write to this drive. and theres something else goin on too. i have an ntfs partition on my other harddrive. everything works fine with it. however, i just noticed that when i umount and and remount it, that now im locked out of that partition as a user. only root is allowed in.. how the hell did that happen

going back to the mp3 player issue. i added a line in my fstab to tell slack how to mount sda1 when i do. however it made absolutely no difference. what else do i have to do here???
 
Old 12-25-2005, 05:37 PM   #5
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,123

Rep: Reputation: 162Reputation: 162
What are your settings for the fs options in /etc/fstab? You can give users rights with the user or users option. I have:

/dev/sda4 /mnt/iriver vfat noauto,users 0 0

The keyword user lets a user mount/unmount the drive. Users does something similar, but allows any user to unmount it.
 
Old 12-27-2005, 02:22 AM   #6
killahsmurf
Member
 
Registered: Mar 2005
Distribution: Slackware
Posts: 50

Original Poster
Rep: Reputation: 15
ok, this is officially making no sense to me as of yet. according to the fstab man pages. having the 'user' option set in the file is supposed make it so that normal users can mount that partition... absolutely not! only root can mount it, yet it can be umounted by anyone 0_o . not only that, after root mounts it, only root can write to it. i spent all of yesterday rackin my brain over this. however i did find a way to mount it so that user can write to it as well. the command

mount /dev/sda1 /mnt/mp3 -o uid=[username]

allows for a particular user to write to the mp3 player cause then that user is acting as the owner of this. this is a pain in the ass to do everytime though, i shouldnt have to do that. bottom line is, i want to be able to mount it from user and write to it. the 'user' option in fstab is supposed to work that out for me, but im receiving no lovin. observe my fstab file and please please tell me where i might have errors in it.

/dev/hdb2 swap swap defaults 0 0
/dev/hdb3 / reiserfs defaults 1 1
/dev/hda1 /mnt/win2k ntfs ro,user,users,exec,umask=000 1 0
/dev/hdb5 /mnt/fat32 vfat defaults,user,rw,exec,umask=000 1 0
/dev/hdd /mnt/cdrom iso9660 noauto,users,ro,umask=000 0 0
/dev/hdc /mnt/dvdrom iso9660 noauto,users,ro,umask=000 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
/dev/sda1 /mnt/mp3 auto noauto,user,users,sync 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0


you might ask why i have 'user' and 'users' in the same line. thats cause i was trying something out, and wanted to see how that would affect how i can mount/umount certain things.

also, riddle me this. why is it that when i umount my win2k partition, then remount it, that im then locked out of that partition (folder) as user guys, i can really use any input here, im really going crazy.

thanks again fellas.
 
Old 12-27-2005, 02:37 AM   #7
killahsmurf
Member
 
Registered: Mar 2005
Distribution: Slackware
Posts: 50

Original Poster
Rep: Reputation: 15
ok, this is officially making no sense to me as of yet. according to the fstab man pages. having the 'user' option set in the file is supposed make it so that normal users can mount that partition... absolutely not! only root can mount it, yet it can be umounted by anyone 0_o . not only that, after root mounts it, only root can write to it. i spent all of yesterday rackin my brain over this. however i did find a way to mount it so that user can write to it as well. the command

mount /dev/sda1 /mnt/mp3 -o uid=[username]

allows for a particular user to write to the mp3 player cause then that user is acting as the owner of this. this is a pain in the ass to do everytime though, i shouldnt have to do that. bottom line is, i want to be able to mount it from user and write to it. the 'user' option in fstab is supposed to work that out for me, but im receiving no lovin. observe my fstab file and please please tell me where i might have errors in it.

/dev/hdb2 swap swap defaults 0 0
/dev/hdb3 / reiserfs defaults 1 1
/dev/hda1 /mnt/win2k ntfs ro,user,users,exec,umask=000 1 0
/dev/hdb5 /mnt/fat32 vfat defaults,user,rw,exec,umask=000 1 0
/dev/hdd /mnt/cdrom iso9660 noauto,users,ro,umask=000 0 0
/dev/hdc /mnt/dvdrom iso9660 noauto,users,ro,umask=000 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
/dev/sda1 /mnt/mp3 auto noauto,user,users,sync 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0


you might ask why i have 'user' and 'users' in the same line. thats cause i was trying something out, and wanted to see how that would affect how i can mount/umount certain things.

also, riddle me this. why is it that when i umount my win2k partition, then remount it, that im then locked out of that partition (folder) as user guys, i can really use any input here, im really going crazy.

thanks again fellas.
 
Old 12-27-2005, 02:47 AM   #8
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,123

Rep: Reputation: 162Reputation: 162
Have you tried the uid or gid options yet? According to the man page for mount, under mount options for ntfs, unless you set the uid and/or gid when mounting the file system the files are owned by root and not readable by somebody else.
 
Old 12-27-2005, 04:38 AM   #9
dunric
Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 479

Rep: Reputation: 89
The record in your fstab seems to be correct.
What error message do you get, when you do
Code:
mount /mnt/mp3
as normal user ?

Concerning unmounting by anyone, option users is there exactly for this purpose. See the manpage for mount

Last edited by dunric; 12-27-2005 at 04:40 AM.
 
Old 12-27-2005, 10:17 AM   #10
killahsmurf
Member
 
Registered: Mar 2005
Distribution: Slackware
Posts: 50

Original Poster
Rep: Reputation: 15
the error i get when i try to mount anything as user is "mount: only root can do that". but isnt that what the user option is for?? ans as far as my ntfs partition goes. from fstab it mounts just fine, anyone can access it. and yes, if i use uid options, then im not locked out. the confusion as far as that comes from the fact that i never put any uid option in my fstab file, so why does it work just fine from there?

i guess the main concern/confusion at this point would be the fact that the user option has yet to work for me, and i need to know why. cause i can take that option out, and absolutely nothing changes. bah... thanks again guys
 
Old 12-27-2005, 10:23 AM   #11
raska
Member
 
Registered: Aug 2004
Location: Aguascalientes, AGS. Mexico.
Distribution: Slackware 13.0 kernel 2.6.29.6
Posts: 816

Rep: Reputation: 30
here's my entry from the /etc/fstab file, might help you as well. You won't lose anything by trying, will you?

Code:
/dev/sda1        /mnt/flash       vfat        noauto,user,rw,umask=0     0   0
 
Old 12-27-2005, 03:20 PM   #12
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,123

Rep: Reputation: 162Reputation: 162
Can I ask what you're typing from the command line as a normal user? It should be just `mount /mnt/mp3`. Don't put anything else because if you do, mount won't use the info in /etc/fstab it will use just your command line and you won't have permission because you're not root.
 
Old 12-27-2005, 05:23 PM   #13
raska
Member
 
Registered: Aug 2004
Location: Aguascalientes, AGS. Mexico.
Distribution: Slackware 13.0 kernel 2.6.29.6
Posts: 816

Rep: Reputation: 30
Quote:
Originally Posted by gilead
Can I ask what you're typing from the command line as a normal user? It should be just `mount /mnt/mp3`...
yes, it's something like that; logically it just type
Code:
mount /mnt/flash/
as that's my folder. It works like a charm so it should work with you too
 
Old 01-01-2006, 09:09 AM   #14
killahsmurf
Member
 
Registered: Mar 2005
Distribution: Slackware
Posts: 50

Original Poster
Rep: Reputation: 15
quite simply, thanks guys, everything worked out. i never knew you could mount with just using the mount dir. so. im normal again. till next time fellas
 
Old 01-04-2006, 12:53 PM   #15
raska
Member
 
Registered: Aug 2004
Location: Aguascalientes, AGS. Mexico.
Distribution: Slackware 13.0 kernel 2.6.29.6
Posts: 816

Rep: Reputation: 30
it is good to know that became solved
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
gui file copy progress indicator? zero79 Linux - Software 3 07-10-2005 03:00 AM
CLI copy & paste between text files? David the H. Linux - General 3 09-15-2004 01:05 PM
how to copy and paste acd copy cd paschim Linux - General 2 04-05-2004 10:25 AM
How can I copy a directory and it's contents with CLI? CyberLord_7 Linux - General 2 03-30-2004 12:35 PM
boot error after using Copy Commander to copy debian system onto larger new drive Interceptor Linux - Hardware 7 05-04-2003 01:40 PM


All times are GMT -5. The time now is 03:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration