LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 04-21-2012, 12:22 AM   #1
BoydRice
Member
 
Registered: Jul 2008
Location: Tacoma, WA
Distribution: Slackware64
Posts: 95

Rep: Reputation: 19
Clementine - compilation error on Slackware64 -current


Hi,

I am trying to compile Clementine on Slackware64 -current. I built the following packages as optional dependencies:

gst-plugins-bad
gst-plugins-ugly
usbmuxd
libtasn1

However the compilation of Clementine itself errors out with the following message:
Code:
Scanning dependencies of target echoprint
[ 10%] Building CXX object 3rdparty/echoprint-codegen/CMakeFiles/echoprint.dir/src/AudioBufferInput.o
In file included from /tmp/SBo/clementine-1.0.0/3rdparty/echoprint-codegen/src/AudioStreamInput.h:14:0,
                 from /tmp/SBo/clementine-1.0.0/3rdparty/echoprint-codegen/src/AudioBufferInput.h:14,
                 from /tmp/SBo/clementine-1.0.0/3rdparty/echoprint-codegen/src/AudioBufferInput.cxx:11:
/tmp/SBo/clementine-1.0.0/3rdparty/echoprint-codegen/src/File.h: In static member function 'static bool File::Exists(const char*)':
/tmp/SBo/clementine-1.0.0/3rdparty/echoprint-codegen/src/File.h:30:71: error: 'F_OK' was not declared in this scope
/tmp/SBo/clementine-1.0.0/3rdparty/echoprint-codegen/src/File.h:30:75: error: 'access' was not declared in this scope
make[2]: *** [3rdparty/echoprint-codegen/CMakeFiles/echoprint.dir/src/AudioBufferInput.o] Error 1
make[1]: *** [3rdparty/echoprint-codegen/CMakeFiles/echoprint.dir/all] Error 2
make: *** [all] Error 2
Would someone be able to help me understand what is wrong?
 
Old 04-21-2012, 12:56 AM   #2
kingbeowulf
Member
 
Registered: Oct 2003
Location: WA
Distribution: Slackware64 14.1, Slackware 14.1
Posts: 527

Rep: Reputation: 140Reputation: 140
See this: http://code.google.com/p/clementine-...ummary%20Stars

Since they are dropping echoprint-codegen, you may want to just grab clementine-1.0.1 or a the newer git snapshot.
 
1 members found this post helpful.
Old 04-21-2012, 12:14 PM   #3
BoydRice
Member
 
Registered: Jul 2008
Location: Tacoma, WA
Distribution: Slackware64
Posts: 95

Original Poster
Rep: Reputation: 19
Thanks that did the trick!
 
  


Reply

Tags
slackbuild


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
gdb error with slackware64-current chexmix Slackware 2 04-06-2012 02:49 AM
md5sum error in slackware64-current EdGr Slackware 3 04-01-2011 02:12 AM
[SOLVED] Samba 4 alpha14 compilation error on Slackware64-13.1 KamasCZ Slackware 2 01-28-2011 06:00 AM
F4L + Slackware64-Current = Error. Martinezio Slackware 2 11-23-2009 10:39 AM
slackware64-current : pulseaudio compilation fails, wrong version of libtool pokipoki08 Slackware 2 08-01-2009 12:59 AM


All times are GMT -5. The time now is 07:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration