LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-12-2013, 05:16 PM   #1
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Clementine


Anybody here intimate with Clementine?

I looked at Clementine as a possible replacement for Amarok. The new Amarok works for me but there a few configuration and usability issues I haven't resolved. And Amarok crashes about every third time I close the app.

I compiled Clementine 1.1. The first thing I noticed after launching was the app trying to download some kind of Magnatune catalog. With propriety software free/libre folks tend to scream and froth when apps do things like that or "phone home."

I don't mind that users want Magnatune support, but is there a way to disable that behavior?

I looked at other music players. XMMS is beyond me and looks like, well never mind. Audacious is a GTK app. I'm using KDE 4.10.1 and want a consistent look in my apps. Likewise with other music players at slackbuilds, such as Exaile.

I thought Clementine might replace Amarok 1.4, but I'm not fond of apps that are designed with the presumption that I need or want 24/7 connectivity. I'm not interested in cover art, fan art, lyrics, sharing, ratings, etc. I want a comfortable music player like Amarok 1.4.

I could block the Magnatune IP address.

I still have Amarok 1.4 and could continue using that app if painted into a corner. Yet I prefer to adapt to KDE4 as much as possible.

Can Clementine be tamed or compiled with certain build options or sledge hammer patching?

If Clementine can't be tamed then I'll keep using Amarok, both 1.4 and 2.7.

Just curious.

Thanks.
 
Old 03-12-2013, 08:05 PM   #2
SwiftTimber-Z80
LQ Newbie
 
Registered: Mar 2013
Posts: 20

Rep: Reputation: Disabled
Can you disable them through the preferences?

Under Internet providers "Magnatune"?

Last edited by SwiftTimber-Z80; 03-12-2013 at 08:06 PM.
 
Old 03-12-2013, 08:12 PM   #3
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,238

Rep: Reputation: 176Reputation: 176
Quote:
Originally Posted by SwiftTimber-Z80 View Post
Can you disable them through the preferences?

Under Internet providers "Magnatune"?
I believe that is correct (but I've be wrong before. )

Last edited by cwizardone; 03-12-2013 at 08:14 PM.
 
Old 03-12-2013, 09:01 PM   #4
beder
Member
 
Registered: Apr 2011
Posts: 82

Rep: Reputation: 28
Been using Clementine since Amarok became a bloatware (in my humble opinion), even on my Windows machines at work.
I'm not sure about your concerns for internet connectivity: AFAIK it only tries to use the internet if you actually select an option that requires it - like song info, lyrics, fill in tags automagically, radio stations... If you don't click those buttons it won't do anything.
 
Old 03-12-2013, 10:44 PM   #5
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Original Poster
Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Hmm. Okay, I'll hunt some more and try again. In the mean time, is there a way to replicate the Amarok 1.4 Playlist browser pane? I'm a very basic user. In Amarok 1.4 I selected the Playlists tab in the browser pane and pretty much never change that. In that pane I added my playlists, some in folders by artist. Simple. No library or nothing complicated.

I can do that in Amarok 2.7 but when I restart the app the folders disappear and the playlists revert to one long flat list. I haven't figured out whether the behavior is a bug or PEBKAC.

Is there a way to disable tabs in Clementine? I'm rather linear and play one playlist at a time. The tabs confuse me.

Also, I haven't found anything to import my Amarok 1.4 database into Clementine. I've been trying to get this script to work but no success yet. According to the blog comments, 1.4 is not supported and somebody with mysql skills needs to massage the script. Odd that Clementine is touted as a successor to Amarok 1.4 and there is no built-in import/conversion feature.
 
Old 03-12-2013, 11:04 PM   #6
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Original Poster
Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Okay. Looks the original problem is the search engines all are enabled. Disabling them all seems to stop the startup behavior. Still haven't a clue about the other problems.
 
Old 03-13-2013, 08:40 AM   #7
beder
Member
 
Registered: Apr 2011
Posts: 82

Rep: Reputation: 28
Quote:
Originally Posted by Woodsman View Post
is there a way to replicate the Amarok 1.4 Playlist browser pane?
I came up with the following:
1. Create a new playlist (Playlist -> New Playlist);
2. Fill it in with the songs you want from your Library;
3. Save your playlists in a specific folder (Playlist -> Save Playlist);
4. On Clementine select the "Files" pane in the left;
5. Navigate to the folder where your playlists are;

For example, I created two playlists and saved them in a specific folder (on a Windows machine at work, but same will apply for Linux). See how it looks in the attached image.

Off course that if you already have some playlists you just paste/move them to that same folder
Attached Images
File Type: jpg screen.jpg (32.0 KB, 33 views)

Last edited by beder; 03-13-2013 at 08:46 AM.
 
Old 03-13-2013, 04:51 PM   #8
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Original Poster
Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
That method works --- sort of.

Unlike Amarok 1.4, the list does not use a tree view. Thus accessing a folder requires fully opening the folder (double-clicking) rather than just viewing the folder by selecting a tree view expansion widget. Not a killer but not smooth either.

Second, that method includes the file name extension. Kind of clunky to view.

As I already mentioned I can't import my Amarok 1.4 database. I've run into some other bugs too. When I open a playlist Clementine will not display anything in the Artist column. Works fine in Amarok 1.4 and 2.7. I don't know whether the problem is Clementine or faulty tags in the music files. Is there a way to test?

I have a collection of online radio stream URLs. Clementine refuses to play one of the streams yet both Amaroks and Streamripper have no problem with the URL.
 
Old 03-13-2013, 05:24 PM   #9
beder
Member
 
Registered: Apr 2011
Posts: 82

Rep: Reputation: 28
Quote:
Originally Posted by Woodsman View Post
As I already mentioned I can't import my Amarok 1.4 database
Sorry, can't help you on that

Quote:
Originally Posted by Woodsman View Post
I don't know whether the problem is Clementine or faulty tags in the music files. Is there a way to test?
"Alt+e" when the song(s) is selected will open its tags (or right click and there will be an option as well), so you can check if the "artist" is filled.
Maybe Amarok tries to guess the artist based on the file name or the folder on which the file is in, but Clementine trusts the tags only

You can correct the tags manually or by using the option to find tags automatically. I'm not sure if it works for multiple files at once or if you'd have to do it one by one.
If Clementine can't do several files at once, try Picard

Also worth noting, you can edit the tags of multiple songs at once, so you can for example select all songs of a given artist and edit it. But then the song name might be missing, so I think auto fill is still the best and more accurate (but maybe not faster) approach

Quote:
Originally Posted by Woodsman View Post
Clementine refuses to play one of the streams yet both Amaroks and Streamripper have no problem with the URL.
Don't know much about it, but maybe it could be a plugin or codec issue; any significant error message that you can try to search for?
 
Old 03-13-2013, 06:28 PM   #10
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Original Poster
Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Ah, yeah, I should have thought about just looking at the files --- Amarok 1.4 does that too. Sheesh!

Anyway, inspecting the tags that way indicates the tags are sane and the Artist is listed. I checked several songs.

I haven't tried to troubleshoot the streaming problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to get Clementine working with lirc alex_65bg Linux - Newbie 4 02-05-2014 10:21 AM
[SOLVED] Clementine Slackbuild bogzab Slackware 6 11-22-2012 07:10 PM
clementine [ SlackBuild] inman Slackware 8 10-05-2012 11:48 AM
[SOLVED] Compiling Clementine Jdogzz Slackware 6 06-22-2012 01:46 AM
[SOLVED] Clementine can't play .m4p files asipper Linux - Software 0 11-21-2011 05:22 PM


All times are GMT -5. The time now is 03:04 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration