LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 04-05-2014, 05:43 PM   #16
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534

Does anybody have build scripts for Cinnamon 2.0?
 
Old 04-05-2014, 08:59 PM   #17
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,624

Rep: Reputation: 448Reputation: 448Reputation: 448Reputation: 448Reputation: 448
I tried to have a look last night and it seems some of it's dependencies (clutter) can't be installed since it requires newer glib than what we have in slackware 14.1.
Although it's easy to upgrade glib using Pat's Slackbuild, there might be side effects and many packages would need to be rebuilt, so i didn't continue looking at it, not until next Slackware releases at least
 
Old 04-05-2014, 09:35 PM   #18
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
So we wait until glib is updated in Current.

My understanding is Cinnamon 2.0 no longer is strictly tied to GNOME 3.
 
Old 04-05-2014, 10:34 PM   #19
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,624

Rep: Reputation: 448Reputation: 448Reputation: 448Reputation: 448Reputation: 448
I tried to start building packages for cinnamon, but probably using an older version of clutter
Hope to publish the slackbuilds soon if it works for me
 
Old 04-06-2014, 12:18 PM   #20
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,624

Rep: Reputation: 448Reputation: 448Reputation: 448Reputation: 448Reputation: 448
i think i'm stuck with cinnamon-settings-daemon which requires colord and turns out, it requires systemd
the cinnamon desktop won't start properly without cinnamon-settings-daemon
 
Old 04-06-2014, 12:41 PM   #21
saxa
Member
 
Registered: Aug 2004
Posts: 301

Rep: Reputation: 18
I do not remember properly, but I think colord doesnt have a hard dep systemd, in any case you have 2 options, use an older colord, or use Barts systemd packages. Another alternative can be to use or look at the scripts we use to build colord in droplinegnome.
 
Old 04-06-2014, 12:45 PM   #22
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,624

Rep: Reputation: 448Reputation: 448Reputation: 448Reputation: 448Reputation: 448
Well, now it does, so yeah, i think i will try to use older version
 
Old 04-06-2014, 12:47 PM   #23
saxa
Member
 
Registered: Aug 2004
Posts: 301

Rep: Reputation: 18
I do remember something we had to do in the past, so I think we switched back to something like 0.0.26 version before the 1.0.0 , don't take my numbers as 100% correct.
 
Old 04-06-2014, 01:04 PM   #24
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,624

Rep: Reputation: 448Reputation: 448Reputation: 448Reputation: 448Reputation: 448
yes, 0.1.26 is the latest one that doesn't depend on systemd
i got colord built now, continuing with cinnamon-settings-daemon
 
Old 04-06-2014, 01:19 PM   #25
saxa
Member
 
Registered: Aug 2004
Posts: 301

Rep: Reputation: 18
Great, you are right, the version is 0.1.26. Good luck.
 
Old 04-06-2014, 08:43 PM   #26
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,624

Rep: Reputation: 448Reputation: 448Reputation: 448Reputation: 448Reputation: 448
OK, managed to install cinnamon, but when i logged in, it's blank (black screen), but the DE is loaded
still have to do more debugging
 
Old 04-06-2014, 09:09 PM   #27
saxa
Member
 
Registered: Aug 2004
Posts: 301

Rep: Reputation: 18
Try to set your language to UTF-8 in /etc/profile.d/lang.sh
 
Old 04-06-2014, 09:49 PM   #28
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,624

Rep: Reputation: 448Reputation: 448Reputation: 448Reputation: 448Reputation: 448
nope, didn't help
 
Old 04-06-2014, 10:00 PM   #29
saxa
Member
 
Registered: Aug 2004
Posts: 301

Rep: Reputation: 18
try to start X with startx > mylog.txt 2>&1 maybe it gives you a hint of why is not loading it until the end.
 
Old 04-06-2014, 10:29 PM   #30
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,624

Rep: Reputation: 448Reputation: 448Reputation: 448Reputation: 448Reputation: 448
I think it's because of this
Code:
(cinnamon-settings-daemon:54654): color-plugin-WARNING **: failed to get edid: unable to get EDID for output

(cinnamon-settings-daemon:54654): color-plugin-WARNING **: unable to get EDID for xrandr-Virtual1: unable to get EDID for output
Traceback (most recent call last):
  File "/usr/bin/cinnamon-launcher", line 8, in <module>
    from gi.repository import Gtk
ImportError: No module named gi.repository
I think this should be satisfied by pygtk, but eventually not
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cinnamon problem abd_bela Linux Mint 1 12-23-2012 03:07 PM
Cinnamon problems linuxPCplus Linux - Software 0 11-28-2012 02:44 PM
[SOLVED] Cinnamon or MATE? turboscrew Linux - Desktop 4 09-29-2012 01:39 PM
LXer: Cinnamon 1.6 Will Bring Cinnamon 2D LXer Syndicated Linux News 0 09-05-2012 01:10 AM
cinnamon 1.4 Workspaces eabel Linux - Software 2 05-06-2012 01:04 PM


All times are GMT -5. The time now is 03:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration