LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Cineralla, Avidemux, & Inkscape Install problems (http://www.linuxquestions.org/questions/slackware-14/cineralla-avidemux-and-inkscape-install-problems-4175486205/)

Bertman123 11-28-2013 08:56 PM

Cineralla, Avidemux, & Inkscape Install problems
 
I'm trying to install the above programs and am running into problems.

I tried using the packages in AlienBob's repositories (to install avidemux) and installed all of the dependencies from his website. After then installing avidemux and clicking on the program from the menu nothing happens.

I then tried installing cineralla & avidemux from sbopkg I got the following errors:

No package 'libavcodec' found
No package 'libpostproc' found
No package 'libavutil' found

I then tried installing inkscape I get the following error:

configure: error: libgc (the Boehm Conservative Collector) 6.4+, is needed to compile inkscape -- http://www.hpl.hp.com/personal/Hans_Boehm/gc

I'm looking to learn about video & photo editing and am looking to play around with them and learn their ins and outs.

Is there something that I'm missing?

I'm running slackware 14.0 32 bit.

willysr 11-28-2013 10:29 PM

you need ffmpeg installed :)

Bertman123 11-29-2013 08:47 AM

Quote:

Originally Posted by willysr (Post 5072229)
you need ffmpeg installed :)

I did that and still had issues with avidemux installing. I installed all of the optional dependencies for avidemux in sbopkg and was then able to install it and it seems to be working at the moment.

For Cinelerra it looks like I need quicktime?

make[3]: Leaving directory `/tmp/SBo/cinelerra/quicktime'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/tmp/SBo/cinelerra/quicktime'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/SBo/cinelerra'
make: *** [all] Error 2


I installed libquicktime from the MLED repository, but it seems like that was not enough.

kikinovak 11-29-2013 09:22 AM

Hi Bertman123. This morning I started working on MLED 14.1. If you can wait a little bit, you'll soon have some ready-made packages to download.

Cheers,

Niki

ponce 11-29-2013 09:37 AM

Quote:

Originally Posted by Bertman123 (Post 5072218)
I then tried installing inkscape I get the following error:

configure: error: libgc (the Boehm Conservative Collector) 6.4+, is needed to compile inkscape -- http://www.hpl.hp.com/personal/Hans_Boehm/gc

gc is already included in Slackware so I suppose you're not running a full install: note that this setup is unsupported, also if you want to build stuff from SBo.

FYI cinelerra builds fine here, with or without libquicktime: try to paste the actual error using just one make job, should go in the lines above the ones you pasted.

bogzab 11-29-2013 10:00 AM

Quote:

Originally Posted by Bertman123 (Post 5072218)
I'm trying to install the above programs and am running into problems.

...
I then tried installing inkscape I get the following error:

configure: error: libgc (the Boehm Conservative Collector) 6.4+, is needed to compile inkscape -- http://www.hpl.hp.com/personal/Hans_Boehm/gc

...
I'm running slackware 14.0 32 bit.

I installed Inkscape last night using a slackbuilds.org build script with no problems under Slackware 14.1. I had it running under 14.0 as well and iirc that was also from a slackbuilds script.

Bertman123 11-29-2013 11:29 AM

Quote:

Originally Posted by kikinovak (Post 5072455)
Hi Bertman123. This morning I started working on MLED 14.1. If you can wait a little bit, you'll soon have some ready-made packages to download.

Cheers,

Niki

I'm not in any rush. :-) It looks like part of the problem was a PEBKAC error... :-p forgot to install part of the MLED 14.0 packages... I'll upgrade to 14.1 when MLED is ready for 14.1 and see how things are then.


Thanks for the help and input guys, I appreciate it.


All times are GMT -5. The time now is 04:14 PM.