LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Chromium doesn't run from KDE menu, but does from Command Line? (http://www.linuxquestions.org/questions/slackware-14/chromium-doesnt-run-from-kde-menu-but-does-from-command-line-4175481453/)

JamesGT 10-19-2013 10:15 PM

Chromium doesn't run from KDE menu, but does from Command Line?
 
I have Chromium installed on my Slackware64 14.0 system. When I try to run it through the KDE menu, it dies and won't start. When I run it from command line, it runs, although there is a string of errors in the terminal, it still runs.

How can I get it to run via the KDE menu and have it ignore the errors?

Errors:

Code:


[6:6:1019/221108:ERROR:base_feature_provider.cc(122)] manifestTypes: Allowing web_page contexts requires supplying a value for matches.
[8:8:1019/221108:ERROR:base_feature_provider.cc(122)] manifestTypes: Allowing web_page contexts requires supplying a value for matches.
[15:15:1019/221108:ERROR:base_feature_provider.cc(122)] manifestTypes: Allowing web_page contexts requires supplying a value for matches.
[12:12:1019/221108:ERROR:base_feature_provider.cc(122)] manifestTypes: Allowing web_page contexts requires supplying a value for matches.
[20:20:1019/221109:ERROR:base_feature_provider.cc(122)] manifestTypes: Allowing web_page contexts requires supplying a value for matches.
[25:25:1019/221109:ERROR:base_feature_provider.cc(122)] manifestTypes: Allowing web_page contexts requires supplying a value for matches.
[31:31:1019/221109:ERROR:base_feature_provider.cc(122)] manifestTypes: Allowing web_page contexts requires supplying a value for matches.
[3248:3311:1019/221109:ERROR:base_feature_provider.cc(122)] manifestTypes: Allowing web_page contexts requires supplying a value for matches.
[39:39:1019/221109:ERROR:base_feature_provider.cc(122)] manifestTypes: Allowing web_page contexts requires supplying a value for matches.
[43:43:1019/221109:ERROR:base_feature_provider.cc(122)] manifestTypes: Allowing web_page contexts requires supplying a value for matches.
[53:53:1019/221109:ERROR:base_feature_provider.cc(122)] manifestTypes: Allowing web_page contexts requires supplying a value for matches.
[49:49:1019/221109:ERROR:base_feature_provider.cc(122)] manifestTypes: Allowing web_page contexts requires supplying a value for matches.
[60:60:1019/221109:ERROR:base_feature_provider.cc(122)] manifestTypes: Allowing web_page contexts requires supplying a value for matches.
[3248:3248:1019/221111:ERROR:profile_sync_service.cc(1221)] History Delete Directives datatype error was encountered: Delete directives not supported with encryption.
[3248:3311:1019/221117:ERROR:audio_manager_base.cc(422)] Not implemented reached in virtual std::string media::AudioManagerBase::GetDefaultOutputDeviceID()
[84:84:1019/221117:ERROR:base_feature_provider.cc(122)] manifestTypes: Allowing web_page contexts requires supplying a value for matches.
[3248:3304:1019/221118:ERROR:audio_manager_base.cc(422)] Not implemented reached in virtual std::string media::AudioManagerBase::GetDefaultOutputDeviceID()
[96:96:1019/221135:ERROR:base_feature_provider.cc(122)] manifestTypes: Allowing web_page contexts requires supplying a value for matches.
[3248:3306:1019/221144:ERROR:object_proxy.cc(539)] Failed to call method: org.kde.KWallet.open: object_path= /modules/kwalletd: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
[3248:3306:1019/221144:ERROR:native_backend_kwallet_x.cc(838)] Error contacting kwalletd (open)
[3248:3344:1019/221144:ERROR:download.cc(253)] PostClientToServerMessage() failed during GetUpdates
[101:101:1019/221246:ERROR:base_feature_provider.cc(122)] manifestTypes: Allowing web_page contexts requires supplying a value for matches.

They've always been there, but I haven't had any problems or issues with the browser. I'd just like to not have a terminal open just to run the browser if I don't have to.

jamison20000e 10-19-2013 10:55 PM

can you run it from [Alt]+[F2] ?

ruario 10-20-2013 01:58 AM

What exactly does the desktop file execute. Is it the same as what you write in Konsole to run it?

jamison20000e 10-20-2013 08:29 AM

I would say right click on the file or go through menu editor to see the icons properties and what command it launches but I don't know how in KDE maybe you can drag the icon to desktop or panel?

JamesGT 10-25-2013 08:47 PM

In the KDE "icon" it had the same line "/chromium/chrome-linux/chrome-wrapper" but it would not run. It gave an error about SUID-Sandbox, but I solved that with the command line. When I run from command line, I don't need to add --no-sandbox, but from the KDE icon, I do. :/

I'm good with it though the way it is. Running without the sandbox didn't change anything.

I want Maxthon to come out with their linux browser so I can switch.

Thank you!

jamison20000e 10-25-2013 10:16 PM

Have you tried Firefox? http://www.linuxquestions.org/questi...ml#post5042929

JamesGT 11-28-2013 06:37 PM

Quote:

Originally Posted by jamison20000e (Post 5052518)


No, I don't like Firefox.

Currently using Maxthon...still in Alpha, but it's basically a Chromium skin right now.

jamison20000e 11-28-2013 10:50 PM

I see this is [SOLVED] now but if you can open Chromium from CLI should be able to make your own link. :)

Alien Bob 11-29-2013 03:44 AM

When you upgrade your Slackware to 14.1, youcan then install my Chromium package: http://slackware.com/~alien/slackbuilds/chromium/

It has the Chrome Native Client built-in, the sandbox works, and Google sync too. And the menu icon works, of course.

Eric

JamesGT 11-30-2013 05:16 PM

I will definitely install your Chromium package when I upgrade.

Chromium is my second favourite browser right now, behind Maxthon.

jamison20000e 11-30-2013 05:44 PM

I trust FF. :D

darksaurian 12-04-2013 10:47 PM

I installed the slackbuild package, it works fine. But I didn't automatically get a chome icon in my KDE menus. :(


All times are GMT -5. The time now is 01:27 AM.