LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Chrome crashes kde (http://www.linuxquestions.org/questions/slackware-14/chrome-crashes-kde-4175459034/)

arubin 04-21-2013 04:37 PM

Chrome crashes kde
 
Every time I start chrome I crash out of my kde session.

This has been happening since I upgraded xorg with the new patches. I have tried going back to the old xorg but it still crashes. Any ideas?

Quote:

[ 60.689] (II) NVIDIA(GPU-0): Display (PKB Viseo 230Ws (DFP-0)) does not support NVIDIA 3D
[ 60.689] (II) NVIDIA(GPU-0): Vision stereo.
[ 60.689] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[ 60.689] (**) NVIDIA(0): device PKB Viseo 230Ws (DFP-0) (Using EDID frequencies has
[ 60.689] (**) NVIDIA(0): been enabled on all display devices.)
[ 68.419]
[ 68.419] Backtrace:
[ 68.419] 0: /usr/bin/X (xorg_backtrace+0x36) [0x55d526]
[ 68.419] 1: /usr/bin/X (0x400000+0x160ee9) [0x560ee9]
[ 68.419] 2: /lib64/libpthread.so.0 (0x7f46074a0000+0xf4e0) [0x7f46074af4e0]
[ 68.419]
[ 68.419] Segmentation fault at address (nil)
[ 68.419]
Fatal server error:
[ 68.419] Caught signal 11 (Segmentation fault). Server aborting
[ 68.419]
[ 68.419]
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 68.419] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 68.419]
[ 68.428] (II) evdev: Power Button: Close
[ 68.428] (II) UnloadModule: "evdev"
[ 68.438] (II) evdev: Power Button: Close
[ 68.438] (II) UnloadModule: "evdev"
[ 68.448] (II) evdev: Logitech USB Receiver: Close
[ 68.448] (II) UnloadModule: "evdev"
[ 68.458] (II) evdev: Logitech USB Receiver: Close
[ 68.458] (II) UnloadModule: "evdev"
[ 68.468] (II) evdev: Eee PC WMI hotkeys: Close
[ 68.468] (II) UnloadModule: "evdev"
[ 68.722] Server terminated with error (1). Closing log file.

arubin 04-21-2013 04:58 PM

I have upgraded chrome and it is working now.

arubin 04-21-2013 05:08 PM

I spoke to soon. Some web sites are crashing kde when using chrome.

arubin 04-21-2013 05:09 PM

This could be a javascript problem. At any rate I have disabled javascript and the crashing has stopped.

arubin 04-22-2013 06:31 AM

I think I have found the answer here

It seems that /usr/lib64/xorg/modules/extensions/libglx.so has been overwritten by the upgrade and I need to re-install the nvidia driver.

I'll post the result once I've had a chance to try it.

Curious that nobody else here has reported the same problem.

arubin 04-24-2013 12:56 PM

So I have re-installed the Nvidia drivers and all seems well.

The only odd thing is that when I log out of a kde session the screen goes black during the 30 second countdown whereas it used to be that the desktop was visible.


All times are GMT -5. The time now is 05:39 AM.