LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-15-2005, 02:13 AM   #1
Swift&Smart
Member
 
Registered: Jan 2003
Location: Hong Kong,China
Distribution: Slackware,OpenSUSE
Posts: 472

Rep: Reputation: 30
Chinese chracter support


Hello everyone. I have at least a question goes unresolved every week....I did search but with no luck.

It's all about displaying chinese chracter. I know that I have to copy some chinese font to the fonts folder in my gnome,I did. However, like many others user experienced, chinese character is not clear and some of them even couldn't display. Does anyone have a better solution?what I need is:[list=1][*]Clear character display[*]No more so-called "mahjong" character-->can't display character[/list=1]

Does anyone have any solution? Please feel free and drop me a line. Thanks.
 
Old 10-15-2005, 07:50 AM   #2
kaon
Member
 
Registered: Dec 2003
Location: Hong Kong SAR
Distribution: Slackware 9.1, 10.x, slackware-current
Posts: 186

Rep: Reputation: 30
Did you try search this forum?
There are several post discussing on this matter, you could refer to it for details.

In general, it can be summarized into 2 ways.
1) Rebuild freetype.
2) Use linux supported fonts.

Thanks.
 
Old 10-15-2005, 10:12 AM   #3
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Where do you want to see Chinese fonts? Which program?
I have trouble with Chinese input, but I see fonts in Firefox
and Thunderbird very well.

What type of graphics card do you have? What monitor?
 
Old 10-15-2005, 10:03 PM   #4
Swift&Smart
Member
 
Registered: Jan 2003
Location: Hong Kong,China
Distribution: Slackware,OpenSUSE
Posts: 472

Original Poster
Rep: Reputation: 30
chinaman,thanks for your input.

I have some trouble displaying chinese in Firefox. I downloaded the chinese font type, but it doesn't display very clear and complete. Some charcter can't even display!So, do you have:
[list=1][*]Font type which you think it is very good and clear to display[*]But it must include Traditional Big 5 & Simplied Chinese[/list=1]

Oh,I miss out something. My display card is a ATI Radeon 9500 or something...I can't really remember the whole name. Also, I have a 15' LCD monitor which can display with the dimension of 1024*768 pixels.

When I recall my memory, I have few problems when I was using Fedora Core or RedHat. Anyway, I just love Slackware now...
 
Old 10-15-2005, 10:34 PM   #5
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
I use the fonts from my Windows CD. I have these Chinese fonts,
which look good in Firefox:
mshei.ttf
msmincho.ttc
mssong.ttf
simhei.ttf
simsun.ttc
simsun.ttf
It is even more important to get good fonts for double byte, or
whatever they call Hanzi.

I guess you know how to change the font selection in Firefox,
since you are at least seeing fonts.

In China I have a 15" Philips 150B4 monitor. It will only display
to 1024x768, also. I have to recompile freetype with the bytecode
interpreter enabled with a Slackware system using these LCD
monitors, or the type is not good quality. There is a tutorial called
LCD Monitor Configuration In X.Org that one of our fellow LQ
members wrote. He also has some good threads here about fonts.
His nick is cathectic, so you can search in LQ for his posts.

There is one note. When you recompile freetype for Slackware,
you have to change the prefix. Freetype has a different path than
where Patrick Volkerding puts it. You will probably read this in a
tutorial.

If you prefer, I can give you a link where you can download a
Slackware package for Freetype2 and just install it using installpkg.

I think RedHat and Fedora already have the bytecode enterpreter
enabled. That would make the fonts look better on those systems.
 
Old 10-16-2005, 05:10 AM   #6
kaon
Member
 
Registered: Dec 2003
Location: Hong Kong SAR
Distribution: Slackware 9.1, 10.x, slackware-current
Posts: 186

Rep: Reputation: 30
Hi Chinaman,

How does bytecode interpreter affects the display of fonts on X?
Any pictures or snapshots that could point the difference out?

I am now using the stock X and freetype, and chinese display looks good to me up till now. Therefore, to keep my hands clean, compiling X and freetype is a last resort to myself.
And last point, if you don't have too much time to deal with this issue, better use some linux supported fonts, don't use Windows chinese fonts. Somehow I got the trouble in it and get myself frsutrated. (Chinese will be sliced into serveral parts that you could never imagine the 'shape' of the word)

Hope this helps.
 
Old 10-20-2005, 05:43 AM   #7
Swift&Smart
Member
 
Registered: Jan 2003
Location: Hong Kong,China
Distribution: Slackware,OpenSUSE
Posts: 472

Original Poster
Rep: Reputation: 30
Hi,kaon,Chinaman.Thanks for your reply.

I am wondering if you both can post your screenshots which displayed the webpage in browser with chinese characters. I just want to see is that the result what I am looking for.

Thanks.
 
Old 10-20-2005, 07:40 AM   #8
nnsg
Member
 
Registered: Apr 2004
Distribution: Slackware 9.1/10.1, Mandrake 9.1/10.1
Posts: 75

Rep: Reputation: 15
Hello,

I followed the following thread in LQ:

http://www.linuxquestions.org/questi...hreadid=291039

And this is the result:

http://www.flickr.com/photos/39433582@N00/54282904/

(Click on "all sizes" to see a large image)
 
Old 10-20-2005, 07:51 AM   #9
Swift&Smart
Member
 
Registered: Jan 2003
Location: Hong Kong,China
Distribution: Slackware,OpenSUSE
Posts: 472

Original Poster
Rep: Reputation: 30
nnsg , thanks a million!

That's the result which I want!!!I will follow the instruction tonight.

Again, I really appreciate your help.
 
Old 10-20-2005, 08:46 AM   #10
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
I used the same web address as nnsg.
This is the location of my screenshots:
https://www.cotse.net/users/servants...s/Chinese4.jpg
https://www.cotse.net/users/servants...s/Chinese5.jpg
One is traditional, the other is simplified characters.

Last edited by Bruce Hill; 10-20-2005 at 08:49 AM.
 
Old 10-20-2005, 12:43 PM   #11
kaon
Member
 
Registered: Dec 2003
Location: Hong Kong SAR
Distribution: Slackware 9.1, 10.x, slackware-current
Posts: 186

Rep: Reputation: 30
Woo.. this rocks! Try this on if you cannot find linux-supported fonts:

Quoted from http://www.linuxquestions.org/questi...hreadid=291039

1. Set your dpi to 96x96 (posted by tuvok and egag)
2. Compile newest FreeType with TT_CONFIG_OPTION_BYTECODE_INTERPRETER (posted by coffeedrinker)
3. Install MS TrueType fonts (posted by coffeedrinker)
3. Set up fonts.conf (posted by coffeedrinker/cathetic)
4. Add settings to ~/.gtkrc and ~/.gtkrc-2.0 (posted by coffeedrinker)
5. If you have LCD Display - set the proper subpixel hinting options (posted by cathetic)

I tried several times on improving chinese support on my linux box using patches made by firefly (fonts, x , settings in local.conf/fonts.conf and pango) in early 2005 but no success (all chinese character are broken as if they were cut into irregular parts). Therefore, just to make myself clean, I grab some linux-supported fonts and let it go. So far so good.

But now I have to say the first 3 steps rocks! (setting dpi to 96 barely won't improve any, at least for myself, you have installed a self compiled freetype along with. After that, you will see a noticable difference!)

Stay tuned everyone!

P.S. not yet deal with the last 3 steps due to timing constraints.
P.S. 2. Configuring local.conf/fonts.conf can be tedious, reading its man pages (?, anyone could point out where can I reference to, I forgot already) could kill myself right away.
 
Old 10-21-2005, 09:11 AM   #12
Swift&Smart
Member
 
Registered: Jan 2003
Location: Hong Kong,China
Distribution: Slackware,OpenSUSE
Posts: 472

Original Poster
Rep: Reputation: 30
It's fine by now

Thanks,everyone.Here's my result:

http://www.flickr.com/photo_zoom.gne?id=54576160&size=o

As you can see,now the chinese fonts is okay. But the system "English font" is not satisfied. I have to find out what cause that.
 
Old 10-21-2005, 09:18 AM   #13
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Have you recompiled Freetype2 with the bytecode_enterpreter enabled?
Those fonts look like what I got until I did that, and followed cathectic's
tutorial.

I have never yet had fonts display as well in KDE or Gnome or any of the
desktop environments as I get in Fluxbox. KDE, for one, is quite buggy
and changes system settings without you knowing what it did. Remember
that you have a LCD monitor, which has different needs than a CRT.

When you recompile freetype, it must have the correct path set in the
./configure step. You should have this in your Slackware system:
Code:
bruce@silas:/tmp$ whereis freetype2
freetype2: /usr/include/freetype2
bruce@silas:/tmp$ whereis freetype 
freetype: /usr/include/freetype
If you have your recompiled freetype in another directory, it will not
work properly.

Just one suggestion...follow the tutorial I linked for you, and setup
everything he mentioned.

Last edited by Bruce Hill; 10-21-2005 at 09:19 AM.
 
Old 10-21-2005, 09:24 AM   #14
Swift&Smart
Member
 
Registered: Jan 2003
Location: Hong Kong,China
Distribution: Slackware,OpenSUSE
Posts: 472

Original Poster
Rep: Reputation: 30
Thanks for your quick reply,Chinaman.

I install the freetype package from linuxpackages. So actually, I did not "compile" it. But I did follow the thread to make amendment on fonts.conf.

Why I install the package?Because I like package than source file. Maybe if the situation does not change, I will compile it.

Chinaman, I did follow the instructions except the above freetype compilation.

Thanks a lot!
 
Old 10-21-2005, 09:27 AM   #15
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Issue those commands I gave you, and see where the LinuxPackages package is installed.
If it's in the wrong place, you're going to be using the same package you had before. And
if that is so, I'll give you a link (I offered earlier) to a properly compiled Freetype2 Slackware
package that you can install.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
chinese font support lik Linux From Scratch 3 12-06-2005 12:48 PM
linux chinese support psa Linux - Newbie 5 02-14-2005 01:15 AM
KDE doesn't support Chinese well cawwt Slackware 2 09-06-2004 02:08 AM
not support chinese ust Linux - Software 1 08-17-2004 12:07 PM
Chinese support for slackware 9.1 roy_tan711 Slackware 5 12-17-2003 11:33 PM


All times are GMT -5. The time now is 02:09 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration