LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-08-2005, 02:55 PM   #1
RockmanExe
Member
 
Registered: Aug 2003
Distribution: Mandriva, Slackware
Posts: 265

Rep: Reputation: 30
Change default language Slackware 10.2


Hello there:

I just installed Slackware on an slow machine and so far so good, the performance is acceptable; however as you may know, Slackware comes with english as the default language.
While i have Slack myself on my home computer, i don't care about this setting, the owner of the slow computer, on the other hand, really need it to be in Spanish, (by that i mean spanish menus, dropdown menus, dialog windows...)

I've tried KDE's regional and language settings, but the drop down list of languages is empty... do i need to download or configure something? i did a full install, including KDE International support.

Hope someone can help

Regards
 
Old 11-08-2005, 04:21 PM   #2
cathectic
Member
 
Registered: Sep 2004
Location: UK, Europe
Distribution: Slackware64
Posts: 761

Rep: Reputation: 34
For KDE, make sure that kde-i18n-es-3.4.2-noarch-1 is installed and non-empty (assuming you are running 10.2 with KDE 3.4.2 - adjust accordingly)
Code:
less /var/log/packages/kde-i18n-es-3.4.2-noarch-1"
If this command produces nothing, then the kde-i8n-es package is not installed properly - try reinstalling it. If it displays the details and installed files for the package, then perhaps something else is at fault? (I'm not aware of what might cause such a problem though).

You should also edit /etc/profile.d/lang.sh to change the default language for non-KDE programs.
Code:
locale -a | egrep "es"
will give you a list of all available Spanish locales (e.g. es_ES for Spain, etc) - edit "export LANG=" in /etc/profile.d/lang.sh accordingly.
 
Old 11-08-2005, 08:39 PM   #3
RockmanExe
Member
 
Registered: Aug 2003
Distribution: Mandriva, Slackware
Posts: 265

Original Poster
Rep: Reputation: 30
Thanks for your response, i'll check it out
 
Old 11-10-2005, 07:51 PM   #4
RockmanExe
Member
 
Registered: Aug 2003
Distribution: Mandriva, Slackware
Posts: 265

Original Poster
Rep: Reputation: 30
It worked!! only on kde though, i wish there would be a way to install Slackware in diferent languages, and i mean the whole distro, not only kde

Thank you
 
Old 11-10-2005, 09:48 PM   #5
cathectic
Member
 
Registered: Sep 2004
Location: UK, Europe
Distribution: Slackware64
Posts: 761

Rep: Reputation: 34
Quote:
It worked
Can you please elaborate for future users of this forum - what fixed your problem (i.e. was it a case of the kde-i8n-es package not being installed properly)?

Quote:
i wish there would be a way to install Slackware in diferent languages
For some languages, other people have developed alternate language Slackware installers - I'm not certain if one exists for Spanish, but eSlack is probably your best bet to find one if it exists for Spanish.

However, given that Slackware is a one man project, we're not likely to see multiple language installers any time soon.

Last edited by cathectic; 11-10-2005 at 09:49 PM.
 
Old 11-10-2005, 10:21 PM   #6
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Just set this variables in this files:
- /etc/profile.d/lang.sh
Change export LANG=C (i don't remember if it was C...) to export LANG=es_ES
- /etc/rc.d/rc.keymap
Change the loadkeys line so it loads: es.map
- /etc/X11/xorg.conf
Look for you keyboard section, add a line with: Option "XkbLayout" "es"

Changing the LANG variable will be the most significant change since it will make programs to read (if it exists) the spanish texts of the programs. The other changes are for the keyboard to accept spanish keys, like ραι, etc.
 
Old 11-11-2005, 09:31 AM   #7
RockmanExe
Member
 
Registered: Aug 2003
Distribution: Mandriva, Slackware
Posts: 265

Original Poster
Rep: Reputation: 30
Thanks for your replies!!

@cathectic: It worked as you suggested before, to install kde-i18n-es-3.4.2-noarch-1 solved the kde spanish problem, however, it's weird that even though i did a "full" install, this package wasn't installed, among many others

@gbonvehi: I'll try those settings later, and i'll reply back

Again, thank you
 
Old 11-11-2005, 12:01 PM   #8
cathectic
Member
 
Registered: Sep 2004
Location: UK, Europe
Distribution: Slackware64
Posts: 761

Rep: Reputation: 34
Quote:
i did a "full" install
/KDEI is not included in a full install unless you specify it (probably to save hard drive space, or just to make you think about which languages you want installed).
 
Old 11-11-2005, 01:50 PM   #9
RockmanExe
Member
 
Registered: Aug 2003
Distribution: Mandriva, Slackware
Posts: 265

Original Poster
Rep: Reputation: 30
Alright, i did what gbonvehi suggested about editing lang.sh script and it worked like a charm!

I'm learning new things everyday, always on the move...

regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 10.2: How do I change default font for shell? PastorFrederick Linux - Newbie 6 10-17-2005 10:10 PM
Changing the default language... njschroe Suse/Novell 5 04-24-2005 01:44 PM
How to use another language as default? anindyanuri Fedora 6 03-19-2005 01:15 PM
how to change the default language of the system icoming Linux - General 8 06-01-2004 01:06 PM
under kde3 i change change language, where in gnome? sirpelidor Mandriva 1 12-10-2003 04:39 PM


All times are GMT -5. The time now is 10:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration