LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-04-2004, 11:15 AM   #1
fusi0n_1911
LQ Newbie
 
Registered: Sep 2003
Location: Florida
Distribution: Slackware 9.0
Posts: 14

Rep: Reputation: 0
Change CDROM to DMA Mode?


Hey guys, just a quick on this time. Installed Xine last night and it is running a little laggy. I suspect that it is because my DVD drive is in PIO mode as opposed to DMA. Is there anyway i can see what the DVD drive is running in? and if so, how can i change it to DMA?
Cheers

(PS I manually set it to DMA in the BIOS last night)
 
Old 02-04-2004, 11:45 AM   #2
mesperidiao
LQ Newbie
 
Registered: Oct 2003
Distribution: Slackware
Posts: 14

Rep: Reputation: 0
Have you tryied "hdparm"?
Take a look at man hdparm to see all the options, but I think you'll need the -d option.

Marcelo
 
Old 02-04-2004, 11:57 AM   #3
fusi0n_1911
LQ Newbie
 
Registered: Sep 2003
Location: Florida
Distribution: Slackware 9.0
Posts: 14

Original Poster
Rep: Reputation: 0
Ok I tried what you said , and it seems like the right command but this is what i get when i try to enable DMA:

bash-2.05b# hdparm -d 1 /dev/cdrom

/dev/cdrom:
setting using_dma to 1 (on)
HDIO_SET_DMA failed: Operation not permitted
using_dma = 0 (off)

any ideas?
 
Old 02-04-2004, 12:06 PM   #4
mesperidiao
LQ Newbie
 
Registered: Oct 2003
Distribution: Slackware
Posts: 14

Rep: Reputation: 0
mmm
maybe this is paranoia, but was your disk not mounted?
maybe being even more paranoic, try /dev/hdc (or hdb, or hdd) instead of /dev/cdrom

Marcelo
 
Old 02-04-2004, 12:09 PM   #5
fusi0n_1911
LQ Newbie
 
Registered: Sep 2003
Location: Florida
Distribution: Slackware 9.0
Posts: 14

Original Poster
Rep: Reputation: 0
I tried it both with the drive mounted and unmounted, and also tried hdc along with cdrom .. still get the same error

EDIT: Actually looking at my HD that is not using DMA mode either . I fear i may have to recompile the kernel? I recently upgrade to 2.6.1

Last edited by fusi0n_1911; 02-04-2004 at 12:14 PM.
 
Old 02-19-2004, 09:59 AM   #6
mesperidiao
LQ Newbie
 
Registered: Oct 2003
Distribution: Slackware
Posts: 14

Rep: Reputation: 0
Hey, did you manage to get that working? I recently hat to turn my DMA on too, and I had to recompile my kernel, to include the proper module for my ide chip. It now works ok. ;P
Sorry 'bout taking soo long to really help...

Marcelo
 
Old 02-21-2004, 11:49 AM   #7
fusi0n_1911
LQ Newbie
 
Registered: Sep 2003
Location: Florida
Distribution: Slackware 9.0
Posts: 14

Original Poster
Rep: Reputation: 0
lol it's cool. And yeah i ended up recompiling the kernel and adding the correct module and now it all runs fine. Only prob is, is that say i reboot the computer i have to manually enable DMA mode. Is there somewhere i can add it so it automatically enables DMA on boot?
 
Old 02-21-2004, 01:10 PM   #8
jong357
Senior Member
 
Registered: May 2003
Location: Columbus, OH
Distribution: DIYSlackware
Posts: 1,914

Rep: Reputation: 52
Theres no space between the d and 1 but I'm sure that was just a typo... Put this into /etc/rc.d/rc.local

/usr/sbin/hdparm -d1 /dev/hdc

I think thats the correct path. I'm at work in windass right now... I also optimize hda in rc.local as well.... try something like this

/usr/sbin/hdparm -d1 -A1 -m16 -u1 -a64 -c1 -X69 /dev/hda

Theres a -k1 switch that will keep the settings on a soft reboot but if you completely shut it down, you'll lose it...
run

hdparm -Tt /dev/hda

before and after setting that.. It's amazing the increase in transfer rates you can pull out of your hard drive... All newer hard drives can cope with that setting. The X switch sets udma to 5... Thats all my drive can handle. Play around with it and see what settings are best for your hardware. Its suggested to mess with it in init1 but I always do it from X.... Up to you..

Jon

Last edited by jong357; 02-21-2004 at 01:12 PM.
 
Old 02-23-2004, 12:32 PM   #9
fusi0n_1911
LQ Newbie
 
Registered: Sep 2003
Location: Florida
Distribution: Slackware 9.0
Posts: 14

Original Poster
Rep: Reputation: 0
Cheers mate, will give what you said a go and see what I come up with.
 
Old 02-23-2004, 03:33 PM   #10
G-fahmah
LQ Newbie
 
Registered: Feb 2004
Location: Puerto Rico
Distribution: Slackware 9.1
Posts: 12

Rep: Reputation: 0
hi, just wondering where would i have to check to get my driver in the menuconfig part?
 
Old 02-28-2004, 11:15 AM   #11
jong357
Senior Member
 
Registered: May 2003
Location: Columbus, OH
Distribution: DIYSlackware
Posts: 1,914

Rep: Reputation: 52
Device Drivers---> ATA/ATAPI/MFM/RLL support--->

Have to enable:

Generic PCI bus-master DMA support
and
Use PCI DMA by default when available

along with your specific chipset support....
 
Old 03-11-2004, 08:46 AM   #12
mothl
LQ Newbie
 
Registered: Mar 2004
Distribution: RedHat 8.0
Posts: 1

Rep: Reputation: 0
problem enabling dma mode for my dvd drive and cd burner

for my CD Bruner i tried

hdparm -d1 /dev/hdd

/dev/hdd:
setting using_dma to 1 (on)
HDIO_SET_DMA failed: Operation not permitted
using_dma = 0 (off)

furthermore i tried

hdparm -c1d1X66 /dev/hdd

-> the same result

the same thing happens when i try to enable dma for my dvd drive(which is hdb)

my hardisks both run in udma mode 5 (hda, hdc)

what am I doing wrong?
please help me!
because burning with 8x instead of 40x is not funny!
and watching dvds is not possible now!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DMA mode keeps resetting epod69 Ubuntu 1 08-19-2005 09:09 PM
How can I change display mode from character mode to graph mode wuzhong Linux - Hardware 1 08-08-2004 09:36 AM
canīt enable DMA-Mode why? Odan Linux - General 11 10-22-2003 06:45 AM
Suse 8.2 change my DMA setting on my DVD-R drive to off & IDE DMA MODE NOT SHOWING IT maximalred Linux - General 0 08-23-2003 04:58 AM
Ultra Dma Mode 5 the panther Linux - Hardware 3 08-09-2003 02:09 PM


All times are GMT -5. The time now is 09:29 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration