LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-17-2012, 04:56 PM   #1
WhiteyMcQ-Tip
Member
 
Registered: Feb 2012
Distribution: Slackware
Posts: 33

Rep: Reputation: Disabled
Chainloading with LILO | Adding Ubuntu Studio to Slackware & Windows Multiboot


So once again I'm having some trouble here..

I've edited lilo.conf as many ways as I can think of and only get syntax errors or no such directory errors.

Slack was on originally, then added 7 for work, now I have Studio installed on its own partition with GRUB
wrote to it.

I'm not sure if I'm adding the wrong things in the wrong sequence or what but every time Studio boots I have no functionality in mouse or keyboard controls.
 
Old 03-17-2012, 06:00 PM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,308

Rep: Reputation: Disabled
It always helps if you post actual helpful information that people can comment on.

Eric
 
Old 03-17-2012, 07:15 PM   #3
WhiteyMcQ-Tip
Member
 
Registered: Feb 2012
Distribution: Slackware
Posts: 33

Original Poster
Rep: Reputation: Disabled
Sorry about that, here is some information

lilo.conf exerpt

////////////////////////////////////////

# Ubuntu Studio Addition
image = /boot/vmlinuz-2.6.38-8-generic
label = U-Studio
loader = /boot/grub
read-only
# Windows bootable partition config begins
other = /dev/sda3
label = Windows
table = /dev/sda
# Windows bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/root
label = Linux

////////////////////////////
fstab exerpt
////////////////////////////

# Ubuntu Studio
/dev/sda5 / ext4 defaults 1 1
/dev/sda6 swap swap defaults 0 0
# Windows below
/dev/sda3 /ntfs ntfs-3g fmask=177,dmask=077 1 0
read-only
# Linux bootable partition config ends
 
Old 03-17-2012, 07:57 PM   #4
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 755

Rep: Reputation: 226Reputation: 226Reputation: 226
Quote:
Originally Posted by WhiteyMcQ-Tip View Post
# Ubuntu Studio Addition
image = /boot/vmlinuz-2.6.38-8-generic
label = U-Studio
loader = /boot/grub
read-only
Firstly image is not used with loader
Secondly to boot a system that has it's own boot loader (either a Linux system with it's own grub/lilo boot sector or Windows) you use this :-

other = /dev/partition-with-boot-sector
label = Whateveryoucallthis
table = /dev/thewholeharddisk

So for your particular setup you would have this :-

Code:
# Ubuntu Studio Addition
other = /dev/sda5
 label = U-Studio
 table = /dev/sda
# Windows bootable partition config begins
other = /dev/sda3
 label = Windows
 table = /dev/sda
# Windows bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz
 root = /dev/root
 label = Linux
 
1 members found this post helpful.
Old 03-17-2012, 11:11 PM   #5
WhiteyMcQ-Tip
Member
 
Registered: Feb 2012
Distribution: Slackware
Posts: 33

Original Poster
Rep: Reputation: Disabled
Here's a little more information :

Device Boot Start End Blocks Id System
/dev/sda1 2048 1048578047 524288000 83 Linux
/dev/sda2 1048578048 1384122367 167772160 83 Linux
/dev/sda3 1384122368 1698695167 157286400 7 HPFS/NTFS/exFAT
/dev/sda4 1698697214 1953523711 127413249 5 Extended
/dev/sda5 * 1698697216 1936916479 119109632 83 Linux
/dev/sda6 1936918528 1953523711 8302592 82 Linux swap

Thanks for the replies. I changed everything as wildwizard said and now when I update lilo i get "Fatal: Partition entry no found."
Also when lilo boots U-Studio I lose complete control over my mouse and keyboard, same now if I
try to boot the U-Studio install disc. (When I say lose control Num/Cap/ScrLk lights wont even work)
Not sure if drivers are not being loaded, also wondering if an "initrd" entry is necessary in lilo.conf?

Last edited by WhiteyMcQ-Tip; 03-17-2012 at 11:12 PM.
 
Old 03-18-2012, 04:48 AM   #6
Martinus2u
Member
 
Registered: Apr 2010
Distribution: Slackware
Posts: 345

Rep: Reputation: 56
Quote:
Originally Posted by WhiteyMcQ-Tip View Post
Thanks for the replies. I changed everything as wildwizard said
looks sane.

Quote:
Originally Posted by WhiteyMcQ-Tip View Post
and now when I update lilo i get "Fatal: Partition entry no found."
that's serious, as if the partition table was broken.

Quote:
Originally Posted by WhiteyMcQ-Tip View Post
Also when lilo boots U-Studio
How is that possible in the light of the fatal error from above?

Quote:
Originally Posted by WhiteyMcQ-Tip View Post
I lose complete control over my mouse and keyboard, same now if I
try to boot the U-Studio install disc. (When I say lose control Num/Cap/ScrLk lights wont even work)
I think you need to sort that issue first.

Quote:
Originally Posted by WhiteyMcQ-Tip View Post
Not sure if drivers are not being loaded, also wondering if an "initrd" entry is necessary in lilo.conf?
not for chain loading.
 
Old 03-18-2012, 04:12 PM   #7
WhiteyMcQ-Tip
Member
 
Registered: Feb 2012
Distribution: Slackware
Posts: 33

Original Poster
Rep: Reputation: Disabled
Could this be due to the fact both partitions are logical? If so how can I make lilo boot U-Studio using the logical root partition?
 
Old 03-19-2012, 08:33 AM   #8
WhiteyMcQ-Tip
Member
 
Registered: Feb 2012
Distribution: Slackware
Posts: 33

Original Poster
Rep: Reputation: Disabled
U-Studio is booting, or at least making it to the main login screen, there I have no input devices available.
I think it's due to the logical parition, and I've tried to use lilo -b with no luck also.
I receive "Fatal: partition entry not found", when updating lilo, and lilo skips the -b option as well.
 
Old 03-19-2012, 04:07 PM   #9
slac-in-the-box
Member
 
Registered: Mar 2010
Location: oregon
Distribution: slackware64-14.1
Posts: 160

Rep: Reputation: 26
I had the no text input at login prompt pest before, on my son's asus g73 to be precise... I was able to fix it by setting
Code:
vga=normal
in lilo.conf and rerunning lilo. (but it was finding my partitions, and not reporting errors)... in my lilo.conf, for my slackware image, it looks like
Code:
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/sda1
  label = slac-in-the-box
  read-only  # Partitions should be mounted read-only for checking
# Linux bootable partition config ends
do you have the "root = /path/to/root/partition" set in your lilo? Oh I see it. Try "root = /dev/sda5" instead of "root = /dev/root" in your lilo.conf.

Also, as far as I know, you don't have to set the bootable flag for the linux root partition; you are setting which partition it boots in lilo with the root = option, and the bootable flag is for windows...

And grub and lilo both do the same thing, so use one or the other, and you don't need any references to grub in your lilo.conf file...

Last edited by slac-in-the-box; 03-19-2012 at 04:21 PM. Reason: adding the "code" block and bit about grub
 
Old 03-19-2012, 04:20 PM   #10
WhiteyMcQ-Tip
Member
 
Registered: Feb 2012
Distribution: Slackware
Posts: 33

Original Poster
Rep: Reputation: Disabled
slac-in-the-box, this is what I have in my lilo.conf

However, I'm still getting the Fatal partition entry not found error.

# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/root
label = Linux
read-only # Partitions should be mounted read-only for checking
# Linux bootable partition config ends
# Linux bootable partition config begins
other = /dev/sda5
label = U-Studio
table = /dev/sda
read-only # Partitions should be mounted read-only for checking
# Linux bootable partition config ends
# Windows bootable partition config begins
other = /dev/sda3
label = Windows
table = /dev/sda
# Windows bootable partition config ends
 
Old 03-19-2012, 04:36 PM   #11
WhiteyMcQ-Tip
Member
 
Registered: Feb 2012
Distribution: Slackware
Posts: 33

Original Poster
Rep: Reputation: Disabled
When I use "root = /dev/sda5" and update lilo, I now receive a syntax error.
 
Old 03-19-2012, 04:40 PM   #12
slac-in-the-box
Member
 
Registered: Mar 2010
Location: oregon
Distribution: slackware64-14.1
Posts: 160

Rep: Reputation: 26
according to man page for lilo.conf:

Quote:
ALTERNATE SYSTEM (other=)
Used to load systems other than Linux. The `other = <device>' specifies the boot sector of an
alternate system contained on a device or disk partition
Since Ubuntu is still linux, I don't think you use the "other =" option for it. Save that for booting windows. Try making the Ubuntu image section just like the slackware one, just changing the relevant parts, so in your case it would be

image = /path/to/ububuntu/kernel/in/ubuntu/fs
root = /dev/sda5 # partition for ubuntu fs
label = U-Studio
read-only

I don't know if ubuntu puts there kerenels in /boot the way slackware does, but the "image =" is asking for the path to a linux kernel image... you might also need an initrd to load modules that that image needs at boottime...
 
1 members found this post helpful.
Old 03-19-2012, 04:46 PM   #13
slac-in-the-box
Member
 
Registered: Mar 2010
Location: oregon
Distribution: slackware64-14.1
Posts: 160

Rep: Reputation: 26
each linux image gets its own "root =" option. So you only want to use the "root = /dev/sda5" for your U-Studio config... but your slackware root should still be left the way it was, or specify your slackware partition explicitly, as "root=/dev/sd?" (is your slackware on /dev/sda1"?). In addition to paths to partitions, the "root =" option can can also take file system labels, or UUIDs.

Last edited by slac-in-the-box; 03-19-2012 at 04:47 PM.
 
Old 03-19-2012, 04:58 PM   #14
slac-in-the-box
Member
 
Registered: Mar 2010
Location: oregon
Distribution: slackware64-14.1
Posts: 160

Rep: Reputation: 26
So when I said Try "root = /dev/sda5" instead of "root = /dev/root" in your lilo.conf" I was wrong (well no harm trying)... but what I meant was try adding "root = /dev/sda5" to your U-Studio section. And then I noticed you were using the other=, and suggest that you don't use that for linux kernel. sry to not be more clear at first.
 
Old 03-19-2012, 05:02 PM   #15
WhiteyMcQ-Tip
Member
 
Registered: Feb 2012
Distribution: Slackware
Posts: 33

Original Poster
Rep: Reputation: Disabled
I understood you completely, I don't understand why my systems acting the way it is, now your method is throwing no errors.
I just have to reboot and try it out, I appreciate your time and help slac. =]

//Now when I boot I get an error reading Unexpected EOF//

Is there any other file I should have to edit other than lilo.conf?
Also as stated before does the logical parition make a difference when using lilo?

Last edited by WhiteyMcQ-Tip; 03-19-2012 at 05:10 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help with chainloading grub2 for a multiboot setup streams &dragonflies Linux - General 2 11-24-2010 03:47 PM
ubuntu studio 8.04, slackware 12 & Realtek 8201CL PHY spamhippy Ubuntu 0 05-13-2008 07:06 AM
Redhat & WIndows...another GRUB & MultiBoot Problme kooladi Red Hat 1 12-19-2005 06:17 AM


All times are GMT -5. The time now is 11:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration