LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-30-2003, 09:13 PM   #1
NewtoSlack
LQ Newbie
 
Registered: Sep 2003
Posts: 21

Rep: Reputation: 15
CDRW Drive mounts as write protected


on Slackware 9.1 when I mount my cd rewiter after logging in with the following command
mount -t auto /dev/cdrw /mnt/cdrw
I get the following message
"Device write protected - mounted as read only"

After this I can view files on my cdrw drive.

How can I mount the cdrw drive so that I can also burn cds?
 
Old 09-30-2003, 09:35 PM   #2
Wynd
Member
 
Registered: Jul 2001
Distribution: Slackware 12
Posts: 511

Rep: Reputation: 32
It mounts as write protected because if you're just viewing a CD, you're probably not gonna be writing anything to it, and in most cases you can't (normal CDs, CD-Rs, etc.). If you wanna burn stuff to a cd, unmount it and use a program like cdrecord to burn stuff onto it, the read-only part won't matter.
 
Old 09-30-2003, 10:46 PM   #3
NewtoSlack
LQ Newbie
 
Registered: Sep 2003
Posts: 21

Original Poster
Rep: Reputation: 15
Thanks for your reply. I installed k3b by compiling the source (k3b-0.9). I ran k3bsetup to configure k3b and then ran k3b. I got the following message.

"cdrdao 1.1.7 does not support ATAPI
The configured version of cdrdao does not support writing to ATAPI devices without SCSI emulation and there is at least one writer in your system not configured to use SCSI emulation.
Solution: The best and recommended solution is to enable ide-scsi (SCSI emulation) for all writer devices. This way you won't have any problems. Or you install (or select as the default) a more recent version of cdrdao.
No support for ATAPI with cdrdao
You will not be able to use all your reading devices as copy sources since there is at least one not configured to use SCSI emulation and your system does not support ATAPI with cdrdao.
Solution: The best and recommended solution is to enable ide-scsi (SCSI emulation) for all writer devices. This way you won't have any problems."

I believe other users have asked how to enable scsi emulation and the responses on this board have shown how to modify lilo.conf to enable scsi emulation. However I boot Slackware from a floppy, without LILO. In this situation how can I enable scsi emulation for my cd burner?
 
Old 10-01-2003, 05:32 AM   #4
thundersnows
Member
 
Registered: Jul 2003
Location: Jakarta
Distribution: Slackware, Fedora Core 2
Posts: 83

Rep: Reputation: 15
i've problem with this too.
as i know, you can activate it in rc.modules, find the section modprobe ide-scsi and uncomment it.
i haven't tried it since i wondering if i must use ide-scsi emulation ? what is the different between using atapi and ide-scsi ? which one is better ?
 
Old 10-03-2003, 12:35 AM   #5
Rodrin
Member
 
Registered: May 2003
Location: Upstate NY, U.S.
Distribution: Slackware
Posts: 247

Rep: Reputation: 31
You generally need to enable SCSI emulation to burn discs. There is no particular advantage or disadvantage to it other than this.

You can load the modules for ide-scsi from rc.modules only if you pass a flag to the kernel at boot time to prevent ATAPI drivers from being loaded for them. In fact, the default behavior for Slackware is to try to load the ide-scsi module, but it will fail if there are no available devices left with which to use it.

If you want to boot Linux from a boot floppy and still have ide-scsi work, you must do one of two things: You can compile a custom kernel that does not include ATAPI support for CD-ROMS and then load the ide-scsi module, or you can use lilo to boot from your boot floppy (this is possible; see the Boot Disk How-to for details), insert the appropriate append statements, and then load the ide-scsi module as before.
 
Old 10-03-2003, 01:05 AM   #6
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Milwaukee, WI
Distribution: Mint
Posts: 6,642

Rep: Reputation: 69
This is what I needed to do to get my CD-RW up and running the way I wanted. This list is more or less based on the (default) "Welcome to Slackware" Email from Patrick from the Slack v9.0 install. -- J.W.

1. Verify this line is in /etc/lilo.conf: append="hdc=ide-scsi"

2. Verify this line in /etc/rc.d/rc.modules is uncommented:
/sbin/modprobe ide-scsi

3. As root, run: cat /proc/scsi/scsi (the CD-RW should be listed)

4. Edit /etc/fstab, add this line:
/dev/scd0 /mnt/scd0 iso9660 noauto,users 0 0

5. Run the following as root:
mkdir /mnt/scd0
cd /dev
rm cdrom
ln -s /dev/scd0 /dev/cdrom
chmod 666 /dev/scd0

6. To allow all users to run commonly-used burner progs, consider running the following:
chmod u+s /usr/bin/cdrecord
chmod u+s /usr/bin/mkisofs
chmod u+s /usr/bin/cdparanoia
 
Old 10-03-2003, 09:21 PM   #7
thundersnows
Member
 
Registered: Jul 2003
Location: Jakarta
Distribution: Slackware, Fedora Core 2
Posts: 83

Rep: Reputation: 15
hi J.W.
thanks for the guide. btw can you explain to me about chmod u+s ?
i've been explained about chmod 666, which is permission code.
 
Old 10-03-2003, 11:27 PM   #8
Shade
Senior Member
 
Registered: Mar 2003
Location: Burke, VA
Distribution: RHEL, Slackware, Ubuntu, Fedora
Posts: 1,418
Blog Entries: 1

Rep: Reputation: 46
At your boot prompt from the Disk, append the line


hdX=ide-scsi

to your normal boot command, where hdX is the location of the drive -- mine is hdd.



And load the module ide-scsi with modprobe.

Then scsi emulation willbe enabled on that drive.

-Shade
 
Old 10-04-2003, 01:33 AM   #9
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Milwaukee, WI
Distribution: Mint
Posts: 6,642

Rep: Reputation: 69
chmod is a command that you can use to change permissions on a file. (Run either: 'man chmod' or 'info chmod' for complete details.) You can either add (+) or remove (-) privs, at either the user (u), group (g), or other (o) level. The usual privs are read (r), write (w), and execute (x), but there's also the 'setuid' (s) which (as I understand it) will allow a program to be run under the privs of the _file_ instead of under the privs of the _user_. Note that this only has meaning in the context of an executable file.

Thus, if root has done a "chmod u+s" on a given executable file (which technically belongs to root) then it would allow ordinary users to run that program with the file's permissions (ie, root) rather then the user's permissions. That is my understanding of it anyway. There are a lot of people here who know a lot more than I do, and I would defer to their greater knowledge. -- J.W.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
unmount write protected disk pradi_net Linux - Hardware 1 05-18-2004 02:48 PM
NTFS Write-Protected? MindFlayer Mandriva 12 05-04-2004 05:36 PM
remove write-protected file randomtask Linux - Newbie 5 04-22-2004 03:06 AM
mounted network share gets write-protected! Falafel Linux - Networking 1 10-23-2003 07:45 AM
HELP! Error from mount: drive is write-protected... won't mount writeable. system Linux - General 2 12-27-2001 09:08 PM


All times are GMT -5. The time now is 05:32 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration